KLRI
Contributor
Contributor

VMWare Workstation error "Waiting for connection"

Jump to solution

I have severe problems with some of my VMWare Workstation Pro virtual machines.

When I create a Virtual machine within the current installation/version of VMWare Workstation running on Ubuntu I can boot them without problems.

However when I try to boot a VM which have not been created with this version of VMWare I get the message "Waiting for connection".

My notebook is dual-boot. The problem occurs only when Ubuntu 16.04 LTS is running. When I boot Windows 10 Pro I can use with VM without any problems.

The VM is located on a NTFS drive. I can use this drive from Linux as well from Windows.

I tried also to make a OVF file from the VM and then import the VM into VMWare Workstation. The problem still exists.

It doesn matter which OS the VM is running. I have Windows and Linux VM's. Problem is the same.

Any idea what is wrong?

Cheers,

Karl

0 Kudos
1 Solution

Accepted Solutions
bluefirestorm
Virtuoso
Virtuoso

It is not always the case the last line is the problem or cause of the problem. But however, if we assume that to be the case,

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Virtual CCID' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB-CCID:  dlopened default libpcsclite.so.1.

CCID would be related to SmartCard readers. If you have a smartcard reader, maybe you could detach it first. If the smartcard reader is not detachable and built-in such as on a laptop, perhaps you could try adding the following two lines to the vmx configuration file after adding back the USB controllers.

usb.generic.allowCCID = "TRUE"

usb.ccid.disable = "TRUE"

The default behaviour is that smart card readers is shareable between VMs. These two lines make the smart card reader not shareable between VMs but behave like normal USB passthrough devices.

If those two lines solves the problem, you could add those lines into /etc/vmware/config instead of having to add that to every VM vmx configuration file.

View solution in original post

7 Replies
bluefirestorm
Virtuoso
Virtuoso

I have encountered this once in VMware Player 14.x on an Ubuntu 16.04 host. The problem was there was a dialog box that required an answer and somehow got pushed into the background and thus the VM power-up appeared stuck in "Waiting for connection".

It might be the case since the system you have is dual-boot, VMware Workstation is asking the question whether you "copied" or "moved" the VM and that dialog box was pushed in the background.

I can't recall exactly how I got to find out about the hidden dialog and how to get it back into focus but Alt-Tab might be the way.

0 Kudos
KLRI
Contributor
Contributor

Nope. That's not the problem, unfortunally.......Smiley Sad

0 Kudos
KLRI
Contributor
Contributor

Got some more info. The problem lays in the USB device configuration. When I remove the USB controller from the VM config the VM starts without any problems.

It seems to be usb related.

Looked in several logfiles but can find the cause of theis problem.

0 Kudos
KLRI
Contributor
Contributor

The last events in het vmware.log are:

2017-12-30T18:00:43.611+01:00| vmx| I125: DISK: DELAY: vide.vtdelay=500 hard-disk.minVirtualTime=0 magicBoot1=0

2017-12-30T18:00:43.612+01:00| vmx| I125: SOCKET creating new socket, connecting to /var/run/vmware/usbarbitrator-socket

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Virtual Hub' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Generic' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Virtual HID' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Remote Device' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: RemoteUSBVMX: Retrieved hostId [4c 45 03 69 36 36 b2 11-a8 5c b4 f3 91 fe 17 ce]

2017-12-30T18:00:43.612+01:00| vmx| I125: RemoteUSBVMX: Protocol version min:15 current:16

2017-12-30T18:00:43.612+01:00| vmx| I125: RemoteUSBVMX: no delay setting is TRUE.

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Virtual Mass Storage' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Virtual RNG' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Virtual CCID' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB-CCID:  dlopened default libpcsclite.so.1.

No extra events are added. When I kill the vmx process I get the following event:

2017-12-30T18:00:43+01:00[+33.237]| vmx| W115: Caught signal 15 -- tid 15435 (eip 0x7f39b8817593)

That's it.

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

It is not always the case the last line is the problem or cause of the problem. But however, if we assume that to be the case,

2017-12-30T18:00:43.612+01:00| vmx| I125: USB: Initializing 'Virtual CCID' backend

2017-12-30T18:00:43.612+01:00| vmx| I125: USB-CCID:  dlopened default libpcsclite.so.1.

CCID would be related to SmartCard readers. If you have a smartcard reader, maybe you could detach it first. If the smartcard reader is not detachable and built-in such as on a laptop, perhaps you could try adding the following two lines to the vmx configuration file after adding back the USB controllers.

usb.generic.allowCCID = "TRUE"

usb.ccid.disable = "TRUE"

The default behaviour is that smart card readers is shareable between VMs. These two lines make the smart card reader not shareable between VMs but behave like normal USB passthrough devices.

If those two lines solves the problem, you could add those lines into /etc/vmware/config instead of having to add that to every VM vmx configuration file.

View solution in original post

KLRI
Contributor
Contributor

Many thanks that fixes the problem.

I use a Lenovo P50 with an integrated smartcard reader. However I do not use the smartcard reader.

For now my problem is fixed, bu I'am look into the problem further.

Cheers,

Karl

0 Kudos
EricChamberland
Contributor
Contributor

It fixed it for me too! Suse Leap 15.2

 

0 Kudos