puffel
Contributor
Contributor

VMWare Workstation cannot run on Windows 10 after recent update to Windows 10

Sorry, but I have to repost this again due to the BBS's default frontpage won't put the most active thread on top, but the newest.

I've add my question to this thread originally: Windows 10 Spring Creators Update (Redstone 4)(RS4)(1803) host status?

I'm having problem with VMWare Workstation 14.1.1 build-7528167, after a Windows 10 update last weekend (Feature update to Windows 10, version 1803).

It was working ok before update, and now it dropped into a loop of Error: CG/DB

and Error: Hyper-V

after rebooting, when I try to start up any VM. I've also posted the question over here:

VMWare Workstation cannot run on Windows 10 after recent update to Windows 10 - Stack Overflow

Hopefully someone can provide me with resolution soon.

This is urgent for me now.

Thanks and regards,

Weishan

P.S.: Why the screenshot cannot display after submit? It looks good in in the edit view:(

17 Replies
Scillonian
Hot Shot
Hot Shot

On the Windows 10 April 2018 (1803) host go to Windows Defender Security Centre > Device Security > Core Isolation and disabled the settings there?

0 Kudos
puffel
Contributor
Contributor

Thanks for your reply. Will try it later and let you know if that will work.

0 Kudos
puffel
Contributor
Contributor

For me, there's only one option "Memory integrity" and it is off already.

Any other advice?

0 Kudos
Scillonian
Hot Shot
Hot Shot

Is Hyper-V also disabled?

What is the exact error message you are getting when you try to start a VM?

0 Kudos
puffel
Contributor
Contributor

Yes, Hyper-V is disabled from the "Turn Windows feature on or off".

Now, I'm in the loop of following two error messages:

https://i.stack.imgur.com/ZSdY5.png

and

https://i.stack.imgur.com/JxUaY.png

0 Kudos
Scillonian
Hot Shot
Hot Shot

This odd Windows 10 behaviour of reporting that Hyper-V is installed when it appears not to be in Turn Windows features on and off has been reported in other places.

From Microsoft's TechNet forum a post had this to say about Device Guard and Credential Guard and the Hyper-V problem:

Credential guard is the root of the problem. Thanks for the post!

I was able to disable credential guard by using microsoft's Device Guard and Credential Guard hardware readiness tool: https://www.microsoft.com/en-us/download/details.aspx?id=53337

First, make sure it isn't managed by group policy. Check local group policy for the following and disable:

Computer configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security: disabled

The tool is a powershell script so make sure to set your powershell exexution policy:

Set-ExecutionPolicy -ExecutionPolicy RemoteSigned

Then run the readiness tool with the disable flag:

DG_Readiness_Tool_v3.2.ps1 -disable

When you reboot you should get a preboot dialougue asking if you want to disable credential manager

I would also make sure to have hyper-v disabled in windows features.

Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V –All

You may also need to disable it from starting by using a command line command mentioned before:

bcdedit /set hypervisorlaunchtype off

There is also reference to the VMware KB:

Powering on a vm in VMware Workstation on Windows 10 host where Credential Guard/Device Guard is ena...

If you want to read the full thread it is available here.

0 Kudos
LurkerGuest
Contributor
Contributor

After updating to 14.1.2 build-8497320, my VMs wouldn't start with the same message with a device guard link. I did disable device guard in gpedit.msc and found the command line instructions to be useless.

There is a setting under "Windows Defender Security Center" > "Device Security" > "Core isolation" named "Memory integrity" that was greyed out and "on". Saying something about your administrator controls this.

I had to go into the registry and turn it off. The VMs are now starting.

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity

Modify "Enabled REG_DWORD" value to (0). [it had the value set to 1, which is ON.]

Hope it works for you! I'm a much happier camper now the I have my virtual machines back.

BTW, I thought I saved the link to the article about setting the registry values but cannot find it.

0 Kudos
puffel
Contributor
Contributor

You can try OneNotes. When you paste things into your notes, the original URL will be automatically added. I like it very much, as well as other features introduced into the application, such as OCR (which is most likely a cool show off only) from the screenshot that makes a cool deeper full "text" search.

0 Kudos
MetsLITech
Contributor
Contributor

I had similar problem just this morning trying to open VM's using VMware Workstation 14. There was a VMware update so thought that would help so now on 14.1.2 build-8497320.

To make this reply short the issue was Core Isolation being turn on.

Core Isolation has been causing a lot of issues at my place of work with products that we make and drivers not being compatible with it.

So will add another thing to the list that Windows 10 1803 has cause an issue with.

0 Kudos
Netjim
Contributor
Contributor

I'm running Windows 10 1803.

I'm betting MS is starting a silent war again with vendors.

VMWare workstation will not stop prompting for this credential guard.

You can fix it once, until a reboot.

Edge also takes over and forces you to use it rather than ALREADY INSTALLED Acrobat Reader.

MS is going to force you to be miserable and use only their products.

0 Kudos
Netjim
Contributor
Contributor

You have to disable credential guard, and then make sure Group Policy isn't turning it back on.

I use this Batch File:

mountvol X: /s

copy %WINDIR%\System32\SecConfig.efi X:\EFI\Microsoft\Boot\SecConfig.efi /Y

bcdedit /create {0cb3b571-2f2e-4343-a879-d86a476d7215} /d "DebugTool" /application osloader

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\EFI\Microsoft\Boot\SecConfig.efi"

bcdedit /set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215}

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO,DISABLE-VBS

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} device partition=X:

mountvol X: /d

REM On reboot, hit F3 then ENTER. Do it twice.

REM pause

0 Kudos
dkutac
Contributor
Contributor

I tried your steps, as they looked promissing. Unfortunately, my VM's still freeze after short time. again and again...

0 Kudos
jcampolo
Contributor
Contributor

I just installed the latest VMware Workstation Player and the problem seems fixed. Some patches were required but just follow the directions.

0 Kudos
waqasalisha
Contributor
Contributor

you can solve this issue . I found a Video on youtube

https://youtu.be/PZ47gQj450c

issue solve tell us if you got success.

0 Kudos
waqasalisha
Contributor
Contributor

tell us if this video can solve you issue.

i am sure after watching this tutorial you can solve your issue.

(Solved) vmware workstation not working on windows 10 Latest 19 Oct 2019 - YouTube

0 Kudos
qflagg
Contributor
Contributor

This video is much better and resolves the issue.

VMware Workstation Pro can't run on Windows - Message Solved - YouTube

C6Dave
Contributor
Contributor

I had the same issue with latest Win 10 build so upgraded to Workstation 15 but as had an older CPU had: Add monitor.allowLegacyCPU = "true" in C:\ProgramData\VMware\VMware Workstation\config.ini

Then it ran and loaded but asked for an update once running which I applied and finally had to enable Virtulization Printing to use the host machine printing.

All these 'fixes' have had to be applied going back several years so why haven't the developers taken notice of the community?

0 Kudos