puffel
Contributor
Contributor

VMWare Workstation 14 get "unrecoverable error: (svga)

As subject.

Host: Lenovo P51, Windows 10 Pro

VM: Workstation 14

Guest: Windows Server 2016 (With GUI) and VMTools installed.

When trying to open "Server Manager" (sometimes other apps as well, but this is the most stable way to reproduce) on the guest system, the following error occurs:

pastedImage_0.png

After upgrade the VMWare workstation to: 14.1.1 build 7528167, it get even worse: Before, when error message occurs, VM will stop; after upgrade, when error happens (same operation, trying to open "Server Manager"), no more error message, but VMWare will hung completely, until get killed from task manager.

For now, if I want to run that guest VM stably, the only way I found was to remove vmtools.

0 Kudos
3 Replies
puffel
Contributor
Contributor

Ok, one update.

I've disabled the 3D graphics acceleration feature. VM no longer crash, not till now at least.

0 Kudos
bluefirestorm
Champion
Champion

Since the P51 has both Intel integrated graphics and Nvidia discrete graphics; the crash may also depend on which graphic card is used when 3D acceleration is enabled.

In laptop with GeForce graphics, the Nvidia Control Panel let you select the default GPU. It might be the case it is available in the Quadro line. Obviously using the Quadro will have graphics performance for the VM but will use a lot more juice from the battery.

You can look at the vmware.log to see which graphic card was used (look for DX11Renderer). The following below is an example from 12.5.x and so might look slightly different for version 14.x. In this example, VMware uses the Intel graphics as the "Successfully create a device" shows up after the Intel graphics was found. The "Successfully created a device" should appear after listing out the Quadro to indicate that it is using the Quadro.

| mks| W115: DX11Renderer: Enumerating adapter 0

| mks| W115: DX11Renderer: `Intel(R) HD Graphics 530` vendor=0x8086 device=0x191b revision=6

| mks| W115: DX11Renderer: video=128MB system=0MB shared=16324MB

| mks| W115: DX11Renderer: Successfully created a device

| mks| W115: DX11Renderer: Enumerating adapter 1

| mks| W115: DX11Renderer: `NVIDIA Quadro M1000M ` vendor=0x10de device=0x13b1 revision=162

| mks| W115: DX11Renderer: video=1993MB system=0MB shared=16324MB

0 Kudos
puffel
Contributor
Contributor

Thank you so much for your reply.

For the moment, I don't need 3D Accelerate feature. So, I'll just disable it and continue. If there's any trouble in the future when I need that feature, I'll come back and revisit this thread.

0 Kudos