tom___
Contributor
Contributor

VMWare Tools download & install fails on Linux host

from the vmware-installer log:

[2016-08-17 15:34:04,801] Installer running.

[2016-08-17 15:34:04,801] Command Line Arguments:

[2016-08-17 15:34:04,801] ['/usr/lib/vmware-installer/2.1.0/vmware-installer.py', '-t', '--console']

[2016-08-17 15:34:04,802] UI Initialization failed.

Traceback (most recent call last):

  File "/usr/lib/vmware-installer/2.1.0/vmware-installer.py", line 288, in main

    ui.Initialize(options.ui)

  File "/usr/lib/vmware-installer/2.1.0/vmis/ui/__init__.py", line 83, in Initialize

    exec 'from vmis.ui.null import *' in globals()

  File "<string>", line 1, in <module>

  File "/usr/lib/vmware-installer/2.1.0/vmis/ui/null.py", line 13, in <module>

    from vmis.ui import console

  File "/usr/lib/vmware-installer/2.1.0/vmis/ui/console.py", line 9, in <module>

    import curses

  File "/usr/lib/vmware-installer/2.1.0/python/lib/curses/__init__.py", line 15, in <module>

    from _curses import *

ImportError: libncursesw.so.5: cannot open shared object file: No such file or directory

I have two python versions installed, 3.5.2 and 2.7.12 and both can import curses, so I assume this is with the VMWare provided python which is linked to ncurses 5 (my system has only ncurses 6 installed).

I am also not sure why it is trying to run the console version at all, as this is being triggered from the GUI after it downloaded the vmware tools update. Shouldn't it be launching the --gtk version (which does appear to work if I run it manually from the command line)?

0 Kudos
3 Replies
bonnie201110141
VMware Employee
VMware Employee

You are correct about the version of ncurses. When trying to install tools via GUI, it will trigger 'vmware-installer -t --console' to obtain the installed component but failed due to libncursesw version mismatch. You have several workarounds for this:

1) Manual install the library ncurses-compat-libs

2) Create soft link: sudo ln -s /usr/lib64/libncursesw.so.6 /usr/lib64/libncursesw.so.5

3) Manually specify the tools iso images (/usr/lib/vmware/isoimages) in VM Settings->CD/DVD

xunil1
Contributor
Contributor

Awesome!, I installed the cursed ncurses package and (after paging to what seems like hundreds of agreement pages), the software installed without any other hiccups.  Thank you so very much.

0 Kudos
NetArcher
VMware Employee
VMware Employee

Following option worked on Ubuntu Ubuntu 20.04.2 LTS  while installing OVF Tool

2) Create soft link: sudo ln -s /usr/lib64/libncursesw.so.6 /usr/lib64/libncursesw.so.5

 

This is the command i ran

sudo ln -s /lib/x86_64-linux-gnu/libncursesw.so.6 /lib/x86_64-linux-gnu/libncursesw.so.5

0 Kudos