dva20
Contributor
Contributor

VMWare Player 14.1.2 and error with 3D acceleration - SVGA_3D_CMD_DX_SET_SHADER_RESOURCES

Hi, everybody!

My host system: Windows 10 with all last updates: 17134.81

My guest system: Kubuntu 18.04 with all last updates. Kernel: 4.15.0-22-generic, open-vm-tools: 2:10.2.0-3ubuntu3

I getting next errors on window system few times every day:

In a system log:

May 28 09:16:24 vm-ws017 kernel: [16709.090546] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command "(null)" causing device error.

May 28 09:16:24 vm-ws017 kernel: [16709.090554] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command buffer offset is 28

May 28 09:16:24 vm-ws017 kernel: [16709.090557] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command size is 24

May 28 09:16:24 vm-ws017 kernel: [16709.093968] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command "SVGA_3D_CMD_DX_DEFINE_SHADERRESOURCE_VIEW" causing device error.

May 28 09:16:24 vm-ws017 kernel: [16709.093974] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command buffer offset is 3652

May 28 09:16:24 vm-ws017 kernel: [16709.093978] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command size is 40

May 28 09:16:24 vm-ws017 kernel: [16709.094212] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command "SVGA_3D_CMD_DX_SET_SHADER_RESOURCES" causing device error.

May 28 09:16:24 vm-ws017 kernel: [16709.094216] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command buffer offset is 0

May 28 09:16:24 vm-ws017 kernel: [16709.094220] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command size is 20

May 28 09:16:24 vm-ws017 kernel: [16709.095910] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command "SVGA_3D_CMD_DX_DEFINE_SHADERRESOURCE_VIEW" causing device error.

May 28 09:16:24 vm-ws017 kernel: [16709.095916] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command buffer offset is 60

May 28 09:16:24 vm-ws017 kernel: [16709.095920] [drm:vmw_cmdbuf_work_func [vmwgfx]] *ERROR* Command size is 40

What to do? How to fix? ))

0 Kudos
1 Reply
JordanRinke2
Contributor
Contributor

For a temporary workaround disable 3d acceleration for the VM.

0 Kudos