supercell
Contributor
Contributor

VMWare 6 Tools won't install (Suse Linux Guest on Vista) Kernel headers don't match running kernel

Hello,

I installed Suse 10 as a guest on MS Vista. I updated Suse to its latest kernel. I install VMWare Tools and it informs me that my kernel versions do not match. My current kernel version is 2.6.13-15.18-default. What is the exact kernel suffix (eg 2.6.13-15.18-default.src, or 2.6.13-15.18-default.rpm) I need to download to allow VMW6 Tools to install? Recent kernel: 2.6.13-15.18-default. And where do I find it?

Thank you,

supercell

0 Kudos
14 Replies
AWo
Immortal
Immortal

Have you installed the kernel source after upgrading to the latest kernel (using YOU, I guess)? If so, the headers weren't updated together with the kernel and they're still at an older version.

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
supercell
Contributor
Contributor

I figured it out. I had to download kernel-source-2.6.13-15.18.i586.rpm and install it. The current problem now is, after installing it and VM Tools is that the virtual NIC no longer works! Any ideas?

0 Kudos
AWo
Immortal
Immortal

Ah, O.K., you didn't had old kernel sources, you hadn't them installed at all.

What doesn't work exactly?

You have to reconfigure your network interface in the guest, as it has used the modules for the AMDnet32 NIC (pcnet32) while the tools weren't installed.

After reconfiguring them you should have the "vmxnet" module loaded.

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
supercell
Contributor
Contributor

How do I point it to the "vmxnet" module?

0 Kudos
AWo
Immortal
Immortal

If you use YaST (ifup method) to configure network interface cards, select the one in question and change its settings. Under "Advanced" (I don't know what the English dialog shows) select "Hardwaredetails" and change the module name from "pcnet32" to "vmxnet".

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
supercell
Contributor
Contributor

I will try this when I get to work today (few hours). Thanks!!

0 Kudos
supercell
Contributor
Contributor

It didn't work. Changed the setting in YaST to vmxnet and eth0 still is not there. I am assuming that AMD PCnet - Fast 79C97 is the card I should be seeing in YaST. That is what is in there now. I am going to attempt to reload the VM Tools.

0 Kudos
AWo
Immortal
Immortal

Yes, that's the type VMware emulates.

By the way, the "pcnet32" driver keeps loading, even if you switch to "vmxnet". Still figuring out why....

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
supercell
Contributor
Contributor

Thanks for helping me out! I will inform you as to what I find reinstalling VMWare Tools.

0 Kudos
Wilz
Contributor
Contributor

I have a similar situation with the following configuration. XP as the host and SUSE 10 Desktop as a guest. Once I install the VMware tools I lose my Network connection. I followed on the on screen directions and some advice found on google and still no Network. If you find the answer can you please reply to the post.

0 Kudos
supercell
Contributor
Contributor

Just rename ifcfg-eth-id-"00:0c:29:56:83:35" (your mac address) to ifcfg-eth0.

0 Kudos
AWo
Immortal
Immortal

Yes, I always have to fiddle with this also. I didn't take enough time to figure it out, yet. I always rename same like you did.

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
Wilz
Contributor
Contributor

I have never renamed interfaces on a linux box. ( SUSE ) I searched google but I am finding conflicting infomation. Would you mind sharing a how to ?

0 Kudos
supercell
Contributor
Contributor

Sure. In your command line, as root (su + root password), go to /etc/sysconfig/network you will see ifcfg-eth0 and something like: ifcfg-eth-id-00:0c:29:56:83:35.

Type cp ifcfg-eth-id-00:0c:29:56:83:35 ifcfg-eth-id-00:0c:29:56:83:35.old (this saves the original just in case).

Now change the original to ifcfg-eth0: mv ifcfg-eth-id-00:0c:29:56:83:35 ifcfg-eth0. Now reboot and be happy!

0 Kudos