VMware Communities
vmassassin
Contributor
Contributor

VM workstation 10 host-only networking with Linux VM and Windows 8.1 host

I've been trying to set-up a host-only network between my Virtual machine Linux and Windows 8.1 pro as host to share internet connection from my Linux VM with Windows 8.1. the Linux distribution i'm working with is Kali-Linux. internet connection is in VM and i want to bring to to host computer and from there share it between other computers using ICS.

i followed the instructions in here and here and found some docs but they were for older versions of Vmware workstation.

First, i tried to disable any ICS that was already running in my host Windows and then in VMware workstation settings, network adapters settings, set the network to host-only and i know that it will enable host-only network on VMnet 1 Virtual network adapter. i connected to internet in my VM but there was no internet connection coming to my Windows host through VMnet 1.

Second, i tried to set the custom option in VM settings and manually set the adapter to be VMnet 1 but still no luck.

i think there are some interference with IP address of my Windows with VMnet 1 virtual adapter.

my computer's IP address is 192.168.1.5 and the VMnet 1's IP address is 192.168.68 and it's DHCP server is 192.168.68.254.

i changed them using Virtual network editor in VMware worksation and set the IP address on the host-only VMnet 1 to 192.168.1.10 and it's subnet ip to 192.168.1.0 but when i go to details of VMnet 1 in Windows, it still has the old configuration.

do i need to configure my Linux VM too or am i doing things wrong? please give me detailed answer if i'm doing it all wrong from the start. thanks in advance.

Reply
0 Kudos
1 Reply
johanun
Contributor
Contributor

Same problem here with Win8.1 as host and win7 as guest. I am not able to ping between host and guest.  With win7 as host and the same win7 guest image the host-only networking works fine. Does anyone have a fix?

Reply
0 Kudos