Fbaixinho
Contributor
Contributor

VIX Wrapper - Workstation Pro 15.5

Hi,


Our Visual Studio builds started failing after upgrading Workstation Pro to 15.5, the problem is with the vixwrapper-product-config file.

In the latest version of VMware Workstation Pro 15.5 the vixwrapper-product-config has wrong configuration where is:

# Workstation and Player 15.0.0

ws        19  vmdb  15.0.0 Workstation-15.0.0

player    19  vmdb  15.0.0 Workstation-15.0.0

Should be:

# Workstation and Player 15.0.0

ws        19  vmdb  15.5.0 Workstation-15.0.0

player    19  vmdb  15.5.0 Workstation-15.0.0

Thanks
Fernando

Tags (1)
3 Replies
wbierman
Contributor
Contributor

We have a similar problem, where VIX stopped working altogether after installing the 15.5 update.  15.0.0 is referenced in our vixwrapper-product-config file too and this is an excerpt from the log file in %TEMP%:

2019-10-04T03:21:39.450-04:00| host-7824| I125: Log for VixWrapper pid=7820 version=1 build=build-14665864 option=Release

2019-10-04T03:21:39.450-04:00| host-7824| I125: The process is 64-bit.

2019-10-04T03:21:39.450-04:00| host-7824| I125: Host codepage=windows-1252 encoding=windows-1252

2019-10-04T03:21:39.450-04:00| host-7824| I125: Host is Windows Server 2012 Standard Edition, 64-bit  (Build 9200)

2019-10-04T03:21:39.434-04:00| host-7824| I125: DictionaryLoad: Cannot open file "C:\Users\bbierman\AppData\Roaming\VMware\config.ini": The system cannot find the file specified.

2019-10-04T03:21:39.434-04:00| host-7824| I125: [msg.dictionary.load.openFailed] Cannot open file "C:\Users\bbierman\AppData\Roaming\VMware\config.ini": The system cannot find the file specified.

2019-10-04T03:21:39.434-04:00| host-7824| I125: PREF Optional preferences file not found at C:\Users\bbierman\AppData\Roaming\VMware\config.ini. Using default values.

2019-10-04T03:21:39.434-04:00| host-7824| I125: FILE: FileLockDynaLink: Further process validation tools are: available

2019-10-04T03:21:39.448-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Users\bbierman\AppData\Local\Temp\2\vmware-bbierman", ...) failed, error: 2

2019-10-04T03:21:39.451-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("vixWrapperDiscovery.dll", ...) failed, error: 2

2019-10-04T03:21:39.459-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.459-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.459-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.459-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.459-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.459-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.459-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.460-04:00| host-7824| I125: Win32U_GetFileAttributes: GetFileAttributesExW("C:\Program Files (x86)\VMware\VMware VIX\\Workstation-15.0.0\64bit\vmwarebase.dll", ...) failed, error: 2

2019-10-04T03:21:39.460-04:00| host-7824| I125: passed in VIX_SERVICEPROVIDER_DEFAULT, computed hostType as 3

2019-10-04T03:21:39.460-04:00| host-7824| I125: Workstation installed version is 15.5.0

2019-10-04T03:21:39.460-04:00| host-7824| I125: No implementation found for service provider 3, apiVersion -1 installedVersion 15.5.0

2019-10-04T03:21:39.460-04:00| host-7824| I125: No Vix library found for provider 1 revision -1, err 22002

0 Kudos
wbierman
Contributor
Contributor

Follow-up:

I installed a trial of VMWare Workstation Pro 15.5 on a clean Windows 10 Professional machine (i.e. never had any vmware products installed).  The same exact problem happens there.

0 Kudos
wbierman
Contributor
Contributor

Second follow-up:

I found the installer we used for the previous version, called `VMware-workstation-full-15.1.0-13591040.exe`.  I uninstalled 15.5, disabling the options to remove license and configuration information, and then re-installed using the old installer.  The VIX API is now working again.