46terherh
Enthusiast
Enthusiast

Using VMware on Windows 1903 host machine cannot turn on guest machine

Jump to solution

Hello, I got a problem after upgrade to Windows Insider Preview 1903 18362.30 x64 on host machine.

CPU : I5-8400

RAM : 16G

Host OS : Windows 10 1903 x64 18362.30 (Latest WIP)

VMWare Version : 15.0.4 build-12990004

Other Status :

"bcdedit /set hypervisorlaunchtype OFF"  (Means that Windows Native hypervisor already turned off)

"Memory integrity guard OFF"

"Credential Guard OFF"

Before I upgraded to Windows Insider Preview 18362.30, I was using Windows 10 RS5 x64 as a host operating system.

I could run any VM guest machine without any problem.

But, after I upgrade to Windows 10 1903, I cannot run any VM guest.

Guest screen only shows a black screen, and nothing happens.

What I can do is just rebooting machine. Cannot terminate vmware-vmx.exe process.

Anybody has same issue like this? And if anybody has solution it will be very thankful.

Thanks.

74 Replies
Sotirisdim4
Contributor
Contributor

No it's not yet rolling out. Right now it's still on the release preview Insider ring (although this appears to be the final RTM build) for extended testing, Microsoft themselves said the first rollouts will begin in late May, so a couple weeks from now.

46terherh
Enthusiast
Enthusiast

IT'S STILL BETA for USER who does not know MSDN.

Currently being rolled out through INSIDER PREVIEW.

You don't know what INSIDER PREVIEW means?

0 Kudos
lindros2
Contributor
Contributor

no we don't.

why don't you explain.

or send us a link like the VMonkeys did above.

0 Kudos
lindros2
Contributor
Contributor

FYI I UNinstalled Windows Sandbox and my VM's now work.

That appeared to be the trigger for me (and yes I also disabled all the Guard stuff).

"Release Candidate" 18362.86 (no further updates)

0 Kudos
MathewBurazin
Contributor
Contributor

15.1.0 got released on the 14th and is hopefully a fix for the black screen issues.

0 Kudos
MathewBurazin
Contributor
Contributor

15.1.0 so far so good all VMs now working as expected.

0 Kudos
akukalle
Contributor
Contributor

Is there going to be update for 14.x?

0 Kudos
MathewBurazin
Contributor
Contributor

The latest update for 14 was

VMware Workstation 14.1.7 Pro for Windows 2019-03-28

0 Kudos
karaak
Contributor
Contributor

Ok after investigation there is a problem.

Some older computers cannot run version 14 or 15 of vmware because of a CPU requirement (there is an error when you try that) and are stuck on version 12. There was no version 13. Perhaps it was an unlucky number?

here is the error>> This host does not support "Intel EPT" hardware assisted MMU virtualization. See discussion here> VMware Workstation Pro 14 - Fails To Start Due To CPU Non-Support

Now with the new windows 10 1903 update there will be a problem.

Those computers that do not support "Intel EPT" will not be able to upgrade to windows 10 1903 because I assume the vmware 12 will not be compatible and give black screens and hang...

If possible Vmware should release a fix or patch for version 12 for this reason.

If its not fixed, I can forsee this being a problem for many people that have perfectly fine servers etc and windows updating and then their VM's wont work!

0 Kudos
TychoSchenkevel
Contributor
Contributor

This really needs to be fixed for 14.x too. After installing 1903 I get this error about Hyper-V being enabled, but it's not

As well as that the credential guard was apparently enabled again but this was quickly remedied. But Hyper-V is definitely not installed. So I can't use my VM box right now Smiley Sad

Adding a floppy drive as suggested didn't work, as the Hyper-V error appears before it shows the floppy error message.

Will there be a patch for 14.x? I'm already running the latest 14.1.7.

0 Kudos
lindros2
Contributor
Contributor

As per other threads I removed Win10 sandbox (1903) and VMware 14.1.7 works fine. No Intel VM errors.

I'm running Win7 and Ubuntu 18.04 LTS VM's.

Win10-on-Win10 caused me all sorts of issues - including, but not 100% proven - corrupting the host machine after running Windows Update on the guest (ultimately I had to rebuild my host).

And my host was only six months old. Built from scratch without any Dell/etc. crapware.

0 Kudos
adza77
Enthusiast
Enthusiast

Using VMware on Windows 1903 host machine cannot turn on guest machine

I'm assuming there's been nothing further mentioned. I'm on VMWare 12.5.9 and I still get black screen.

The other day - I ended up having to crash out of the black screen but then couldn't boot up again. Restarting my host, and even restoring a backup didn't work due to some PIPE error. In the end I had to uninstall and reinstall VMWare itself.

I'm hoping VMWare consider releasing a patch for the other versions that are still supported soon!

0 Kudos
RayS55
Contributor
Contributor

Player version 14.1.7 still needs to be updated.

Running 64x Win10 Pro 1903 on host. Formerly healthy 64x Win10 Pro 1809 on guest did automatic update to WU 1903 and, after automatic reboot, the VM shows a completely black screen.

I tried all the remedies mentioned above: Updated video drivers, disabled USB connection in guest. Edited relevant line in VMX file to: ethernet0.virtualDev = "vmxnet3". Also added a fake floppy drive to guest. Did many reboots of host. Still no joy.

Do we know for sure VMWare is working on an update for Player version 14.1.7 to address the problem with WU 1903?

Thanks,

Ray

edited for typo

0 Kudos
alank2
Contributor
Contributor

I am having lots of trouble with this.  Upgraded to 14.1.7 still trouble with build 1903.  Any updates on this?

0 Kudos
RayS55
Contributor
Contributor

Hi alank2,

This problem was solved for me by Wil at VMware Workstation 14 Player (non - commercial) Black Screen after Win10 1903 Update

Summary:

Uninstall Player 14. Install free for non-commercial version of Player 15 from Download VMware Workstation Player | VMware

My previously inaccessible VM is now working fine.

Ray

0 Kudos
alank2
Contributor
Contributor

Thanks Ray, unfortunately I'm using VM Workstation Pro 14 and it says it won't let me install the 15 player alongside it!

Is there any hope that VMWare will provide a fix for v14?  These licenses were purchased last May and now they are useless...

0 Kudos
RayS55
Contributor
Contributor

Hi alank2,

I'm pretty sure VMWare has released Workstation Pro 15 ( Download VMware Workstation Pro ).

I saw on another thread some people who were getting the black screen said it cleared when they upgraded to V15. I don't know the cost (if any) to upgrade from V14 to V15. Did you try the VMWare product page?

Ray

0 Kudos
alank2
Contributor
Contributor

Hi Ray,

I saw on another thread some people who were getting the black screen said it cleared when they upgraded to V15. I don't know the cost (if any) to upgrade from V14 to V15. Did you try the VMWare product page?

Yep, I called them and got nowhere.  Two licenses purchased last May, now completely unusable.  It concerns me about buying another one - how do I know they won't release 16 one week later and only IT will be compatible with the next win10 update.  This is a bad precedent to set.

0 Kudos
RayS55
Contributor
Contributor

Hi alank2,

I checked a little farther. I see the price for upgrading from v14 to v15 is $149.99.

Upgrade to Workstation 15 Pro

I don't see any consideration for recent purchases like yours.

In my case, such expenses wouldn't be practical because my only use of Player is to experiment safely with registry hacks or new software. It's a sandbox in which I have set some semi-permanent configuration options. I don't need a VM for production work.

Sorry I can't be of any help.

Ray

0 Kudos
alank2
Contributor
Contributor

Thanks Ray; I appreciate your replies!

0 Kudos