GerhardUM
Contributor
Contributor

Update to 16.2.1 of Pro fails at LIBSSL-1_1.DLL is missing

Workstation 16.1.2-17966106 was working without issue. 

Was notified that there was a new version by Workstation and opted to update to 16.2.1-18811642.exe.

After the update installation I received an error indicating that SSLESY32.DLL was not found.

Uninstalled the 18811642 version (after a repair attempt), and installed the 17966106 version... and I get the error:

"The code execution cannot proceed because LIBSSL-1_1.dll was not found. Reinstalling the program may fix this problem."

Reinstalling doesn't fix this problem...  

Anyone have any ideas?

0 Kudos
2 Replies
GerhardUM
Contributor
Contributor

FWIW: I'm also seeing that if I can find a current copy of the missing DLLS, others are missing as well.

It seems to me that files are missing from the installation.

 

For example, when I copied libssl-1_1.dll from the Zoom installation after doing a general search on C:, I got the error that libcrypto-1_1.dll was also missing.

 

Once again, Zoom had that DLL, so I copied it to the ../workstation/ and ../workstation/x64 folders... 

 

...and suddenly Workstation Pro 16.1.2-7xxxxx is working.

 

Mods: Can you reach out to support?  Please?  (I'm even a former VMware employee... )

0 Kudos
GerhardUM
Contributor
Contributor

Oh, and those DLLS I added because they were missing... they are too new to work properly with VMware Workstation.

 

As such, attempting to connect to a vCenter fails.

0 Kudos