richstep
Contributor
Contributor

Uninstall error - Error in the lua script: [string......

Hi all,

I'm trying to update my Workstation 7 software to the latest version but my current version will not uninstall. I'm on Win7 64 bit SP1.

I get this error:

Error in the lue script: [string "----------------------------------..."]401: attempt to call global 'IsVMAppControlAvailable' (a nil value)

Any ideas?

Thanks.

-Rich

0 Kudos
2 Replies
WoodyZ
Immortal
Immortal

0 Kudos
dsmith321
Contributor
Contributor

I experienced this same issue upgrading from workstation 7.1.x to 8.x due to recovering a Windows 7 machine from a 2 year old backup. WoodyZ’s pointer to manual removal instructions did work for me but I found a much simpler way if you still have the previous version installation application. If you do, then launch that installer, and select repair installation. You may be instructed to reboot. Then launch the previous workstation version installation app again and select the remove installation option. Select this should cleanly remove the previous install. You will be asked to reboot. The new workstation version should now load without issue. Hope this helps to those that may come across this issue.

0 Kudos