bacampbe
Contributor
Contributor

Uncompressing Linux

I created a Linux vmware guest image on a machine that had 3gb of memory, I gave the vmware image 2.5gb of memory. I then tried copying the vmware image to another machine that only had 2gb of memory, so before starting the image I reduced the amount of memory for the linux vmware image to 1.4gb. However, when I try to start the image I get to the point where it says "Uncompressing Linux... Ok. booting the kernel". It hangs here and never continues booting. I think the problem has something to do with having creating the image with more memory than is available on the new machine but not sure what to do. The only other difference is that the vmware host is Win XP on the 3gb machine and Win 2k on the 2gb machine. Any suggestions on how I can get this to boot? I am using Vmware workstation 6.02 and the Linux version is RHEL AS 4 update 4.

0 Kudos
5 Replies
AWo
Immortal
Immortal

What kind of copy/image did you create? Where do you copy it to? Again VMworkstation, same version? Did you use the same .vmx and .vmdk files on the other host or have you created a new guest and used the only the .vmdk copied over?

The files that make up the guest? As long as you copy them while the guest was shut down, there shouldn't be such an issue. The linux kernel is saved in a compressed format on the "/boot" partition, but it shouldn't take such an amount of memory.

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
Peter_vm
Immortal
Immortal

You should try to reduce RAM size of that virtual machine, reboot a few times to make sure it works, before copying it to another host.

0 Kudos
bacampbe
Contributor
Contributor

Thanks for the replys, let me see if I can clarify things. Both the original (3gb PC) and the 2gb PC are running the same version of VMware Workstation (6.02). I copied the entire vmware image directory from the original PC to the 2gb PC (all files, not just the .vmdk file). The Linux Guest was shutdown before I did the copy. When I went back to the original (3gb PC) to reduce the memory for the Linux Guest to 1.4gb I did reboot it (just once) to verify that it would come up. I then shut down the linux guest and re-copied the vmware image to the other machine but still get the same error message when I try to start the Linux Guest. One other difference is that the 3gb PC and the 2gb PC are not the same model if that makes a difference (I would think not), both are ThinkPads one is a T60p the other a T41. Also, I googled my sympton "Uncompressing Linux", and found a entry that talked about there not being enough resources (memory/disk) to boot the image. Disk space is fine, so that also leads me to believe it has something to do with the memory configuration.

0 Kudos
AWo
Immortal
Immortal

Which kernel do you boot? smb? If so, try to change to the non-smb kernel on the source before cloning it to the destination.

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
bacampbe
Contributor
Contributor

Thanks. Your suggestion made me think...I had just been letting Linux boot up automatically. I finally interrupted the boot and brought up the GRUB menu and saw this:

Red Hat Enterprise Linux ES (2.6.9-42.ELsmp)

Red Hat Enterprise Linux ES-up (2.6.9-42.EL)

I found this on the redhat web site:

SMP Motherboards, GRUB, and LILO

This section is specific to SMP motherboards only. If the installation program detects an SMP motherboard on your system, it will automatically create two /boot/grub/grub.conf or /etc/lilo.conf entries (depending on the boot loader you installed), rather than the usual single entry.

The two entries in grub.conf will be Red Hat Linux (kernel version) and Red Hat Linux (kernel versions-smp). The Red Hat Linux (kernel version-smp) will boot by default. However, if you have trouble with the SMP kernel, you can elect to boot the Red Hat Linux (kernel version) entry instead. You will retain all the functionality as before, but you will only be operating with a single processor.

The two entries in lilo.conf will be linux and linux-up. The linux will boot by default. However, if you have trouble with the SMP kernel, you can elect to boot the linux-up entry instead. You will retain all the functionality as before, but you will only be operating with a single processor. By default it was selecting the first entry, which is the kernel that hangs during the boot.

Without interrupting the boot process the first menu item is chosen, that is the one that was hanging on the 2gb PC. The key here is that the T60p is a Dual Processor so when I installed the Linux guest it sensed that and created the GRUB menu. So using the image as it was previously all I have to do is choose the non-smp option and everything works fine.

0 Kudos