martyouel
Contributor
Contributor

Unable to start virtual machine by using command line

Jump to solution

Hi,

I'm trying to start my virtual machine by using command line and I always get that error :

"Command failed : You do not have access rights to this file"

I'm admin of computer...

Here's the command that I run :

"C:\Program Files\VMware\VMware Workstation\vmrun.exe" start "C:\Documents and Settings\mouellette\My Documents\My Virtual Machines\DYNACOM-VMBUILD-V10\Windows XP Professional.vmx"

I'm using Vmware workstation 6. I'm able to start one other virtual machine by command line, but the one I really need wont start. This virtual machine start great when I dbl-click on .vmx file.

What's wrong?

Here's my .vmx file :

config.version = "8"

virtualHW.version = "6"

scsi0.present = "TRUE"

memsize = "1000"

MemAllowAutoScaleDown = "FALSE"

ide0:0.present = "TRUE"

ide0:0.fileName = "dynacom-vmbuild-000005.vmdk"

ide1:0.present = "TRUE"

ide1:0.fileName = "auto detect"

ide1:0.deviceType = "cdrom-raw"

floppy0.present = "FALSE"

ethernet0.present = "TRUE"

usb.present = "TRUE"

sound.present = "TRUE"

sound.virtualDev = "es1371"

sound.fileName = "-1"

sound.autodetect = "TRUE"

displayName = "DYNACOM-VMBUILD"

guestOS = "winxppro"

nvram = "Windows XP Professional.nvram"

ide0:0.redo = ""

ide1:0.startConnected = "TRUE"

ide1:0.autodetect = "TRUE"

tools.syncTime = "FALSE"

ethernet0.address = 00:50:56:3A:60:30

checkpoint.vmState.readOnly = "FALSE"

checkpoint.vmState = ""

ethernet0.connectionType = "bridged"

extendedConfigFile = "Windows XP Professional.vmxf"

virtualHW.productCompatibility = "hosted"

tools.upgrade.policy = "manual"

isolation.tools.hgfs.disable = "TRUE"

uuid.action = "create"

uuid.location = "56 4d 46 da 38 e7 1c 73-1a 44 1a 26 99 c8 5b 53"

uuid.bios = "56 4d 46 da 38 e7 1c 73-1a 44 1a 26 99 c8 5b 53"

ethernet0.addressType = "generated"

ethernet0.generatedAddress = "00:0c:29:c8:5b:53"

ethernet0.generatedAddressOffset = "0"

pciBridge0.present = "TRUE"

ehci.present = "TRUE"

svga.autodetect = "TRUE"

thanks in advance for you help.

0 Kudos
1 Solution

Accepted Solutions
Liz
Virtuoso
Virtuoso

try changing the word myuser and mypass in the following command to your username and password

"C:\Program Files\VMware\VMware Workstation\vmrun.exe" -u myuser -p mypass start "C:\Documents and Settings\mouellette\My Documents\My Virtual Machines\DYNACOM-VMBUILD-V10\Windows XP Professional.vmx"

PS You are logged in as mouellette right? Otherwise its not "My Documents" its "mouellette's Documents"

View solution in original post

0 Kudos
8 Replies
Liz
Virtuoso
Virtuoso

try changing the word myuser and mypass in the following command to your username and password

"C:\Program Files\VMware\VMware Workstation\vmrun.exe" -u myuser -p mypass start "C:\Documents and Settings\mouellette\My Documents\My Virtual Machines\DYNACOM-VMBUILD-V10\Windows XP Professional.vmx"

PS You are logged in as mouellette right? Otherwise its not "My Documents" its "mouellette's Documents"

View solution in original post

0 Kudos
martyouel
Contributor
Contributor

Umm, I still get the same error.

I tried my mouellette user, witch is a user from domain, and also tried local user Administrator and both don't work.

0 Kudos
Liz
Virtuoso
Virtuoso

Try moving the vm to a more central location such as c:\vm

0 Kudos
martyouel
Contributor
Contributor

That still don't work.

I found the problem...it's the configuration file name. Vmware seem to don't like space in name. In Vmware 5 that worked great, but in Vmware 6 we need to have a configuration file name without spaces.

0 Kudos
RDPetruska
Leadership
Leadership

I've got plenty of VMs with spaces in the vmx file names here, running Workstation 6, and do not have that problem. Are you certain that you surrounded your path+filename with quotes on the command line?

0 Kudos
martyouel
Contributor
Contributor

Yeah, just take look my first post.

Here's the command that I run :

"C:\Program Files\VMware\VMware Workstation\vmrun.exe" start "C:\Documents and Settings\mouellette\My Documents\My Virtual Machines\DYNACOM-VMBUILD-V10\Windows XP Professional.vmx"

That command line worked great on VM5, but not on VM6 and I tried that on two computers here and always get the same error. So, I renamed my vmx file to Build.vmx and all works great now...

0 Kudos
Liz
Virtuoso
Virtuoso

I wasnt thinking of the spaces being an issue, more the location within someone elses my documents directory.

Glad you fixed it.

0 Kudos
ScottNZ
Contributor
Contributor

Hi,

Just an additional comment. I was experiencing the same problem but with a .vmx with no spaces but a number. Renaming the .vmx and removing the single trailing number solved the issue in my case. I suspect it's not really the space or number that's the problem because I have several other VMs with spaces and numbers. Maybe it's something about the act of renaming the file??

Cheers,

ScottNZ

0 Kudos