Nukleus2014
Enthusiast
Enthusiast

Unable to start virtual machine after upgrade to VMWARE Workstation Pro 15.5.5

Jump to solution

Today I tried to install VMWARE Workstation Pro 15.5.5 on openSUSE LINUX Version 15.1.

Unfortunately the result was, that I am unable to start any of my virtual machines. For all of them (Windows 10, Windows 10 X64) I get the message:

Unable to change virtual machine power state: Transport (VMDB) error -14: Pipe connection has been broken.

when I start to resume the virtual machine.

I am able to start the virtual machines when using the previous version of VMWARE Workstation Pro (I think 15.5.2). So there is no problem with the virtual machine itself.

If the virtual machine is down (meaning not suspended) I get another error message. So far my VMWARE environment is not working anymore.

Unfortunately there is no possibility to download Workstation Pro 15.5.2 again (at least I wasn't able to find it). Are there solutions for the problem?

27 Replies
GvMariani
Contributor
Contributor

I just did the passage 15.5.2 -> 15.5.5 and got bitten by the same issue as Calva76... So I guess I'm hitting the same issue, because I'm running Linux x86_64 on an AMD Phenom II X4 810 CPU (upgrade planned, but not feasible right now...).

I'm replying here to this question:

Was there a warning about the unsupported CPU when you first installed Workstation 15?  Was it a fresh installation of 15.x or an upgrade from 14.x or older?  We should double-check that our install-time CPU checks are operating as expected... If you were not warned about the unsupported CPU, we will need to correct that

.

No warning about unsupported CPU was given at update time...

0 Kudos
dariusd
Leadership
Leadership

Thanks for posting, GvMariani.

If there was a warning, it should have been given at the time that you first installed some release of Workstation 15.x – For example, if you upgraded from Workstation 14.x to 15.0, that was when the warning should have been given, because that was when your CPU dropped off the list of processors supported by Workstation.  There would not have been any additional warning for the automatic upgrade between Workstation 15.5.2 and 15.5.5 because the CPU was already unsupported by 15.5.2... it just happened to work correctly with 15.5.2 despite not being officially supported.

Having sudden failures after the upgrade to Workstation 15.5.5 is definitely not a pleasant way to learn about this, though.

If you would like me to confirm that it's the same issue, feel free to post your vmware.log from Workstation 15.5.5 as an attachment – look for the blue Attach button in the bottom-right corner when composing your reply... please don't copy-and-paste it.  But the age of your CPU suggests that it is almost certainly the same problem.

I have filed a defect report to ask the team responsible for the installer to make sure that the installer's CPU checks are correct and complete.

Thanks,

--

Darius

0 Kudos
Mits2020
Hot Shot
Hot Shot

Given the abundance of CPU models and the absolutely commendable persistence of people to reuse and recycle instead of dumping perfectly working old hardware, the question "does my old PC support Workstation and from what version on?" is not trivial at all.

The description of CPU requirements given e.g. for WS 15.5.5 in Document Processor Requirements for Host Systems​  are in my humble opinion too vague. The only requirement is that we have to use "processors launched in 2011 or later" (taking into account exceptions), so we have to identify our CPU and search for it in the authoritative source of ark.intel.com (Intel® Product Specifications​​ ) to determine whether WS will run or not. (But I would not be surprised if some users did manage to run WS 15.5.5 on an earlier CPU).

I understand that it is not easy way to compile a list of all the compatible processors and their variants for each WS version (especially laptop CPUs), and that detection-during-installation is not trivial to code and may fail for unforeseen reasons (e.g. a recent OS update or aggressive antivirus protection etc).

This is why I think (and I maybe I have posted this elsewhere) that a small VMware Compatibility Check Utility (possibly checking for other VMware products too) would be very welcome and surely would save much time and frustration, as evidenced in this thread. That Utility ideally could provide guidance regarding upgrading to a socket-compatible CPU that may run the VMware app, or even suggest upgrading the RAM if it is found insufficient, etc. This would be a case of "total customer support", where the manufacturer takes special care to approach beginners even before they decide to try for the first time a new unfamiliar technology, in our case virtualisation.

Nukleus2014
Enthusiast
Enthusiast

Today I received VMWARE Workstation Pro 15.5.6.

I am still running openSUSE LINUX Version 15.1. as host system. I cared about, that every available update of openSUSE has been installed before trying to install VMWare Workstation 15.5.6 on the host system. The installation process itself runs without error messages.

However still unfortunately the result is, that I am unable to start my virtual machines. When testing to start the (suspended) Windows 10 virtual machine, I get the message:

Unable to change virtual machine power state: Transport (VMDB) error -14: Pipe connection has been broken.

when I start to resume the virtual machine.

Being cautious from my last tries to install VMWARE Workstation Pro 15.5.5 (which failed) I used my test Linux machine for installation only. I still may resume the virtual machine using Workstation 15.5.2

0 Kudos
Nukleus2014
Enthusiast
Enthusiast

Hello dariusd,

I just noticed your post to Calva76, stating that VMWare no longer supports my processor (AMD Phenom(tm) II X6 1075T Processor).

I can't remember of any error message complaining about unsupported component. Neither when installing 15.5.0 nor on installing 15.5.5 nor on 15.5.6.

These are really bad news, because the whole system itself runs perfect. Is there any list on supported components?

Calva76
Contributor
Contributor

Hello Nukleus2014,

I agree with you. 😞

0 Kudos
cparke2
Contributor
Contributor

Not all guest OS's are working for me under VMware Player v15.5.2 on the old AMD hardware!

In particular, Windows 98 is consistently crashing the VM for me on VMware Player v14.0.0 and later!

So I am stuck on VMware Player v12.5.9 for this reason.

0 Kudos
fperalmmoliner
Contributor
Contributor

Where can one find the compatibility guide for the different versions of vmware player? I'm having the same error with a PhenomIIx6 1045T. My system is upgradable up to Phenom IIX6 1100T(HDE00ZFBK6DGR) and I would like to know if it will work with it.

 

 

0 Kudos