alantcy
Enthusiast
Enthusiast

Unable to edit VM settings VMware Workstation Pro 17.0

Hi,

On Workstation Pro 17.0

Whenever I click 'Edit virtual machine settings', I get the following error and the whole application crashes.
VMware Workstation unrecoverable error: (vmui)
Exception 0xc0000094 has occured.

Please help.

Tags (1)
32 Replies
scott28tt
VMware Employee
VMware Employee

All VMs? Just one VM? A new VM? An older VM?

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
Radhak
Contributor
Contributor

Downloaded the upgrade yesterday and installed. When ever I try to modify the VM settings it get the same error message 

0 Kudos
ronicon
Contributor
Contributor

I experience the same thing. The new Workstation Pro 17.0 (17.0.0 build-20800274) has a bug in VM editing. for both old (16.x) and new (17) VMs. So far, I have not experienced any errors when running a VM.

Host OS: Win10

 

0 Kudos
alantcy
Enthusiast
Enthusiast

In my case, several VMs of various versions Win8/Win10/Win11 have this issue except for 2 Win10 machines.

It appears the problem arises after the VM hardware compatibility is upgraded to v17.

0 Kudos
sunjwvista
Contributor
Contributor

Yes, the same problem here. After installed workstation 17, upgrade 16.x VM to 17, then edit VM setting crash UI. VM running OK, snapshot management works well.

0 Kudos
alantcy
Enthusiast
Enthusiast

Update: 
Found a workaround.
Reduce Processor/Core count to 1 before upgrading VM compatibility to v17.
The settings page should then work properly, after which you should be able revert back to the original CPU count.


You will have to have a backup of the VM to do this.
For reference, I'm running on an Intel 12th gen host (the cpu with P- & E- cores).

Fratod68
Contributor
Contributor

You can also set back the compatibility of the VM. Then change to 1 CPU and afterwords resetting the number of CPUs you want. You can also change the value numvcpu="n" to "1" in the configuration file (Text) of the VM (*.vmx). That worked for me.

0 Kudos
Peter1226
Contributor
Contributor

I resolved this issue by using the same disk files to re-create the VM.

This error occurred on a Win 11 host and W10 guest with VMWare WS Pro 17 which is upgraded from 16.2. I have many VM guests and all work OK except for this one Win10 guest. The odd thing is that I can run it without problem. Once it started, I can view the VM settings. The error surfaces only when the guest is off and I try to Edit VM "settings". After I got the error, VMWare WS Pro will quit. Restarting Host is no help. This makes me think it is VM configuration files that are corrupted and caused the problem

0 Kudos
iScrubz
Contributor
Contributor

All VM's I convert from 16.x to 17.x

0 Kudos
iScrubz
Contributor
Contributor

That doesn't work for me.

0 Kudos
Psychoticsixx
Contributor
Contributor

I was able to change back to the 16.2 hardware compatibility to resolve the issue. I'm using the 17 Pro version.

0 Kudos
sunjwvista
Contributor
Contributor

After some comparison, I found the real bug is missing cpuid.coresPerSocket = "n" in vmx file.

Workstation 16 seems to be OK with no cpuid.coresPerSocket = "n", but 17 seems to be restrict with that when VM compatibility level is 17.

AAR75
Contributor
Contributor

This might help some folks, running VMware Workstation Pro 17.0, temporary solution is rolling back the VMX config file virtualHW.version setting. Tested on a few different VMs (Windows and Linux), after installing 17.0 upgraded the VM hardware compatibility to 17.x which set virtualHW.version = "20" that is when started getting the unrecoverable error message. In the config file changed back virtualHW.version = "19" to VM hardware compatibility 16.2.x. Now everything is running properly. Welcome hearing back if anyone has the same result.

sunjwvista
Contributor
Contributor

Just add cpuid.coresPerSocket = "1" to your VMX config file.

ShuaiY
Contributor
Contributor

The same here as I just finished update this morning. My win-11 VM has just 1 CPU core anyway but the vmx file is encrypted...I can not manually adjust it. Any options other than waiting for the bug fix?

0 Kudos
qqvv0909
Contributor
Contributor

i have same problem. i have three virtual machines. only one has this problem after i update the v16 to v17. C:\Users\zjp22\Desktop\2022-11-22 09_06_30-Greenshot.png
0 Kudos
qqvv0909
Contributor
Contributor

only oneC:\Users\zjp22\Desktop\2022-11-22 09_06_30-Greenshot.png
0 Kudos
MaxPaschetto
Contributor
Contributor

Also, as per AAR75 answer, If you don't know what it was the previous value you can try this reference:

https://kb.vmware.com/s/article/1003746

 

0 Kudos
spicerlabs
Contributor
Contributor

It's completely working fine with hardware compatibility 16.2.x version but its crashes when it's set to 17.x version. So I've powered off the VM, change the compatibility from 17 to 16.2, made the required changes, and again changed the Hardware version to 17 then powered on the VM. Let me know if this worked for you.

This worked for me. I'm using VMware Workstation 17 Pro with Windows 11 Pro.

0 Kudos