2milk
Contributor
Contributor

Unable to connect to the MKS: Login (username/password) incorrect

Jump to solution

I am trying to use the VMware workstation 12, connect to server functionality but I get that error message.

My desktop pc (host) is running windows 7, and running VMware workstation 12. I have shared one of my virtual machines. I have enable port, 443, 902, and 903 on my router. I have temporarily turned off my firewall.

When I try to connect to the host from my laptop running Kubuntu and Vmware workstation 12, I am able to connect to the host, I'm able to see my shared VM and I'm able to turn it on and off but that is pretty much it. I cant actually use the VM because i get the message in the title.

Can someone help me out? Thank You.

1 Solution

Accepted Solutions
2milk
Contributor
Contributor

Found a solution.

In host machine (windows)

Open notepad as admin

edit the file in:

C:\ProgramData\VMware\VMware Workstation\config.ini

Change:

authd.client.port = "903"

To:

authd.client.port = "902"

Save

Unable to connect to the MKS: Login(username/password)incorrect - Spiceworks

View solution in original post

10 Replies
2milk
Contributor
Contributor

Found a solution.

In host machine (windows)

Open notepad as admin

edit the file in:

C:\ProgramData\VMware\VMware Workstation\config.ini

Change:

authd.client.port = "903"

To:

authd.client.port = "902"

Save

Unable to connect to the MKS: Login(username/password)incorrect - Spiceworks

View solution in original post

Ajzimmerman
Contributor
Contributor

Doesn't work.

0 Kudos
GingkoBiloba
Contributor
Contributor

Hello,

This solution works for me, thank you very much.

However I need to apply it again each time I upgrade VMWare to a new version.

Why couldn't we have the VMWare developers fixing this problem ?

Gingko

0 Kudos
Ajzimmerman
Contributor
Contributor

The solution for me was to have AD setup with correct DNS.

Vcenter utterly depends on it.

Also had to have vcenter in AD, and the hosts as well.

I was viewing it from another subnet... I also added the other domain's A records to a forward lookup on our subnet.

All of those things fixed this issue, not the 902 stuff..

andrewiassur
Contributor
Contributor

does anyone have this solution for linux ubuntu 16.04

0 Kudos
Eloyo79
Contributor
Contributor

Hi this solution did not work for me. Any other suggestions?

Workstation: Windows 10 x64

Product: VMWare Workstation Pro 14

I used to be able to connect to vCenter using Workstation 12 without issue, now I've bought licenses for 14 and I haven't made any progress over the past few days.

0 Kudos
Vmwarewindowinf
Contributor
Contributor

You just put host entry of the esxi server in your dns of local desktop.
Location:- C:\Windows\System32\drivers\etc\hosts
Like:
192.168.225.102 esxi2.testlab.in
192.168.225.103 esxi3.testlab.in

After that problem has been resolved.

Unable to connect to the mks login (username/password) incorrect

0 Kudos
cmaier1
Contributor
Contributor

There is definitely a problem with Workstation Pro 14.
Was working with version 12.5 and I am able to access the ESXi hosts with vSphere client

Verified the config.ini and there was no change (still showing "902")

De-installed version 14 and re-install 12.5 and it works just fine.

De-installed 12.5 again completely and re-booted before re-installing version 14 and no change, still get the "Unable to connect to the MKS:Login(username/password) incorrect".

Not a DNS issue, doesn't work with FQDN nor the ip address.

Update, Install Workstation Pro 14 for Linux (Installed with Ubuntu 16.04) and get the same error so the issue is not just with the Windows version.

Update 2, Installed an ESXi 6.5 host and the console works with Workstation 14 Pro, so there is an issue connecting to older ESXi hosts!

So found the issue, what is the solution?

Setting on the older ESXi hosts?

Compatibility with WS 14 Pro? Will this be fixed?

0 Kudos
Ashz
Contributor
Contributor

I read through quite a number of posts referencing same sort of errors, here is the fix i tried and it worked

Trouble is vcsa is not able to connect to the esx host when the connection is being attempted .

This mostly happens when the previous session you connected wasn't disconnected properly.

Just do a vmotion and move the vm to another host. This should release the old session and you no longer should get the MKS error.

-AT
0 Kudos
bsnvmw
VMware Employee
VMware Employee

Thanks this was the solution for me also. I had to add the ESXi hosts FQDN to the drivers\etc\hosts file on my laptop. Cheers!

0 Kudos