VMware Communities
pvandoren
Contributor
Contributor

Unable to Connect USB Device "..." to the virtual Machine (error code 4) WS 6.5

Hi All,

Since upgrading to 6.5, I've come across an anoying issue with USB connectivity, About 50 % of the time, when I try to connect a USB device to a guest, I get the error message " Unable to connect USB device "..." to the virtual machine (error code 4), Please contact VMware, Inc. technical support for assistance.

Then I get a second message. An Error was encountered while attemptinga connection operation for a USB device between the host adn guest. Please check the Windows Device Manager for the current stateus of teh USB devices attached to the host.

This seems to occur when ever I plug a device in the host that doesn't have a driver in the host system, but does in the guest. IE I have some USB key dongles, that I don't have the software installed in the host, but I do in the guest, I usually attach them right away to the guest, and never install the driver in the host.

This has always worked with no troubles in version 5.5 and 6.0.x

The vmware-xxx-yyy.log shows the following about this error

Oct 14 13:34:54.453: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:34:54.531: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:34:54.656: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:34:54.750: vmui| VMDlg::ShowDialog: Unable to connect USB device "Altera USB-Blaster" to the virtual machine (error code 4). Please contact VMware, Inc. technical support for assistance.

Oct 14 13:34:54.750: vmui|

Oct 14 13:34:56.359: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:35:01.937: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:35:01.984: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:35:02.203: vmui| VMDlg::ShowDialog: Unable to connect USB device "Altera USB-Blaster" to the virtual machine (error code 4). Please contact VMware, Inc. technical support for assistance.

Oct 14 13:35:02.203: vmui|

Oct 14 13:35:02.203: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:46:48.312: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:46:48.343: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:46:48.421: vmui| VMDlg::ShowDialog: An error was encountered while attempting a connection operation for a USB device between the host and guest. Please check the Windows Device Manager for the current status of the USB devices attached to the host.

Oct 14 13:47:43.484: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:48:05.265: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Oct 14 13:48:05.312: vmui| Disconnect check in progress: C:\Documents and Settings\pvandoren\My Documents\My Virtual Machines\ITRON_XPPRO\Windows XP Professional.vmx

Thanks

Pete

Reply
0 Kudos
3 Replies
RandyAndy
Contributor
Contributor

I'm sorry that I cannot help you solving the problem!

But I have exactly the same problem running Vista Ultimate 64 Bit Edition, VMWare Workstation 6.5.2 on HP Laptop EliteBook 6930p.

When I try to connect the BlueTooth Adapter from the host to the guest, I am getting the error message "An Error was encountered while attempting a connection operation for a USB device between the host adn guest. Please check the Windows Device Manager for the current stateus of teh USB devices attached to the host."

The driver for this adapter is installed at the guest (XP Pro 32 Bit) but I think not (correctly) at the host (it seems to be a problem with the 64 bit driver).

Like you have written, this was no problem in earlier versions of vmware workstation.

I would be very happy, if somebody knows a workaround.

Best regards

Andi

Reply
0 Kudos
Eku2
Contributor
Contributor

Likewise.

Curriously, sometimes, even without a driver in the host, I am able to connect the usb device to the VM guesf for a specific usb device. It is however consistant. This particular device will not connect to the guest and I dont want the drivers installed in the host.

Reply
0 Kudos
RandyAndy
Contributor
Contributor

hello eku2,

I found a solution on my side.

in my case, the problem was the chipset driver for the host machine.

i reinstalled the os and tested without any driver and i had no problems.

step by step i have installed the drivers and i got the behaviour, after installing the chipset driver.

i found an older driver for the chipset on the host machine and since using that older driver, i had no more problems.

i hope, that could help you finding a solution on your side.

bye and a nice weekend

andi

Reply
0 Kudos