vm_dude123
Enthusiast
Enthusiast

Ubuntu Host, WinXP Guest Freezes every few seconds

I'm running Ubuntu 10.04 (32bit), but this also happened under Ubunu 9.10. I am running VMWare workstation 7.1, but it also happened under 7.0.0 and 7.0.1.

My WinXP x32 guest has a tendency to lock up for about 2-3 seconds very often, perhaps as much as every 10 seconds...sometimes every 30 seconds.

I was hoping it would go away with Workstation 7.1, but it has not.

Any suggestions? I was very happy with 6.x Workstation on Ubuntu for years...but this is almost unsuable anymore....

Tags (4)
0 Kudos
12 Replies
Scissor
Virtuoso
Virtuoso

Anything interesting in your Host's Event Logs ( /var/log/messages ) around the time that your Guest freezes? Please attach the vmware.log file from the directory containing your Guest.

0 Kudos
Dell670guy
Contributor
Contributor

I am running VMWare 6.5 and am seeing precisely the same symptoms. My VM running XP freezes every 3-10 seconds and when it freezes, it can freeze as long as 20 seconds.

It only happens on my Dell precision laptop.

0 Kudos
louyo
Virtuoso
Virtuoso

PMJI:

Does system monitor show you anything when it freezes? Like CPU usage, swap file growth, etc?

Are your VM's running on the same disk as the host OS? That can make a significant difference.

I don't see anything like that unless I open 4 or 5 VM's and start to hit the memory limit, although I have to set swappiness to 0 to avoid disk cache growing to the point that it starts swapping.

I am running on a Quad core Xeon, Ubuntu 9.10.

Lou

0 Kudos
Dell670guy
Contributor
Contributor

Hi Lou,

I will try looking at system monitor. I have a duo core system and plenty of system resources on my host system. I have 4 Gig Ram and gobs of extra disk space and should have plenty of cpu time. I have also ruled out viruses or malware etc. as I'm running on a work machine that only goes to extremely safe web sites. I am only running a single XP VM that isn't doing anything fancy. What is the "swapiness" setting?

Thanks Paul.

0 Kudos
AWo
Immortal
Immortal

Install the VMware Tools if you haven'Ät done so, yet.

Reduce the number of vCPU's to one if more are assigned to your guests. If that helps, check if you need to change the Windows HAL, as well. That might be the case depending on which HAL is used, now.


AWo

VCP 3 & 4

\[:o]===\[o:]

=Would you like to have this posting as a ringtone on your cell phone?=

=Send "Posting" to 911 for only $999999,99!=

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
louyo
Virtuoso
Virtuoso

>>What is the "swapiness" setting?

Useful if your host is swapping in order to accommodate disk caching. Linux seems to do this more than Windows but they will both do it. Tends to show up if you create or modify large files, like a Windows system backup. You would only need to consider this if system monitor shows swapping.

Unless you installed with PAE, you may not be getting all 4GB of RAM.

If what aWO said doesn't resolve your problem, run with system monitor and see what it tells you. You can also see swapping with top.

>>sudo sysctl vm.swappiness

will show you the setting, default is usually 60

>>sudo sysctl vm.swappiness=0

will discourage swapping until it is really necessary, not stop it altogether.

Again, if your problem is not due to swapping, that is of no value.

Lou

0 Kudos
vm_dude123
Enthusiast
Enthusiast

Thank you all for your advice. I still have the original problem. Additional details:

1) running with 1 cpu

2) running with swap OFF on both the Ubuntu host and WinXP guest

3) latest version of vmware tools

4) latest version of vmware workstation -- 7.1.1 (has happened with every version since 6.5)

I am at my wits end here....

0 Kudos
AWo
Immortal
Immortal

Disable all daemons on the host you do not need for testing.

Disable all services in the guest you do not need.

Open "esxtop" on the host, press "p" and check if a process consumes a lot of CPU power every 30 seconds.

Open the Task Manager in the guest and try to check the sdame there.


AWo

VCP 3 & 4

\[:o]===\[o:]

=Would you like to have this posting as a ringtone on your cell phone?=

=Send "Posting" to 911 for only $999999,99!=

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
vm_dude123
Enthusiast
Enthusiast

How do I get the esxtop program installed on my VMware Workstation Ubuntu host?

0 Kudos
tester711
Contributor
Contributor

Hi,

another similar case here.

Host: Win XP, guests: FreeBSD, Ubuntu, CentOS

All guests freeze for 3-4 seconds every 10-12 seconds.

The only exception they are not freezed is when the user who runs VMware Workstation (Administrator) has their desktop active.

That is, freezing is observed when I switch from Administrator to my normal limited user and leave the VMware running in the background Administrator's session.

Previously, with WS 6.5 all was OK.

0 Kudos
tester711
Contributor
Contributor

And BTW - all VMs freeze simultaneously,

And CPU usage on Host actually DROPS during the freezes.

0 Kudos
vm_dude123
Enthusiast
Enthusiast

OK, I can't take it anymore.  I've tried everything to get this to work.  I am done sending vmware my money, at least for desktop virtualization.

My workaround can be found here:

http://www.virtualbox.org/

Frankly, after seeing how much faster and simpler it is, I feel like an idiot not switching a long time ago.

0 Kudos