varnken
Contributor
Contributor

USB devices not being seen by Workstation if plugged-in on Thunderbolt Dock

Using Workstation 12.5.7.

I have a Dell Precision 5520 laptop connected to a docking hub via Thunderbolt.  I have a 4-port unpowered USB hub plugged-in on the docking hub.

For some reason, VMware Workstation cannot see any USB devices in the Removable Devices list when the hub is plugged into the dock.  If I connect the hub directly into a USB port on the laptop, then VMware Workstation can see the USB devices on the hub.  If I plug the USB devices directly into the dock, then VMWare can also see them.  How do I get VMware to see these devices on my hub when it is plugged-in to the dock?

0 Kudos
6 Replies
RDPetruska
Leadership
Leadership

What host OS?

Does the host see the devices when connected to the hub through the dock?

0 Kudos
varnken
Contributor
Contributor

The host OS is Windows 10.  It can see the USB devices on the hub when it is plugged into the dock.  However, Workstation does not see them in the Removable Devices list.

0 Kudos
DougGerlach
Contributor
Contributor

Were you able to find a resolution to this?  I am experiencing the same issue with a Thunderbolt dock.

0 Kudos
andersdl
Contributor
Contributor

I have a 5220 Dell with a TB16 Thunderbolt 3 docking stations.  VMware workstation Pro 12.5.9 in the removable devices  I can not see any USB storage devices 2.0,3.0 Sticks or external WD 3.0 drives when plugged into the docking station.  When the devices are plugged into the laptop ports I can see them. Does VMWARE have any fixes for this issue?

0 Kudos
VLvyFw
Contributor
Contributor

I can replicate this bug. HP Spectre, Win10, Vmware Workstation 14.1.1

0 Kudos
andersdl
Contributor
Contributor

No, I did get to VMWare support an they confirmed that ThunderBolt 3 is not supported in VMWARE. There does not seem to  be any KB articles about this on the support site. I do not have any official VMWARE support, someone that has should log a case with support to see if they are going to fix it or at least publish something about it.  For Now I just plug a USB hub into my Laptop USB to get extra USB ports. For me the TB16 lets me run 3 displays which outweights accessing the USB Ports.  Just an aside I did previously have the smaller 3.1C docking station and you could see the USB port on it. It only did 2 displays and was little short on power so I upgraded to the TB16 TB3 dock.

0 Kudos