VMware Communities
Pablo_1980
Contributor
Contributor

Trying to run a game through vmware workstation 17 pro not working

Hello all.

I'm trying to run a game inside a virtual machine and I'm getting a error: "Failed to initialize graphics device. Please ensure your PC meets the minimum system requirements and your drivers are up to date"

I tried to look for vmware workstation 17 pro gpu passthrough but I couldn't find something that solved my problem.

I disabled 3d acceleration and game starts but there's a moment where hangs the computer and I have to poweroff with the tools of vmware workstation.

Could someone help me and give me a hand please?

Regards and thanks

 

 

Reply
0 Kudos
9 Replies
Pablo_1980
Contributor
Contributor

I have activated in windows hosts hardware acceleration as this article says https://docs.vmware.com/en/VMware-Workstation-Pro/17/com.vmware.ws.using.doc/GUID-EA588485-718A-4FD8... and no luck, diablo2 keeps crashing. Should I try with a older version of workstation pro?

Regards and thanks

Reply
0 Kudos
RDPetruska
Leadership
Leadership

Host OS/version?  Guest OS/version?  Any errors in the vmware.log file?  I assume you have the VMware Tools installed in the guest?

Reply
0 Kudos
Pablo_1980
Contributor
Contributor

Both Host and Guests are windows 10 pro 64 bits.

I have installed vmware tools in the guest.

I'm going to search how to look those logs.

Regards and thanks

Reply
0 Kudos
Pablo_1980
Contributor
Contributor

These are the vmware logs.

I was looking for errors to try to see what's happening but there are a lot of errors.

Regards and thanks

Reply
0 Kudos
Pablo_1980
Contributor
Contributor

I have searched in the logs for the diablo2 failure: Fail to initialize but I didn't found anything with that string. I will keep searching for errors.

Regards and thanks.

Reply
0 Kudos
Pablo_1980
Contributor
Contributor

Hello again. Searching in the vmware logs, I found this, that I'm not sure if it will be the cause that diablo2 can't run:

2023-08-30T13:03:52.769Z In(05) svga SWBScreen: Screen 1 Destroyed: xywh(0, 0, 2177, 1248) flags=0x2
2023-08-30T13:03:52.771Z In(05) svga SVGA thread is exiting the main loop

2023-08-30T13:03:52.771Z In(05) mks SWBWindow: Window 0 Destroyed: src screenId=-1, src xywh(0, 0, 2177, 1248) dest xywh(0, 0, 2177, 1248) pixelScale=1, flags=0xF
2023-08-30T13:03:52.772Z In(05) mks SWBWindow: Number of MKSWindows changed: 0 rendering MKSWindow(s) of total 1.
2023-08-30T13:03:52.772Z In(05) mks SWBWindow: Window 1 Destroyed: src screenId=-1, src xywh(0, 0, 2177, 1248) dest xywh(0, 0, 2177, 1248) pixelScale=1, flags=0x10
2023-08-30T13:03:52.772Z In(05) mks GDI-Backend: stopped by HWinMux to do window composition.
2023-08-30T13:03:52.772Z In(05) mks SWBWindow: Number of MKSWindows changed: 0 rendering MKSWindow(s) of total 0.
2023-08-30T13:03:52.775Z In(05) vmx MKS/SVGA threads are stopped

 

Could it be the cause I can't play inside a virtual machine? I'm going to try play another games and see what happens.

 

Regards and thanks.

Reply
0 Kudos
Pablo_1980
Contributor
Contributor

I have tested diablo3 and it works so it must be something wrong with the setup of diablo2.

I keep looking for the reason it can't run.

Regards and thanks

Reply
0 Kudos
Pablo_1980
Contributor
Contributor

I also found a dxdiag log inside diablo2 resurrected game.

I found these traces of error:

Windows Error Reporting:
+++ WER0 +++:
Depósito con errores INVALID_REQUEST, tipo 0
Nombre de evento: WindowsServicingFailureInfo
Respuesta: No disponible
Identificador de archivo .cab: 0

Firma del problema:
P1: 10.0.19041.3266:1
P2: 0x800F0984 0x800F0984 Matching binary: wvkrnlintvsp.inf missing for component: amd64_dual_wvkrnlintvsp.inf_31bf3856ad364e35_10.0.19041.3086_none_7ea5b9ade3804b2d
P3: ??›??????????????????????????????????
P4:
P5:
P6:
P7:
P8:
P9:
P10:

Could it be the problem?

Regards and thanks.

Reply
0 Kudos
Pablo_1980
Contributor
Contributor

More error traces:

8/30 17:51:43.923 [Prism/4] [<>:0]: prism: Error Invalid (0x887a0004): pm_dx12::Instance::CreateDevice: D3D12CreateDevice Failed

8/30 17:51:43.923 [Prism/4] [<>:0]: prism: Error Invalid (0x887a0004): pm_api::PlatformInstance::CreateDevice: Unsupported API Backend

8/30 17:51:43.923 [D2Prism/5] [<>:0]: Fatal: failed to create device.
8/30 17:51:43.923 [D2Prism/4] [<>:0]: Available GPU vendor ID 5549 driver version 262145l device name VMware SVGA 3D
8/30 17:51:43.923 [D2Prism/4] [<>:0]: Available GPU vendor ID 5140 driver version 1247873764l device name Microsoft Basic Render Driver
8/30 17:51:45.394 [D2Win/5] [<>:0]: Fatal failure during initialization.

Any idea? It seems like if dirextx12 was incompatible with running the game but windows 10 brings directx from 9 to 12.

I'm not sure where is the problem, windows, nvidia, vmware or diablo2.

Regards and thanks

Reply
0 Kudos