Highlighted
Contributor
Contributor

The host high-resolution timer device (/dev/rtc) is not available (Operation not permitted) on Ubuntu 8.10

Hi all.

Whenever I start a VM on my VMware workstation (version 5.5.9), I get the following error message:

The host high-resolution timer device (/dev/rtc) is not available (Operation not permitted). Without this device, the guest operating system can fail to keep time correctly. For more information, see .

My VM's also run very slowly and time seems to lag behind.

I've checked that the /dev/rtc device does exist. (It's a symlink to /dev/rtc0 ).

I've also tried to run vmware as root in case it was a permissions problem, but I still get exactly the same error.

I saw the following logs in dmesg which might be related (Sorry about formatting, I'm not sure how to get it right):

[http://132455.983263|http://132455.983263] [9648]: host clock rate change request 0 -> 19
[http://132455.984987|http://132455.984987] [9648]: host clock rate change request 19 -> 1043
[http://132455.985017|http://132455.985017] [9648]: /dev/rtc enable interrupt failed: -1
[http://132501.392795|http://132501.392795] [9648]: host clock rate change request 19 -> 1024
[http://132501.393471|http://132501.393471] [9648]: /dev/rtc enable interrupt failed: -1
[http://132501.394903|http://132501.394903] [9648]: host clock rate change request 19 -> 1043
[http://132501.394921|http://132501.394921] [9648]: /dev/rtc enable interrupt failed: -1

Kernel version: 2.6.27-11-generic

This error (and degraded performance) is really annoying.

Any advice would be appreciated.

Thanks,

0 Kudos
27 Replies
Highlighted
Virtuoso
Virtuoso

What OS are you running on your Host? Edit -- It appears that you're running Ubuntu as the Host and some unknown OS as your Guest

0 Kudos
Highlighted
Immortal
Immortal

What happens if you use WS 6.5.2?

Make a backup of your VM's and download the 30 day eval of WS 6.5.2, if it resolves your issue, then you will just need to upgrade

0 Kudos
Highlighted
Enthusiast
Enthusiast

There is now this issue with 6.5.3 after upgrading from 6.5.2 on ubuntu 9.04 32-bit. What can we do. The rkernel version is 2.6.28-15-generic.

Thanks.

0 Kudos
Highlighted
Contributor
Contributor

Same problem here.... running Ubuntu 9.04 and after upgrade to Workstation 6.5.3 I started to get this error: The host high-resolution timer device (/dev/rtc) is not available (Permission denied). Without this device, the guest operating system can fail to keep time correctly. For more information, see . The error didn't appear while using 6.5.2.

0 Kudos
Highlighted
Enthusiast
Enthusiast

I also started seeing this problem after upgrading to Workstation 6.5.3. Host OS is Ubuntu 8.10. Guest OS is WinXP.

0 Kudos
Highlighted
Contributor
Contributor

Hi All,

For what's it worth, I too started getting this error on an Ubuntu 9.04 (kernel 2.6.28-15-generic) host running Windows 2008 Standard server (w/o Hyper-V) as guest--after upgrading to Workstation 6.5.3, build185404.

~$ dmesg | grep /dev/rtc produces:

... /dev/vmmon(20587): /dev/rtc open failed: -13 (square brackes changed to parens for rich text editor's sak0

If I run Workstation as root (sudo vmware), I don't see any additional "open failed" messages. Could this be a permissions issue?

Any suggestions appreciated,

Scott

0 Kudos
Highlighted
Contributor
Contributor

+1

Upgraded yesterday from 6.5.2 to 6.5.3 build-185404 and are now experiencing the very same thing as ScottNZ

Host is Ubuntu 8.10 (2.6.27-14-generic) and Guest is WinXP Sp3

0 Kudos
Highlighted
Contributor
Contributor

Same problem here. I upgraded from VM Workstation 6.5.2 to 6.5.3 on a Fedora 7 host. All my linux guest OSes now complain of /dev/rtc not available when I boot them. I have the error on Ubuntu 8.04 guest, Ubuntu Server 9 guest, PCLinuxOS guest, and Fedora7 guest.

I guess I have to downgrade back to 6.5.2 until this is fixed.

0 Kudos
Highlighted
Contributor
Contributor

Same here - VMs running very slow after upgrade to WS 6.5.3 and on reboot they complain about RTC. Tried chmod on /dev/rtc and vaious hacks to no avail.

Same problem with 2.6.28, 2.6.29 and 2.6.30 kernels, same problem with Ubuntu 9.04 and Fedora 11 hosts.

Only solution for now for me is to downgrade, which is a pain. Note for Fedora 11 users on 6.5.2 to use Krellan's patch (http://communities.vmware.com/thread/208963)

(Further note - I know Fedora is not officially supported but it's a shame WS 6.5.3 a.) needs a bodge to install and b.) seems to me given this and the installation fiasco a bit ropey. When's 6.5.4 due?)

0 Kudos
Highlighted
Contributor
Contributor

Same here. Bug. What's status on fix?

0 Kudos
Highlighted
Contributor
Contributor

Yes this issue has been open for over five months now. When is VMWare going to give us some kind of response or direction on this? VMWare Support: are you listening??

0 Kudos
Highlighted
Contributor
Contributor

I have the same problem here.

Host: Ubuntu 9.04 64Bit

Guest: Windows XP SP3

0 Kudos
Highlighted
Contributor
Contributor

Same here:

VMWare Workstation 6.5.3, host: Ubuntu 9.04, guest: XP, Win7, ... it happens on all

Hello VMWmware - Support - you'r working? greetings from orleando

0 Kudos
Highlighted
Enthusiast
Enthusiast

I have the same problem on an Opensuse host after upgrading to WS 6.5.3 build-185404.

Host: Opensuse 11.1, Kernel 2.6.27.25, Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz.

Guest : Win XP

0 Kudos
Highlighted
Contributor
Contributor

This is due to the default value of max-user-freq being too small (64) by default. Running the following (as root) should work:

$ echo 1024 > /proc/sys/dev/hpet/max-user-freq

You need to adjust the above path to match the device your system is using, eg rtc instead of hpet.

To make this change persistent across reboot edit /etc/sysctl.conf.

0 Kudos
Highlighted
Enthusiast
Enthusiast

edit /etc/sysctl.conf and....

a) plant posies

b) bath the dog

c) say a prayer

d) none of the above

0 Kudos
Highlighted
Expert
Expert

--Semi-agreed, but if you're not confident enough to change a system file in Linux you might want to rethink your host OS. Smiley Wink

--May be safer to do what I did, and put the echo statement in /etc/init.d/rc.local or the equivalent.

./. If you have appreciated my response, please remember to apply Helpful/Correct points. TIA

./. If you have appreciated my response, please remember to apply Helpful/Correct points. TIA
0 Kudos
Highlighted
Contributor
Contributor

Thanks for the tip elicollins and others. This is something I remember now thanks to your reminder from the very early days of workstation.

However the warning on VMware 6.5.3 specifically said it was unable to open the high precision timer device, and prior to 6.5.3 I had not seen this specific warning.

Does anyone know conclusively whether the max-user-freq change solves this specific warning in 6.5.3?

I ask because 6.5.3 is such a pain to reinstall on Fedora 11 (workaround necessary) and also because after each upgrade, custom vmnet settings are lost.

(If anyone from VMware is actually reading this would appreciate a.) an upgrade path that preserved vmnet configuration, i.e. doesn't randomly change the subnet for private, completely lose custom nets, loses bridging rules and b.) a fix to 6.5.3. installation so it works on Fedora - thanks)

0 Kudos
Highlighted
Contributor
Contributor

Let me just clarify that the max-user-freq change has potentially fixed a long running performance issue with a specific machine configuration we use on WS 6.5.2

But I'm wondering now whether it's "safe" to upgrade to 6.5.3 or whether I will still see the "new" warning that about high precision timer that I have only ever seen in WS 6.5.3 (even though the core issue could have been there in 6.5.2 and earlier).

0 Kudos