Faize
Enthusiast
Enthusiast

The default sound device cannot be opened: A device ID has been used that is out of range for your system. Sound will be disconnected.

Jump to solution

I'm getting the error listed in the title with a Windows 7 x64 host running Workstation 7.1.3 and a Ubuntu guest.

I did make a sound-related hardware change on the host today (used onboard audio instead of USB sound card), but sound works perfectly fine on the host.

0 Kudos
1 Solution

Accepted Solutions
Coder201110141
Contributor
Contributor

I had the exact same problem as well. I have a windows 7 64-bit host, and running Ubuntu quest on VMware Workstation 6.5.

image1.jpg

After playing with the settings a little, this is how I got it to work. In Ubuntu, open the Sound Preferences:

image2.jpg

In the Hardware tab my Profile was set to "Analog Stereo Duplex". I changed it to "Analog Stereo Output" and everything was resolved. I was able to connect the Sound Card!

image3.jpg

View solution in original post

0 Kudos
20 Replies
Faize
Enthusiast
Enthusiast

Oh yes, I should probably mention that I also installed Windows 7 SP1 on the host several days before this, in case it matters.

0 Kudos
WoodyZ
Immortal
Immortal

Just for the the record...

At the present time Windows 7 SP1 is not an officially supported Host or Guest OS for any VMware Desktop Product.

As with any unsupported configurations they should not be used in production systems until fully tested on non-production systems.

That said, as far as the sound device issue, have you tried removing the sound device from the VM and adding it back?  Also may need to remove it from the Guest OS too however I'd first try removing the sound device from the VM and adding it back.

0 Kudos
Faize
Enthusiast
Enthusiast

I tried removing the sound device, uninstalling Tools, adding the sound device back, and reinstalling Tools. The problem persists.

To make matters worse, none of my Windows guests have this problem.

0 Kudos
WoodyZ
Immortal
Immortal

To make matters worse, none of my Windows guests have this problem.

That sounds absurd. Smiley Happy How does this make matters worse?

0 Kudos
Faize
Enthusiast
Enthusiast

I was thinking in a "if the problem is global, at least it'll be easier to find and reproduce" developer mindset for a moment there :smileyblush:

0 Kudos
Coder201110141
Contributor
Contributor

I had the exact same problem as well. I have a windows 7 64-bit host, and running Ubuntu quest on VMware Workstation 6.5.

image1.jpg

After playing with the settings a little, this is how I got it to work. In Ubuntu, open the Sound Preferences:

image2.jpg

In the Hardware tab my Profile was set to "Analog Stereo Duplex". I changed it to "Analog Stereo Output" and everything was resolved. I was able to connect the Sound Card!

image3.jpg

View solution in original post

0 Kudos
bonobo201110141
Contributor
Contributor

I had the same problem and managed to solve it completely with advice from another post.

1)  In Ubunutu

System-->Preferences-->Sound-->Hardware-->Profile

Change "Analog Stereo Duplex" to "Analog Stereo Output".

2) To fix addition problem of losing connection at login:

Disable pulse audio in gdm (gnome login manager)

http://www.debuntu.org/how-disable-pulseaudio-and-sound-gdm

Faize
Enthusiast
Enthusiast

That would be the workaround Coder suggested and the one I used.

Still, I'm disappointed that VMware did not fix such an obvious bug in 7.1.4 despite adding official support for Ubuntu 10.10...

0 Kudos
xxxLCxxx
Contributor
Contributor

I had the same problem (Win7, 64-bit SP1 as host and Ubuntu 11.04 64-bit as guest). I added an autostart-script that executes:

vmware-toolbox-cmd device enable sound

during login. Not nice, but it works.

0 Kudos
gorussgo
Contributor
Contributor

I'm also running Win 7 64-bit host, VMware Workstation 7.1, and Ubuntu 11 as guest.  Getting same error: "A device ID has been used that is out of range for your system. Sound will be disconnected."  I tried the above suggestion: changing sound preferences from "Analog Stereo Duplex" to "Analog Stereo Output".  Unfortunately, I'm still getting the same error/issue.  I'm a new VMware user as well as Linux illiterate, and am trying to set up this virtual machine in an attempt learn more about both.  Any additional suggestions to correct this sound issue would be greatly appreciated!

0 Kudos
xxxLCxxx
Contributor
Contributor

As I posted before, you can fix this by "restarting the sound" after you logged in.

This should work if you are running GNOME or such (make sure you have the VMware-tools installed

(System => Administration => Synaptic Package Manager - type in vmware in Quick filter and select the following packages

xserver-xorg-video-vmware, open-vm-toolbox, xserver-xorg-input-vmmouse, open-vm-tools, open-vm-source, open-vm-dkms -

reboot after having installed these):

1. Open a terminal window holding down the left Ctrl and Alt key while pressing the T key.

2. Type the following, pressing the ENTER key afterwards:

cd

3. Next type (again - finishing with ENTER) or better paste (copy&paste - right mouse-click: paste):

cat > .config/autostart/enable_vmware_sound.desktop

4. Next type (finishing each line with ENTER) or better paste (copy&paste - right mouse-click: paste):



[Desktop Entry]
Name=Enable VMware Sound
Comment=Start sound on VMware
Exec=bash -c "vmware-toolbox-cmd device enable sound"
Icon=preferences-desktop-accessibility
Terminal=false
Type=Application
StartupNotify=false


5. Finish by holding the left Ctrl key and pressing the D key twice.

6. Log out & log in again - voila ...

PS.: You might want to copy & paste because of dreadful line wrapping!

0 Kudos
WoodyZ
Immortal
Immortal
1. Open a terminal window holding down the left Ctrl and Alt key while pressing the T key.

2. Type the following, pressing the ENTER key afterwards:

cd

What directory are you trying to change to? Smiley Wink

PS.: You might want to copy & paste because of dreadful line wrapping!

If your posting command lines or block of code it is better if you use the controls available to set them so it clear what the full command line looks like or what is a block of code.  Highlight the command line(s) or block of code and then on the Toolbar click the >> and select Syntax Highlighting > Plain.

(Click image to enlarge.)

Syntax_Highlighting.png

0 Kudos
xxxLCxxx
Contributor
Contributor

cd

What directory are you trying to change to? Smiley Wink

This should get you to your home directory ...

If  your posting command lines or block of code it is better if you use the  controls available to set them so it clear what the full command line  looks like or what is a block of code.  Highlight the command line(s) or  block of code and then on the Toolbar click the >>

and select Syntax Highlighting > Plain.

Thanks! I looked for it but I couldn't find it, because the tooltip reads "Insert" (which is slightly misleading - at least it mislead me).

0 Kudos
vmQuint
Enthusiast
Enthusiast

I found a system-wide solution to this for my system.

http://communities.vmware.com/thread/406063?tstart=0

0 Kudos
digerpaji
Contributor
Contributor

Coder's method will work on Ubuntu 10 LTS, but it will not work on Ubuntu 12 LTS, because they take out the option for switching from Duplex.

To get the sound going in Ubuntu 12.04 LTS, you need to first install "pavucontrol"

You can do so by typing the following in the terminal:

sudo apt-get install pavucontrol

After you have installed pavucontrol you can run it by typing the following in the terminal:

pavucontrol

Go to the configuration tab, select Analog Stereo Output

And you should be good to go.

0 Kudos
Faize
Enthusiast
Enthusiast

Thanks for sharing the new workaround, digerpaji.

@VMware, this bug is now over two years old!!!! Is it ever going to be fixed?

0 Kudos
DeMixx
Contributor
Contributor

hi,

the workaround of digerpaji doesn't work on my system. Host Windows7 x64 Professional, Guest Ubuntu 12.04 LTS x64. I've installed pauvcontrol and changed to analog stereo output, but the errormessage is still as in the subject and the sound doesn't work 😞

Any further ideas?

thx,

DeMixx

0 Kudos
DeMixx
Contributor
Contributor

+++ BREAKING NEWS +++  🙂

It works. After changing to analog stereo output via pauvcontrol I disabled the sound card in the vm-settings and re-added it. Now it is "connected" and works.

But: After every restart of the guest the sound card is disconnected, I have to connect it manually.

Any ideas how to automatically connect it?

cheers,

DeMixx

0 Kudos
Justart
Contributor
Contributor

Hi,

I have host Windows 7 x64 HomeBasic and guest Ubuntu 12.04 LTS.

The working method for me was to remove pulseaudio and use alsa for sound output:

sudo apt-get autoremove pulseaudio

sudo apt-get install gnome-alsamixer


p.s. I use Player 5.0.2, but i think, it should work for Workstation

0 Kudos