avin
Contributor
Contributor

Switching mouse buttons

I've just upgraded from VS 10 to VS 12 Pro.

I want to switch mouse buttons on both host (Win 10) and guest (Win 8.1).

Problem is that when both of them are set to Mouse & touchpad /Mouse/Select your primary button -> right, the host's primary button is right but the guest's one is the left!

Any suggestions?

0 Kudos
2 Replies
avin
Contributor
Contributor

This appears to be a design bug. The problem AFAIU is that when the host buttons are switched, VMWare expects the guest to avoid switching the mouse buttons, affecting a "hierarchy" view: There is no need to switch the buttons at each guest, as they are already switched "system level" wise by the host.

However, when the host is switched and the guest isn't, and both are Windows machines (in my case - the host is Windows 10 and the guest is Windows 8.1), windows sync switches either of them to the same state of the other. So, there's a "double negation" and the mouse in one of them is not switched.

The workaround is to disable syncing of the mouse setting. At Windows 8.1 it's the "Other Windows settings File Explorer, mouse, Printer and more." At WIndows 10 it's "Other Windows settings". Both are at the bottom of the list.

H.T.H

0 Kudos
avin
Contributor
Contributor

Same problem again. I'm so happy I've documented the solution!

0 Kudos