Kandsmerlin
Contributor
Contributor

Stretch Guest display options in WS15 not available for any guest OS after Windows Vista

I'm having a problem with the stretch guest display option not being available for my Windows 7 VM as well as a few Windows 10 VMs. However, it appears to be available with a Windows Vista VM as well as a Windows XP VM. My question is this: Is this a bug or by design? I really don't want to have to use my Win7 or Win10 VMs as "centered (with borders - no resolution change)" The display elements are incredibly small in that mode and the other mode is not appropriate either due to some older applications that don't scale properly and do not function well with windows 10.

If this is not a bug, then how do I enable stretching for said VMs? Any help would be appreciated.

Tags (1)
37 Replies
xishengzhang
VMware Employee
VMware Employee

Hello, Kandsmerlin

For WS15, "Stretch guest" works for windows guest that is earlier than win7 or linux guest. Regarding win7 or later windows Guest, WS supports DPI sync features which means guest DPI could be synced from Host if the "Automatically adjust user interface size in the virtual machine " under display setting is enabled.

Try "Fit guest now" or "autosize ---autofit guest" under view menu.

Please feel free to let us know if you have any further questions. Thanks

0 Kudos
Super_Kevin
Contributor
Contributor

There have one workaround for your case, but it could only work if your VM is configured as BIOS boot but not UEFI. You can check that by VM->Settings->Options->Advanced, the "firmware type" group.

  1. Install guest OS, vmtools, thinprint... etc.
  2. Shut down your VM, go to VM->Settings->Hardware->display, uncheck "Automatically adjust user interface size in the virtual machine". Active "Options" tab, select General to active Guest Summary page in right panel, change the "Guest operating system" to "Window XP Professional" if your VM is 32bit OS. If your VM is 64bit OS, change it to "Window XP Professional x64 Edition".
  3. Close "Virtual Machine Settings" dialog and open it again, select "Display" to active "Display settings " panel in right, you can find the configuration of "Stretch mode".

It' not recommand to use this method to active stretch guest feature, because the other feature may be broken, such as "VMTool upgrade automitically", "DPI sync" features. If you want to upgrade your VMtools, make sure you change back to the right Guest OS for your VM.

0 Kudos
bkraul
Enthusiast
Enthusiast

This feature should be available for all Windows guest OSes. There is development that requires not having HDPI features in order to match users' environment. Especially when developing with Visual Studio Windows Forms. I cannot have HDPI on and design forms that will look the same on non-HDPI environments, and if I turn HDPI off, I end up with the situation OP describes.

Please make this feature available, across the board, It is already present. Plus, VMWare Fusion continues to support this stretching feature without problems, even for newer Windows OSes. Why not the WS15 version as well? No need to force users to use HDPI. Like for example, why couldn't the stretch feature be available if I uncheck the "Automatically adjust user interface size in the virtual machine" box?

Being unable to have this feature has forced me to scale down my 4K displays.

0 Kudos
Kandsmerlin
Contributor
Contributor

Hello XS:

You said: "Try 'Fit guest now' or 'autosize ---autofit guest' under view menu."

That would defeat the purpose of stretching the guest then -- exactly the feature I so know and loved. As I said in my original post, I need these VMs to be in an un-scaled state for certain apps and for apps that do not work under windows 10 but do so on windows 7. Another reason (which I didn't originally mention) is for streaming software which have set up in the VM where I have to set the resolution down to 720p for my audiences sake. I cannot use the "fit guest now" option as that would introduce scaling within the guest OS. I also cannot use the "autosize/autofit guest" option as that would make the entire desktop entirely too small on a 32" 4K display.

I would appreciate if this feature can be made an option instead of simply forcing us to use a scaling mode that isn't desired.

IMHO, this WS15 "upgrade" isn't really an upgrade if features from previous releases aren't preserved.

bkraul
Enthusiast
Enthusiast

Interesting. There used to be a feature that would allow stretch only if you were in Full Screen mode, for all machines, regardless of OS. This feature is now gone. I kept waiting for the feature to be available while in windowed mode. Looks to me that there needs to be a usability re-evaluation of this feature.

0 Kudos
xishengzhang
VMware Employee
VMware Employee

Hello, Kandsmerlin

Try to uninstall the vmtools from win7 guest, then there will be "stretch and keep display ratio" mode available. I am not sure whether it could fulfill your requirement. Hope this helps. anyway, please let us know your feedback. If not, maybe this could be enhanced in future release.  Thanks.

0 Kudos
bkraul
Enthusiast
Enthusiast

But then shared host folders and VM efficiency functionality are gone. A pretty hacky workaround. Hopefully the future release will be a quick fix release and not a major release for which we will have to shell out another $149.00.

0 Kudos
tomba4
Contributor
Contributor

Just some feedback: this is a deal-breaker for me. I've been upgrading since WS10, but if this option is not restored, I'll not upgrade to WS15.

bkraul
Enthusiast
Enthusiast

In May 2018, I raised the same question, and received absolutely no response from VMWare staff. I recently received a survey from VMWare on things they could improve on. I listed this community as the single most important thing VMware staff should focus on, after all, we are the ones that pay and use the software. Anyway, not meaning to offend anyone. I am just frustrated. I work with the software M-F 8-5pm. Kinda wish it did what it needs to.

0 Kudos
djhopps
Contributor
Contributor

I have exactly the same issue after upgrading to WP15. I use a Windows 7 VM on a Win10 laptop with a 4k display and external second display. Although my laptop correctly scales 4K in Windows 10 to a nice readable and clunk-free form, the VM in Windows 7 will not. In WSPv14 I was able to use the "stretch guest" option to run my Windows 7 VM at 4k which was stretched nicely to fit the screen. Now the only options I have are "autofit guest" which changes the Windows 7 resolution to 4k and renders everything tiny. The obvious solution is to set windows 7 to scale the DPI to 150-200%, however if I do this the the second monitor I use which is running a lower res of 1650x1050 use that scaling too! There's no option on Win7 for setting scaling for different screens.

The only acceptable solution I've found is to lower the resolution of my 4k laptop screen to 1920x1080 BEFORE firing up WP15. The resulting Win7 VM and external monitor then run at the regular DPI and I get a nice scaled screen on my VM

Please bring back the "stretch guest" option! It's crazy that i have a nice 4k screen and I have to change down to 1920 before working on my VM :S

Lev115
Enthusiast
Enthusiast

There have one workaround for your case, but it could only work if your VM is configured as BIOS boot but not UEFI. You can check that by VM->Settings->Options->Advanced, the "firmware type" group.

  1. Install guest OS, vmtools, thinprint... etc.
  2. Shut down your VM, go to VM->Settings->Hardware->display, uncheck "Automatically adjust user interface size in the virtual machine". Active "Options" tab, select General to active Guest Summary page in right panel, change the "Guest operating system" to "Window XP Professional" if your VM is 32bit OS. If your VM is 64bit OS, change it to "Window XP Professional x64 Edition".
  3. Close "Virtual Machine Settings" dialog and open it again, select "Display" to active "Display settings " panel in right, you can find the configuration of "Stretch mode".
bkraul
Enthusiast
Enthusiast

That approach has already been mentioned in this thread by SuperKevin. It does not work for Windows 10 vms that have been upgraded to VM 15 version, as the option to use legacy appears to have been removed, and changing it at the VM Settings level will render the VM unbootable.

pastedImage_0.png

djhopps
Contributor
Contributor

Thanks for the suggestion, but the above doesn't work when you work with a secondary monitor. You can't use a secondary monitor with stretch mode Smiley Sad

0 Kudos
jj0999
Contributor
Contributor

Yes, I too would like the 'Stretch Guest display' options in WS15 to be available for any guest OS. Sometimes I do not need to install the VM Tools and would like to keep my Windows 10 image fresh from any unnecessary software changes. In addition, this is a strange limitation to put as ALL operating systems can benefit from it. There should be no limit to what OS you can use it for.

Please VMware team make Guest Display options work for ALL operating systems!

jj0999
Contributor
Contributor

Yes, this is another thing they have to fix. It should work when a user has multiple monitors and use Stretch mode based on the DPI setting each monitor has. The Stretch algorithm needs to account that not all monitors will use same DPI

0 Kudos
bkraul
Enthusiast
Enthusiast

IMHO, no need to over-complicate the feature. The following options are already visible:

pastedImage_0.png

Just make them available for ALL OSes (obviously, the "Automatically adjust user interface..." would only apply to OSes that support HDPI). Let the user have the say on whether stretch is used over HDPI. That would be perfect.

jj0999
Contributor
Contributor

Hmm I did not see those options. But yes we should be given the option to allow this to work for all OSes, HIDPI or not, Windows or linux or other OS, etc.

I'd like to buy vmware 15 but they must fix this before I can commit to it. I've had nothing but issues with mixed dpi when using workstation 12-14

0 Kudos
3ak
Contributor
Contributor

For me the problem is resolved.

Don't look in Preferences > Display... It's just UI. It doesn't matter.

Go to C:\Users\%USERNAME%\AppData\Roaming\VMware\preferences.ini

Check for string: pref.autoFitFullScreen = "stretchGuestToHost"

That's all.

Sorry for my English.

bkraul
Enthusiast
Enthusiast

@3ak, you da real MVP. This helps with the full screen situation. At least it allows me to work on full screen with my machines without having to jump through hoops (faking WinXP, for example) to be able to work. I hope though that vmware will listen and truly properly resolve this situation soon.

0 Kudos