Highlighted
Contributor
Contributor

Since Windows 10 1903 is now officially out, when will Workstation be upgraded to work with it?

Last week the final Windows 10 1903 was released via MSDN for developers. Needless to say, many of us are upgrading to test / develop with that new feature update.

I've had to migrate all my VMs to Hyper-V in order to be productive but I really prefer VMware Workstation.

Any estimated timeframe for getting an update that works with the new feature update?

24 Replies
Highlighted
Contributor
Contributor

Testing WS Pro 15.0.4 on 20H1 since the day it came and running mutiple 19H1,20H1 with no issues. Runs fine in a nested environment too.

0 Kudos
Highlighted
Contributor
Contributor

i also have 1903 from msdn, vmware have heavy issues, all vm start with black screen and i cannot terminate the process.. so i have to restart the host !!

Update is needed ! Hope they will realease it soon..

0 Kudos
Highlighted
Contributor
Contributor

So, it seems to be working for some people, but in my case it fails when I try to start a VM saying that VMware Workstation is not compatible with Device / Credential Guard. Note that I have disabled this in Group Policy Editor but I still get these errors.

0 Kudos
Highlighted
Contributor
Contributor

Resolved - It was a bit more involved then simply disabling Device / Credential Guard. The article below resolved the problem for me. The only thing I was missing was the BCDEDIT commands that had to be run at the end of the article.

Windows Sandbox Feature enables windows defender credential guard feature sets. Does not play well w...

0 Kudos
Highlighted
Contributor
Contributor

Update: While the notes above resolve the original issue, I'm now finding that the VM display turns completely black and it is impossible to work with the VMs. They cannot even be shutdown.

Now going back to Hyper-V until the issues are resolved.

0 Kudos
Highlighted
Contributor
Contributor

yes, i read that issue is fixed on internal release... i'm waiting for new release... hope soon Smiley Happy

0 Kudos
Highlighted
Contributor
Contributor

All you have to do is remove the hyper-v feature. Go into Programs and Features, Turn Windows features on or off, scroll down to hyper-v, and clear all the check boxes. Then reboot. If it still doesn't work then go into programs and features, right click VMware Workstation, and click change, then next. If VMware is running it will say Stop the following process.. to continue: vmware.exe. Do CTRL-ALT-DEL, click Task Manager, click VMware Workstation, and click end task. Then click Next and click repair.

0 Kudos
Highlighted
Contributor
Contributor

See it works.

pastedImage_0.png

0 Kudos
Highlighted
Contributor
Contributor

Any word if Workstation 14 will be upgraded to support 1903 as a host?  Or do we need to upgrade t

Currently running Workstation 14 and will upgrade when 16 comes out, it feels like we are being forced to upgrade VMWARE every time Microsoft releases a Windows 10 upgrade.

Highlighted
Immortal
Immortal

> Currently running Workstation 14 and will upgrade when 16 comes out,

Interesting - do you have insider knowledge about a coming WS 16.

I do not expect that we will see a WS 16 at all

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
Highlighted
Enthusiast
Enthusiast

I do not expect that we will see a WS 16 at all

What do you expect? Transition to some kind of "rolling" model?

0 Kudos
Highlighted
Contributor
Contributor

Same problem

Capture.JPG

Running Windows 10 Home 1903 Build 18362.175

VMware Workstation 15 Pro 15.1.0 build-13591040

tempsnip.png

Highlighted
Immortal
Immortal

> What do you expect? Transition to some kind of "rolling" model?

No - I expect that the Workstation product will be discontinued.

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
Highlighted
Contributor
Contributor

My Windows 10 Pro 1809 system would not upgrade to 1903 until after I uninstalled VMware Workstation 11.

Now neither the newest Workstation 15.1.0 and newest 14.1.7 will install. They both throw the same error:

Setup cannot continue. The Microsoft runtime DLL installer failed to complete installation.

pastedImage_0.png

pastedImage_4.png

pastedImage_5.png

EE and programmer before UNIX existed.
0 Kudos
Highlighted
Contributor
Contributor

I expect My $%^&$%^windows software to work on windows. I will NEVER pay for a piece of vmware software ever again. FFS I owned 14 for less than a #$#& year 9/18/18 its #^#$% ridiculous.

Note:  Content edited by moderator for language/cursing

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi, lcbrevard2012:

This error happen when there have conflict for "Microsoft Visual C++ XXXX Redistributable" component in your computer. To resolve this problem, you need uninstall them in control panel firstly, then re-install Workstation.

Thanks.

0 Kudos
Highlighted
Contributor
Contributor

I am having that same issue (with Credential Guard) even after I paid to upgrade to WS 15.

The link is to an article that says it has instructions on how to fix the issue but does not!

So far I am completely unable to use VMware Workstation 15 Pro on this system.

"https://kb.vmware.com/s/article/2146361"

pastedImage_6.png

EE and programmer before UNIX existed.
0 Kudos
Highlighted
Contributor
Contributor

A windows update broke their competitors software and everyone blames VMWare?  Not sure I get that.

If you're looking to blame VMWare for something, I recommend the almost unusable web interface they're pushing these days.  I have to keep switching back and forth between the two options because features are broken or missing.  Not to mention that without vSphere the management interface for hosts is unusable mostly but strangely there's a few things it's necessary for.

Highlighted
Contributor
Contributor

Repllying to:
pastedImage_0.png

Thanks for the suggestion. I have removed ALL of the "Microsoft Visual C++ XXXX Redistributable" items as well as VMware Workstation 15 and rebooted.

After a reinstall of Workstation 15 Pro, the 2015 versions are back:

pastedImage_0.png

I also confirmed that Credential Guard is OFF:

pastedImage_1.png

I still get the error when trying to run a VM - even creating a new one:

pastedImage_2.png

pastedImage_6.png

pastedImage_4.png

THIS IS MADDENING!

What really bugs me is that I cannot even file a ticket since I purchased Workstation 15 in June and my 30 days is up.

I have wasted at least 20 hours on this by now.

As a loyal VMware user since 2003, I am rapidly losing my loyalty!

I guess I'll try phone support on Monday and see if I get someone who can at least report this absurd problem.

EE and programmer before UNIX existed.
0 Kudos