bkraul
Enthusiast
Enthusiast

Shared folders not available on Linux guests after upgrading to VMWare Workstation 15

Jump to solution

After upgrading to from VMWare Workstation 14 to 15, the shared folders are not available as mounts in linux guests, even when they show as enabled on the host. I even tried disabling them and re-enabling them, thinking it might need a refresh, to no avail. Virtual hardware on the linux guests has been upgraded to 15 as well.

Both guests are running Ubuntu 18.04.1 LTS with the latest open-vm-tools (last updated 9/27/2018).

1 Solution

Accepted Solutions
steve_goddard
Expert
Expert

Hello

Thanks for reporting the problem.

Can you please try to run:

/usr/bin/vmhgfs-fuse --enabled

and report the output here.

Also for making mounts and configuring persistent shares see the knowledge article

VMware Knowledge Base

I will try and see if I can reproduce this myself though I have not seen it as yet.

Thanks

Steve

Thanks. Steve

View solution in original post

0 Kudos
20 Replies
bkraul
Enthusiast
Enthusiast

Looking around I found that I can access the shares by manually executing:

vmhgfs-fuse .host:/ /mnt/hgfs -o allow_other

However, I have been using shared folders in linux hosts since VMWare 11 and never had to manually mount. Guess I will have to set this up on /etc/fstab as follows:

.host:/ /mnt/hgfs fuse.vmhgfs-fuse allow_other 0 0

At least the actual shared folder functionality does work, which is what I was worried about.

0 Kudos
Parveen1988
Enthusiast
Enthusiast

Hi,

I didn't face this issue with my Ubuntu 18-04, shared folders access is component of VMware Tools, try re-installing the tools next time if you face this issue.

0 Kudos
bkraul
Enthusiast
Enthusiast

For the sake of replicating, I removed the /etc/fstab entry and uninstalled (even purged) open-vm-tools. Reinstalled tools, result was the same, no shared folders (even as enabled on host), unless entry goes back on /etc/fstab.

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

What is your open-vm-tools version?

0 Kudos
bkraul
Enthusiast
Enthusiast

Latest version (per Ubuntu bionic).

~#vmware-toolbox-cmd -v

10.3.0.5330 (build-8931395)

As mentioned before, removing/re-installing the tools did not work. I ended up deleting the machine and creating a new one. It was only then that fuse actually worked as expected.

0 Kudos
K1ngK005
Contributor
Contributor

I have the exact same issue:

Host Windows 10 workstation 14

VM ubuntu 18.04 LTS

~#vmware-toolbox-cmd -v

10.3.0.5330 (build-8931395)

When I do a vmhgfs-fuse .host:/ /mnt/hgfs -o allow_other I can see the shared folder do a reboot and it is gone again.

will adding this: .host:/ /mnt/hgfs fuse.vmhgfs-fuse allow_other 0 0 to the /etc/fstab make this permanent?

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

Not sure what issue you have run into. But adding that entry in /etc/fstab would be a workround.

0 Kudos
K1ngK005
Contributor
Contributor

I can't get to the shared folder in /mnt/hgfs. And I am using workstation 14 pro and Ubuntu 18.04

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

Can you try this?

1. From Workstation UI VM > Settings > Options > Shared Folder, disable shared folder

2. In guest os, please do the following to remove open-vm-tools:

sudo apt-get remove open-vm-tools

sudo apt-get purge open-vm-tools

3. Reboot the guest os

4. In guest, install bundle tools again from Wokstation UI VM > Install VMware Tools

5. Reboot guest OS again after tools installation.

6. Enable shared folder from Workstation UI.

Let me know if it works for you.

K1ngK005
Contributor
Contributor

Thanks, Bonnie, I have since gone to the help section on VMWare and seen that my version is 12 pro. Tried your steps anyway and wasn't successful either. Manually downloaded the latest version of the tools and tried installing to no avail......

0 Kudos
bkraul
Enthusiast
Enthusiast

Well, I am glad I am not the only one who had this problem.

So, yes, adding the entry to fstab would make your mount work after reboot, but if you ever pause your machine and then resume it, the mount will again become unavailable until you restart the VM.

That is not the way it used to behave.

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

Hi ,

Can you also try the steps above with VMware Workstatation 15 and let us know if it works for you?

0 Kudos
bkraul
Enthusiast
Enthusiast

All of that was tried prior to the initial post, to no avail. Tried the rest of the steps down the line (as you can see from my subsequent posts) Which is why I ended rebuilding the vm, and even then, even when using fstab, I am still having issues where the hgfs mount goes away after pausing/unpausing the machine, and end up having to restart.

0 Kudos
steve_goddard
Expert
Expert

Hello

Thanks for reporting the problem.

Can you please try to run:

/usr/bin/vmhgfs-fuse --enabled

and report the output here.

Also for making mounts and configuring persistent shares see the knowledge article

VMware Knowledge Base

I will try and see if I can reproduce this myself though I have not seen it as yet.

Thanks

Steve

Thanks. Steve

View solution in original post

0 Kudos
bkraul
Enthusiast
Enthusiast

Steve:

The result of the command:

/usr/bin/vmhgfs-fuse: 0 - HGFS FUSE client enabled

It seems this is working since I upgraded to 15.0.2 build-10952284.

I have a recurrent problem with after resuming but I believe it is not related to VMware. It relates to the docker daemon not starting back properly after a resume.

0 Kudos
francwalter
Enthusiast
Enthusiast

Thanks, only with putting your command into the fstab this worked for me:

.host:/ /mnt/hgfs fuse.vmhgfs-fuse allow_other 0 0

Disable share, uninstall the tools and purge and reboot and reinstall and enable share did help only if no reboot. After reboot the share was gone, /mnt/hgfs/ was empty.

But with fstab entry, now it seems working Smiley Happy

frank

Windows 8.1 (64-bit) with VMware Workstation 15.5.2 on a virtual machine Ubuntu 18.04.4 LTS server (without gui).

maximede
Contributor
Contributor

Thanks francwalter !

This solved the issue I had too ( on Ubuntu 18.04LTS and 20.04 LTS). I won't have to disable/enable shared folders at every reboot !

Any idea why configuring that in fstab would solve the issue ?

0 Kudos
John_Deg
Contributor
Contributor

On June 1er 2021, this problem is still there with Workstation Pro 16 and Unbuntu 20.04.

Only working solution, is the one proposed with fstab.

 

0 Kudos
stakys
Contributor
Contributor

Solution by @bonnie201110141 worked perfectly: VMware: 16 / Ubuntu 20.04

0 Kudos