kenglishkeyw
Contributor
Contributor

Shared folders disappear after first reboot

I have built an Ubuntu Sever (no UI) 18.04 VM.  Immediately after the initial boot, I am able to configure a Shared Folder and copy files over.

After the first reboot I cannot get the Shared Folder to re-appear.   I have tried:

  1. restarting the open-vm-tools service [  systemctl restart open-vm-tools.service ]
  2. unchecking and re-checking the share in the UI
  3. removing and re-adding the share
  4. adding:  "After=console-setup.service" to /etc/systemd/system/multi-user.target.wants/open-vm-tools.service


How do I get this working?  It worked once, there must be a way to get it to work again.

The only suspicious lines in the vmware.log are the GuestRpcSentTimedOut messages:

2019-06-14T13:42:18.205-05:00| vmx| A100: ConfigDB: Setting sharedFolder0.enabled = "TRUE"

2019-06-14T13:42:18.205-05:00| vmx| I125: TOOLS received request in VMX to set option 'synctime' -> '0'

2019-06-14T13:42:18.206-05:00| vmx| A100: ConfigDB: Setting tools.syncTime = "FALSE"

2019-06-14T13:42:18.237-05:00| vmx| I125: VMXVmdb_SetCfgState: cfgReqPath=/vm/#_VMX/vmx/cfgState/req/#19/, remDevPath=/vm/#_VMX/vmx/vigor/setCfgStateReq/#138/in/

2019-06-14T13:42:18.238-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:42:18.241-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:42:18.287-05:00| vmx| I125: TOOLS received request in VMX to set option 'synctime' -> '0'

2019-06-14T13:42:18.287-05:00| vmx| A100: ConfigDB: Setting tools.syncTime = "FALSE"

2019-06-14T13:42:18.301-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:42:18.309-05:00| vmx| A100: ConfigDB: Setting tools.upgrade.policy = "useGlobal"

2019-06-14T13:42:18.324-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:42:56.254-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:42:56.324-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:42:56.342-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:43:18.241-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:43:18.301-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:43:18.324-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:46:28.902-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:46:28.902-05:00| vmx| I125: TOOLS received request in VMX to set option 'synctime' -> '0'

2019-06-14T13:46:28.902-05:00| vmx| A100: ConfigDB: Setting tools.syncTime = "FALSE"

2019-06-14T13:46:28.909-05:00| vmx| I125: VMXVmdb_SetCfgState: cfgReqPath=/vm/#_VMX/vmx/cfgState/req/#1a/, remDevPath=/vm/#_VMX/vmx/vigor/setCfgStateReq/#143/in/

2019-06-14T13:46:28.910-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:46:28.960-05:00| vmx| I125: TOOLS received request in VMX to set option 'synctime' -> '1'

2019-06-14T13:46:28.960-05:00| vmx| A100: ConfigDB: Setting tools.syncTime = "TRUE"

2019-06-14T13:46:28.981-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:46:28.985-05:00| vmx| A100: ConfigDB: Setting tools.upgrade.policy = "useGlobal"

2019-06-14T13:46:28.992-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:47:07.746-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:47:07.746-05:00| vmx| I125: TOOLS received request in VMX to set option 'synctime' -> '1'

2019-06-14T13:47:07.747-05:00| vmx| A100: ConfigDB: Setting tools.syncTime = "TRUE"

2019-06-14T13:47:07.754-05:00| vmx| I125: VMXVmdb_SetCfgState: cfgReqPath=/vm/#_VMX/vmx/cfgState/req/#1b/, remDevPath=/vm/#_VMX/vmx/vigor/setCfgStateReq/#150/in/

2019-06-14T13:47:07.755-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:47:07.799-05:00| vmx| I125: TOOLS received request in VMX to set option 'synctime' -> '1'

2019-06-14T13:47:07.800-05:00| vmx| A100: ConfigDB: Setting tools.syncTime = "TRUE"

2019-06-14T13:47:07.807-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:47:07.811-05:00| vmx| A100: ConfigDB: Setting tools.upgrade.policy = "useGlobal"

2019-06-14T13:47:07.818-05:00| vmx| A100: ConfigDB: Setting floppy0.clientDevice = "FALSE"

2019-06-14T13:47:28.911-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:47:28.982-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

2019-06-14T13:47:28.993-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox-dnd timed out.

0 Kudos
4 Replies
louyo
Virtuoso
Virtuoso

My experience has been 2 choices:

1. Fight it and lose, sometimes works, sometimes not.

2. Create share(s) <sharename> in  host (10.X.X.X) Samba (or shares in Windows) and:

mkdir hostshared

sudo mount -t cifs -o vers=1.0  //10.X.X.X/<sharename>  hostshared

You could probably add it to fstab as well.

Lou

0 Kudos
kenglishkeyw
Contributor
Contributor

I found this response very helpful.  Unfortunately, configuring a share on the target computer will not be permitted.  So it sounds like I just have to get used to scripting all file transfers using scp. 

I am going to try and talk the customer into switching to VirtualBox which seems to be much more compatible with Windows 10.  It installs without 4 hours of struggles with disabling windows components and security; it is compatible with Docker and Windows services for Linux; it supports file shares without any hiccups.

0 Kudos
ImShy237
Contributor
Contributor

something i tried after having the same isue is disabling shared folders functionality in Vmware there enabling it back. 

0 Kudos
Technogeezer
Champion
Champion

@ImShy237 There is a known issue where shared folders do not mount at boot time on Linux guests.  A non-persistent  workaround is to disable and re-enable shared folders while the VM is running as you have found. A persistent resolution is:

In the VM, open a root shell prompt.

Make sure an empty directory /mnt/hgfs exists  This will be the mount point for the shared folders  If it doesn’t exist, create it  

Add the following to /etc/fstab:

vmhgfs-fuse /mnt/hgfs  fuse defaults,allow_other   0   0

Your shared folders should mount automatically at the next boot. 

0 Kudos