cynar
Contributor
Contributor

Set guest client area to 1600 x 900 (exact resolution) - guest high dpi work-around?

Hi,

I am struggling with running a guest CentOS 7 / KDE on a Windows 10 laptop which has a high dpi resolution of 3200 x 1800.

Because the guest has unsatisfactory support for high dpi (and I cannot change the guest), I am trying to solve the problem from the outside. The following works somewhat OK:

* resize the client area of the guest (i.e. the VMware window) to 1600 x 900

* go full screen with the VM (Ctrl+Alt+Enter)

* make sure that "View -> Autosize -> Stretch Guest" is enabled

For the to work sufficiently well, without fuzzy rendering, I really, really want the client area at 1600 x 900.

What is the easiest way to set this reliably? Right now, I have to manually resize, which is a real pain to do manually.

Bonus question: Are there other means to compensate for the bad high dpi support in guest CentOS 7?

3 Replies
bluefirestorm
Champion
Champion

Have you tried this?

https://forum.kde.org/viewtopic.php?f=83&t=94892

I tried it and it added the 1600x900 on a Centos 7 VM that I have. It didn't survive logouts and reboots though; maybe that part you can figure out. The upside of this you can add custom screen resolutions as you see fit with the high DPI host that you have.

pastedImage_1.png

0 Kudos
bluefirestorm
Champion
Champion

Answer to the bonus question:

You can also set scaling for the CentOS 7 KDE using xrandr.

Example:

xrandr --output Virtual1 --scale 0.75x0.75

To put it back to default scaling

xrandr --output Virtual1 --scale 1x1

One thing I found if I use

xrandr --size 1600x900

to set the screen resolution (after the xrandr --newmode and --addmode) is that sometimes (not all the time), the fonts became bigger (for example the Konsole fonts, the Display Config app buttons became bigger).

cynar
Contributor
Contributor

I really like the approach with xrandr - thank you!

My initial attempts seem to indicate that VMware mouse integration does not really like this all that much, though:

  • host = 3200x1800
  • host scaling = 200% (should not affect the VM guest)
  • xrandr --output Virtual1 --scale 1x1
  • xrandr --output Virtual1 --scale 0.5x0.5
  • move VMware window to secondary screen @ 1920x1200 (native)

--> mouse in the guest is offset, seems to be still on the 1x1 scale

A first go at "sudo systemctl restart vmtoolsd.service" did not fix that.

All in all, this looks much more promising than the other options, tough!

0 Kudos