VMware Communities
admin111253
Contributor
Contributor
Jump to solution

Secure Boot selection not available for Debian 12.x

Hello!

I'm using VMware Workstation 17 on Host Windows 10.
I'm using the guest Debian 12.x.

The guest has the following properties:
- UEFI enabled
- VM encrypted

However, the Secure Boot selection is not available. It is greyed out. 😞

I followed this instructions, but it did not change anything:
https://kb.vmware.com/s/article/77150

For Windows 11 guest, Secure Boot in VMware is working properly.

Does anyone have an idea?

I tried for several hours, so any idea is warmly welcome. πŸ˜‰

 

Cheers.

 

 

Reply
0 Kudos
1 Solution

Accepted Solutions
bluefirestorm
Champion
Champion
Jump to solution

Have you tried adding the line

uefi.secureboot.enabled = "TRUE"

to the vmx file?

Since you mentioned the VM is encrypted, you need to decrypt it first BEFORE editing the vmx file. And then re-encrypt once you're done.

 

View solution in original post

Reply
0 Kudos
2 Replies
bluefirestorm
Champion
Champion
Jump to solution

Have you tried adding the line

uefi.secureboot.enabled = "TRUE"

to the vmx file?

Since you mentioned the VM is encrypted, you need to decrypt it first BEFORE editing the vmx file. And then re-encrypt once you're done.

 

Reply
0 Kudos
admin111253
Contributor
Contributor
Jump to solution

That is working PERFECTLY.

Thanks! πŸ™‚

Manually adding the option enabled Secure Boot even if it was greyed out in options page.

 

Reply
0 Kudos