GeeteshBajaj
Contributor
Contributor

Running Windows 95 on VMware Workstation 7.x

I have installed Windows 95 on VMware Workstation 7 -- but it runs in a very low resolution of 640x480 in 16 bit color -- how can I make this work better? Thank you so much.

0 Kudos
13 Replies
RDPetruska
Leadership
Leadership

Did you install the VMware Tools yet?

Have you read through the Guest OS Installation Guide for tips for specific guest OS's?

0 Kudos
GeeteshBajaj
Contributor
Contributor

Thank you, RDPetruska -- but is there VMware Tools for Windows 95 that work under Workstation 7.x? If yes, can you share a download link.

Also, I found no Guest OS Installation Guide for Windows 95 under Workstation 7.x

Have a great day.

- Geetesh

0 Kudos
RDPetruska
Leadership
Leadership

Use the winpre2k.iso image for 95, etc.  If you have set the GuestOS setting correctly, this should be the image loaded automatically...

http://partnerweb.vmware.com/GOSIG/home.html

0 Kudos
srnhpp
Enthusiast
Enthusiast

Please have a look windows 95 installation guideline...

Virtual Power
0 Kudos
GeeteshBajaj
Contributor
Contributor

Thanks, RDPetruska and srnhpp -- the link you both provided takes me to: http://partnerweb.vmware.com/GOSIG/Windows_95.html

Followed everything on that page and it all works fine until the step that asks to install VMware Tools. That install crashes (see attached screenshot).

Can you suggest what I should do next -- thanks again for all your help.

Have a great day.

0 Kudos
Bernd_Nowak
Hot Shot
Hot Shot

I'm pretty sure that you need to apply Microsoft Updates for Windows 95 to run the installer. I believe for Windows 2000 SP4 is needed. Especially the Windows Installer updates come into my mind.

Bernd_Nowak
Hot Shot
Hot Shot

0 Kudos
GeeteshBajaj
Contributor
Contributor

Thanks, Bernd Nowak -- installed all these 3:

1. Service Pack 1 for Win 95

2. Windows Installer 2.0 for Win 95, 98, and ME

3. Internet Explorer

And VMware Tools will still not install but I can now run the MSI file manually (rather than launch setup.exe) and that works great except that it mentions that the SVGA driver cannot be installed and manual instructions on how to install it will appear at the end of the installation. However the end of the installation asks for a reboot with no manual instructions to enable SVGA.

Are manual instructions on enabling SVGA for Win 95 VMs available somewhere?

Thanks again for all your help -- looks like we are almost there!

Have a wonderful day.

- Geetesh

0 Kudos
GeeteshBajaj
Contributor
Contributor

Thank you -- followed those instructions but Windows 95 warns about some display error -- will get you the exact details and screenshots on Monday since our office is closed for the weekend.

Thanks a ton for all your support!

- Geetesh

0 Kudos
GeeteshBajaj
Contributor
Contributor

The VMware SVGA driver is installed but Windows 95 still insists on using 640x480 resolution -- do I need to change any monitor settings? I am attaching two screenshots to illustrate what I see.

Thank you again for all your help.

- Geetesh

0 Kudos
Bernd_Nowak
Hot Shot
Hot Shot

A long time ago Smiley Happy

I believe that you need first to change it to the VMware display adapter and then you need to reboot. After the reboot you should be able to change the resolution.

On a side note, are you really bound to Windows 95? No chance for at least Windows 98/SE? I know from my last tries some time ago (2-3 years I believe) that it's a problem to install all official updates for Windows 95 and a lot of current installers don't work anymore with Windows 95. At least 98 was slightly better but I gave up developing anything for those OS because even if I could get something to work it was no way to guide another one who has some Windows 95 to help troubleshoot. My Windows development targets are Windows XP SP3 and all what has been released after Windows XP.

But maybe some diehard Windows 95 gurus will help Smiley Happy

0 Kudos
GeeteshBajaj
Contributor
Contributor

Thanks Bernd Nowak -- completely agree with you on the not-using-Win95 part! Just wanted to have a copy of Win 95 for memorabilia reasons -- I do have DOS, Win 3.1, and Win 98 all working great -- just seems strange that Win95 is the most difficult one to get working!

Also done several reboots and this problem does not go away.

Thank you so much for all your help! Have a wonderful day.

0 Kudos