Contributor
Contributor

Regression in workstation 10 with usb mice linux guests

In workstation 9 I had my usb 7 button mouse working correctly in linux.

mouse.vusb.enable = "TRUE"

usb.generic.allowHID = TRUE

allowed me to get 7 button events in xev. From there I was able to map the side buttons and get back and forward buttons in linux but now this appears to be gone. If I leave the mouse.vusb.enable = "TRUE" line in the vmx config file I get a very strange operating mode with the mouse. Mouse will jump locations when grabbing and ungrabbing. If I remove the line, mouse is working properly but no side buttons. Anyone have any clues? BTW in windows guests all works correct. Is the same whether host is linux or windows.

0 Kudos
26 Replies
Contributor
Contributor

Same problem here.  Anyone have a solution?

0 Kudos
Contributor
Contributor

I wish there was a way to file a bug with vmware

0 Kudos
Contributor
Contributor

What if you follow the steps listed in the below KB article?  It did not work for me because my university licenses Vmware and I don't have any keys in my account, but that should not be a problem for most paying VMware users.

VMware KB: Filing a Support Request in My VMware

0 Kudos
Hot Shot
Hot Shot

Hello,

Have you installed VMware Tools?

This is case to be a driver problem, try to find and istall driver for that mouse.

Hope will help.

Your Oscar

0 Kudos
Contributor
Contributor

Vmware tools is indeed installed, I have tried both the official tools and also the open vm tools, no difference

0 Kudos
VMware Employee
VMware Employee

Hi buddy,

        Would you mind to provide following information so that I can help to open a bug in VMware ?

        1, what host are you using, windows or linux ?

        2, the distrubution of your linux guest

        3, the full name of your usb 7 button mouse (so that we can try to reproduce)

        4, in VM settings of your machine, go to Options ->Advanced, select Full option in "Gather debugging information"

        5, add usb.analyzer.enable = "TRUE" in your vmx file

        6. if you are using windows host, please get hcmontrace*.etl as below

               //rem logman.exe is Windows OS builtin app

               logman.exe create trace -n hcmontrace -p "{4211ca93-51aa-4e54-a2f6-ff03a014679c}" 0x7fffffff 0xff -o hcmontrace

               logman.exe start hcmontrace

               //rem XXX: now reproduce the problem ...

               logman.exe stop hcmontrace

               logman.exe delete hcmontrace

         7. try to reproduce your issue again

         8, attach following files please:

             Workstation UI log from somewhere like this : C:\Users\xxxxxxx\AppData\Local\Temp\vmware-xxxxxx\vmware-ui-844.log

             vmware.log in your VM folder

             vmware-usbarb-2948.log in C:\Windows\Temp\vmware-SYSTEM

             hcmontrace*.etl in the folder that you run logman.exe

 

            I assume you are on windows host.

            Many thanks. Smiley Happy

0 Kudos
Contributor
Contributor

I have tried on both a windows host and a linux host and the results are the same. I will indeed do as you have asked but unfortunately I cannot do it this month as I am getting ready to leave on a business trip, I will definitely do it as soon as I return in about 3 weeks. I will though give you what info is readily available.

Hosts used with WS10 - Windows 8 x64, Gentoo Linux x64, Fedora 19 x64 - all are on motherboards with newer Intel chipsetes (2 X79 Platfoems, One Z77 platform

Guests used - Gentoo Linux x64, Fedora 19 x64

Mouse used, is a Microsoft Wireless Intellimouse Explorer 2.0 Model 1007

0 Kudos
Contributor
Contributor

I'm not sure of what is going on but after upgrading (again!!!) my windows 8 and gentoo 64 hosts to ws10, it now all works correctly. The fedora 64 host does not. A fedora guest on my gentoo host does work correctly.

0 Kudos
Contributor
Contributor

Okay, I have definitively found the problem, it's not ws 10 per say, it's when you do a hardware compatibility upgrade. If you are running ws 10 with a linux guest that is set for hardware compatibility for ws 9, all works well. The nmmoment you upgrade to ws 10 hardware compatibility, it messes up

0 Kudos
Contributor
Contributor

could it be that something in the bios needs to be changed?

0 Kudos
VMware Employee
VMware Employee

Hi billydv,

    Many thanks for your reply. Then I will try to setup the environment including Fedora19x64 host and Fedorax64 guest with Microsoft Wireless Intellimouse Explorer 2.0 Model 1007 on intel chipsets. (I am not sure I can get exactly the same environment with yours, but I will try to.)  Do you think this environment is enough ?

    One thing to clarify. What do you mean "upgrading (again!!!) my windows 8 and gentoo 64 hosts to ws10" ? I thought that you were working with Workstation 10 where you found this issue. So why you "upgrade" again ?

0 Kudos
VMware Employee
VMware Employee

Hi billydv,

        After your upgrading hardware version to 10, is the previous USB setting that you added in vmx file as below missing or still existing ? If missing, if you added them back manually, will the mouse work ?

               mouse.vusb.enable = "TRUE"

               usb.generic.allowHID = TRUE

        So this issue only happened on linux guest, no matter windows host or linux host, right ?

        I am trying to upgrade a vm from 9 to 10 to see if I can reproduce your issue.

        Many thanks.

0 Kudos
VMware Employee
VMware Employee

I tried upgrading from  HW version 9 to HW version 10, the setings mouse.vusb.enable = "TRUE" and usb.generic.allowHID = TRUE still exists.

I will talk interally about this issue.

If I get any workaround, I will let you know. Smiley Happy

0 Kudos
Contributor
Contributor

is the same on either a windows or linux host (irrelevant), also the only item I noticed changing upon the hardware upgrade was the virtual hw version, other than that it remained the same.(btw, in response to your question about upgrading again, I had reverted to ws 9 in order to avoid the mouse problem, all machines were now returned AGAIN to ws 10 and I have left them on ws 10 since I now know the problem)

0 Kudos
Immortal
Immortal

Are you connecting the USB mouse exclusively to the VM or simply using it by mousing over or clicking within the VM window? I ask because the two configuration options you list do two contradictory things. mouse.vusb.enable = "TRUE" enables the virtual USB mouse and usb.generic.allowHID = "TRUE" allows HID devices (such as mice) to be connected exclusively to the VM and otherwise doesn't change any of the virtual mouse behavior.

0 Kudos
Contributor
Contributor

Everything works fine if I don't add "mouse.vusb.enable = "TRUE"" to the *.vmx file.  However, I need that line in order to have the back and forward mouse buttons working in the guest VM.  I tried reinstalled Vmware, creating new VMs, but nothing seems to help.  Shouldn't it be fairly easy to make it work (on your end)? 

Everything was functioning properly in Workstation 9.

0 Kudos
VMware Employee
VMware Employee

If you could post a vmware.log file from running the VM that would be very helpful.  But you might try setting " mouse.vusb.useBasicMouse = FALSE" in your vmx file and see if that helps.

0 Kudos
Contributor
Contributor

Thank you for the suggestion, but mouse.vusb.useBasicMouse = FALSE had no effect on the button behavior.

The log file is attached.

0 Kudos
VMware Employee
VMware Employee

We're not sure what might be going wrong here, but are still investigating the issue.

Could you post a log file with the usb analyzer turned on?

You can temporarily enable it with the vmx file config options:

usb.analyzer.enable = TRUE

usb.analyzer.maxLine = 1024

That should log all USB traffic inside the guest, and let us see how the mouse is actually talking to the guest OS.

If you could post an Xorg.log and xorg.conf from inside the guest that might be helpful too.

0 Kudos