VMware Communities
balubeto
Enthusiast
Enthusiast

Reboot an UEFI VM with SATA CD/DVD

Hi

Using Workstation 10.x and configuring an UEFI VM with a SATA CD/DVD, I noticed that, if I reboot the VM normally by the guest OS, it is not longer able to boot because this screen is displayed:

SATA_CD-DVD_problem.png

This happens with various Linux Live-distributions, such as Ubuntu 13.04 or Parted Magic 2013.08.01 .

How come?

Thanks

Bye

balubeto
0 Kudos
24 Replies
continuum
Immortal
Immortal

enter "BIOS" and then configure the UEFI boot options - it is a bit un-intuitive but here I can use LiveCDS with efi fine


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
balubeto
Enthusiast
Enthusiast

I had already tried to change the UEFI so that the SATA CD/DVD is first boot device but it still does not the boot. How come?

Thanks

Bye

balubeto
0 Kudos
dariusd
VMware Employee
VMware Employee

Usually this would mean that the CD or image is unreadable/corrupt, the guest OS you're using doesn't support EFI, or the CD/DVD is not "connected".

Please attach the vmware.log from the VM's directory after a failed attempt to boot from the CD.

Have you previously installed an OS onto a hard drive in this VM?

Thanks,

--

Darius

0 Kudos
continuum
Immortal
Immortal

the Ubuntu 13.04 works fine here


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
balubeto
Enthusiast
Enthusiast

I have no virtual hard disk in the VM.

Here is my vmware.log file.

I just tried with Ubuntu 13.04 and I have the problem described above. How come?

Thanks

Bye

balubeto
0 Kudos
dariusd
VMware Employee
VMware Employee

Here, we successfully launch a bootloader from the SATA CD/DVD:

2013-09-25T12:46:31.813+02:00| vcpu-0| I120: Guest: About to do EFI boot: EFI VMware Virtual SATA CDROM Drive (0.0)

... and it boots into an OS:

2013-09-25T12:46:36.804+02:00| vcpu-1| I120: CPU reset: soft (mode 2)

2013-09-25T12:46:36.815+02:00| vcpu-2| I120: CPU reset: soft (mode 2)

2013-09-25T12:46:36.827+02:00| vcpu-3| I120: CPU reset: soft (mode 2)

2013-09-25T12:46:36.838+02:00| vcpu-4| I120: CPU reset: soft (mode 2)

2013-09-25T12:46:36.849+02:00| vcpu-5| I120: CPU reset: soft (mode 2)

2013-09-25T12:46:36.861+02:00| vcpu-6| I120: CPU reset: soft (mode 2)

2013-09-25T12:46:36.872+02:00| vcpu-7| I120: CPU reset: soft (mode 2)

which runs for about two minutes before ejecting the disc...

2013-09-25T12:48:24.894+02:00| vmx| I120: CDROM: Guest eject on sata0:0. Disconnecting disc image.

2013-09-25T12:48:24.897+02:00| vmx| I120: CDROM: Disconnected cdrom: sata0:0

Three seconds after that, it reboots:

2013-09-25T12:48:27.440+02:00| vcpu-0| I120: CPU reset: soft (mode 1)

[...]

2013-09-25T12:48:27.466+02:00| vcpu-0| I120: Guest: EFI ROM version: VMW71.00V.0.B64.1308231723 (64-bit RELEASE)

... and we spend a few minutes searching for a boot device (skipping the EFI Shell), and then give up because we can't boot from an empty drive:

2013-09-25T12:49:43.438+02:00| vcpu-0| I120: Guest: EFI Shell inactive in default boot sequence.

2013-09-25T12:49:43.438+02:00| vcpu-0| I120: Msg_Post: Warning

2013-09-25T12:49:43.438+02:00| vcpu-0| I120: [msg.Backdoor.OsNotFound] No operating system was found. If you have an operating system installation disc, you can insert the disc into the system's CD-ROM drive and restart the virtual machine.

Do you know why the guest ejected the disc at 2013-09-25T12:48:24.894+02:00?  If you manually reinsert (reconnect) the disc again, does the VM boot properly?

Cheers,

--

Darius

0 Kudos
continuum
Immortal
Immortal

> Do you know why the guest ejected the disc at 2013-09-25T12:48:24.894+02:00?

Ubuntu LiveCDs all do that - in WS 9 and earlier you would then just enter OK to eject the CD/ISO but in WS 10 that now often sticks across a reboot and in a VM with firmware = bios you would have to shutdown completely and reconnect the ISO in settings again.
Interesting with firmware = efi this seems to work as expected.


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
balubeto
Enthusiast
Enthusiast

Apparently, using the ISO file as boot image and activating the UEFI, when the VM is restarted, the ISO file is not automatically remounted. How come?

Thanks

Bye

balubeto
0 Kudos
dariusd
VMware Employee
VMware Employee

I would not expect it to be remounted.

On a physical machine, a tray-load CD/DVD drive might pull in the tray when the drive is reset during boot, and this might cause the media to be "re-inserted".  A slot-load CD/DVD drive won't pull the media back in, though.  So, on a physical machine, the behavior depends on the style of CD/DVD drive you have.

Our virtual drive acts more like a slot-load drive: Once the media is ejected, it's gone, unless you take some action to reconnect it (push the disc back in).

I see the same behavior from BIOS and EFI when restarting a VM running the Linux Mint 13 live DVD here: In each case, the disc is ejected and the VM fails to find a boot device.  Have you tried the same steps with BIOS and seen a difference in the behavior?

Cheers,

--

Darius

0 Kudos
continuum
Immortal
Immortal

> I see the same behavior from BIOS and EFI when restarting a VM running the Linux Mint 13 live DVD here: In each case, the disc is ejected and the VM fails to find a boot device.

that is a new behaviour of WS 10 - I never had this behaviour with earlier versions


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
dariusd
VMware Employee
VMware Employee

Are you sure?  I can reproduce exactly the same behavior with WS 9.0.2 and Fusion 5.0.3 with Ubuntu 13.04 i686 and amd64.  If I allow the guest to restart itself by pressing Enter, the CD/DVD remains disconnected and the VM fails to boot.  If I power it off and then on again or restart it from the WS/Fusion UI, the Connect at power on setting takes effect and the CD/DVD gets reattached, and the VM boots into the live disc environment again.

Note that Ubuntu can be quirky with the last moments before it shuts down.  It often displays a prompt suggesting that you can press Enter to reboot, but just as often the prompt doesn't appear at all... You can still press Enter to reboot though.  Might that be the cause of the differences in behavior you're observing?

Cheers,

--

Darius

0 Kudos
continuum
Immortal
Immortal

> Are you sure ?
I thought so - but after spending some time with the new boot behaviour my memories may be flawed.

I thought that the previous versions allowed to reboot a LiveCD that ejects the CD at shutdown without leaving the VM - now I always have to reset the VM from the WS GUI.

The behaviour is still very different - WS 10 no longer uses the startconnected parameter at all - setting that option in the GUI is not reflected in the vmx-file  ???
Wonder why that change was made ? - I assume that this is work in progress ?

I tried to prevent that Ubuntu is allowed to eject the CD with
sata0:0.allowGuestConnectionControl = "false"

but it does not work - can I use anything else instead ?


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
dariusd
VMware Employee
VMware Employee

Hi continuum,

I thought that the previous versions allowed to reboot a LiveCD that ejects the CD at shutdown without leaving the VM - now I always have to reset the VM from the WS GUI.

I went all the way back to Fusion 2.0.6 running Ubuntu 9.10 amd64, and it still behaves the same way: The guest ejects the disc at shutdown (although Fusion 2 gives an erroneous warning about the guest having locked the CD drive, and clicking Cancel on that warning would leave the disc "connected"), and we don't reconnect it when the guest resets itself.  We only reconnect when the Fusion UI is used to reset or power-cycle the VM.

The behaviour is still very different - WS 10 no longer uses the startconnected parameter at all - setting that option in the GUI is not reflected in the vmx-file  ???
Wonder why that change was made ? - I assume that this is work in progress ?

What you describe sounds like it should not be happening, and I cannot reproduce that problem here, although it's possible that it could be a host-OS-specific UI issue.  I tested with WS 10.0.0 on a Debian 7.1 amd64 host, with IDE and SATA drives in an Ubuntu 64-bit VM (no OS installed, attaching Linux Mate 13 64-bit DVD image), and the checkbox state corresponds with the startConnected parameter and it is honored by the VM at power-on time.  If you're using a Windows host there, I can try to reproduce the problem you describe on a Windows machine on Monday.  Please let me know if there are any other factors which you think might contribute towards reproducing the problem here!

Thanks,

--

Darius

0 Kudos
continuum
Immortal
Immortal

Hi Darius
if you have a look at the log from Balubeto you will see that the startconnected parameter for the Iso is not there too.
So this may be host OS specific.
I am using Win7-64 as the host and none of the about 50 new VMs with WS 10 have the startconnected parameter set in the vmx.
The parameter first appears when you uncheck the option via the GUI.

That looks like the silent default for (cd-device).start.Connected has changed to "true" - in earlier versions it was "false".


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
dariusd
VMware Employee
VMware Employee

As far as I know, startConnected has always defaulted to TRUE, and only needs to be written to the .vmx file when the user sets it to FALSE via the UI.  (A UI is free to write an explicit value earlier, but there is no need unless setting startConnected to FALSE.)  I verified this behavior with my crusty old Fusion 2.0.6 installation: It does not write startConnected at all, and the IDE and SCSI CD/DVD drives default to being connected at power-on.  I believe that's the expected behavior and is unchanged in WS10.

The <devicename>.allowGuestConnectionControl only restricts connect/disconnect requests originating from within the guest and received through the VMware backdoor -- it does not restrict device-specific eject commands.  I'm not aware of any way to configure a VM to ignore guest optical disc eject commands.

Cheers,

--

Darius

0 Kudos
balubeto
Enthusiast
Enthusiast

Then, using a host with Windows 7 SP1 64-bit, what should I do to prevent the content of an IDE or SCSI or SATA CD-Rom is ejected from a guest system?

Thanks

Bye

balubeto
0 Kudos
balubeto
Enthusiast
Enthusiast

Help!!!

Thanks

Bye

balubeto
0 Kudos
WoodyZ
Immortal
Immortal

Did you miss what darius, a VMware employee, said... "I'm not aware of any way to configure a VM to ignore guest optical disc eject commands."! Smiley Wink

0 Kudos
dariusd
VMware Employee
VMware Employee

How would you do this on a physical machine?  I think the only way is to place a heavy obstacle in front of the CD/DVD drive to prevent it from being ejected.  We don't virtualize heavy obstacles.  :smileylaugh:

If this is the only scenario in which our current behavior is a problem, I would suggest simply using the Restart button to cause the startConnected setting to take effect again.  Let us know if that is not an adequate workaround, or consider filing a feature request with a description of your situation and why you need the ability to disable guest-initiated disc eject.

Thanks,

--

Darius

0 Kudos