Geminon
Contributor
Contributor

Problems going from IDE to AHCI mode

I accidentally made a mistake and installed Win7 as a host OS on my new SSD disk in IDE mode (after a firmware upgrade on the SSD - hence the IDE mode). When I change back to AHCI (using regedit-trick) the guest machine cannot handle it after the host reboot and crashes. The guest machine seems to be set to AHCI mode itself so this is strange (msahci->Start = 0)

I change between the modes like this: http://www.ocztechnologyforum.com/forum/showthread.php?69682-Change-from-IDE-to-AHCI-after-Installat...

Any ideas?

0 Kudos
8 Replies
continuum
Immortal
Immortal

a regulat guest should not even notice that if you installed it to a regular vmdk

can youi explain ?


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
dan13476
Contributor
Contributor

I would have thought the same thing, but I'm experiencing this problem the moment I changed host drivers over to ahci.

With my Win7 base os, in ide mode I can power on vms in player or workstation no trouble.

When I reboot to ahci mode, workstation and player dont start at all with an access violation error.

Reboot again into ide mode and it's all perfect.

Where's the setting that tells workstation/player where to look for the host partitions? seems like my install will only look for settings it discovered during install.

If you know of a solution (other than to not run the host in ahci) I'd love to know.

Dan.

0 Kudos
Ranguvar
Contributor
Contributor

Windows has problems going from and to AHCI after it's already been installed.

This is both on real hardware and virtual machines.

You can (I have in the past) hack around this via regedit, certain keys control the AHCI drivers/services.

I believe http://support.microsoft.com/kb/922976 has the info you need, but try with the value 1 instead of 0 if that does not work.
Keep Googling if it does not work at all, it is very possible to fix.

0 Kudos
dan13476
Contributor
Contributor

My host OS (Win 7) that workstation is installed into has no problem booting ide/ahci, as I've already performed the registry edit that re-enables the ahci drivers in windows.

But Workstation and Player wont even start if I boot my host OS using ahci.

0 Kudos
Ranguvar
Contributor
Contributor

Your problem is with the host OS?
Then boot without AHCI and do what I suggested.
Why are you asking on VMware forums?

0 Kudos
dan13476
Contributor
Contributor

No. I have no problem with the host OS. Actually I think I said that when I said that the host has no problem with ide or ahci.

I can boot the host OS with or without ahci.

The reason why I'm asking on VMware forums (specifically this VMware Workstation forum) is because I have a problem with VMware Workstation, as I stated right from the beginning.

I thought the most appropriate place to request assistance about VMware Workstation would be the Workstation forums.

I've even included a vmware log file in my first post with the problem listed there.

When the HOST is in ahci mode (successfully booted  - no problems or errors of any kind) VMware Workstation will not start at all. VMware player wont start either. That is my problem.

If I change the mode back to ide in the host bios, again I get no issues on boot, and then I am able to open Workstation & run vms without a problem.

I want to run the system in ahci mode AND be able to create & run vms. I get an error and have posted the log file requesting assistance. I think your suggested course of action seems unrelated to my problem, but thankyou for your reply though.

0 Kudos
continuum
Immortal
Immortal

can you start VMs if you run WS with right click "run as administrator" ?


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
dan13476
Contributor
Contributor

Thanks for the reply.

The problem is fixed - sort of.

I say that because I haven't changed any new settings but it's working now.

All I did was change the mode from ide to ahci & back again a few times in the host bios (6 restarts), and powered off the host on 2 separate occasions.

Not sure why, but yesterday WS started working in ahci mode, and I can confirm that I can run vms in player too. That's without using runas administrator.

Seemed like it was a host problem not allowing access to the app, but as I said, I didn't change any additional settings in the host.

Dan.

0 Kudos