Zimmy73
Contributor
Contributor

Problem installing VMware-VIX-1.17.0

Hello all,

I'm experiencing problems installing VMware-VIX-1.17.0 on my debian 10.

Here is the exception output:

sudo ./VMware-VIX-1.17.0-6661328.x86_64.bundle

Extracting VMware Installer...done.

(vmware-installer.py:7233): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «adwaita»,

/usr/share/themes/Adwaita/gtk-2.0/main.rc:733: error: unexpected identifier `direction', expected character `}'

(vmware-installer.py:7233): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «adwaita»,

/usr/share/themes/Adwaita/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant

Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: impossibile aprire il file oggetto condiviso: File o directory non esistente

Traceback (most recent call last):

  File "/tmp/tmp7nnm4p8z.vmis.env", line 132, in <module>

    exec(fileObj.read(), mod.__dict__)

  File "<string>", line 265

    except OSError, e:

                  ^

SyntaxError: invalid syntax

The libcanberra-gtk-module.so seems to be correctly installed:

sudo apt-get install libcanberra-gtk-module

Lettura elenco dei pacchetti... Fatto

Generazione albero delle dipendenze      

Lettura informazioni sullo stato... Fatto

libcanberra-gtk-module è già alla versione più recente (0.30-7).

0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

floris@k10:~/Scaricati$ sudo apt-get install libcanberra-gtk3-

libcanberra-gtk3-0           libcanberra-gtk3-0-dbg       libcanberra-gtk3-dev         libcanberra-gtk3-module      libcanberra-gtk3-module-dbg 

sudo apt-get install libcanberra-gtk3-module

Lettura elenco dei pacchetti... Fatto

Generazione albero delle dipendenze      

Lettura informazioni sullo stato... Fatto

libcanberra-gtk3-module è già alla versione più recente (0.30-7).

0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Some extra info:

vmware-installer -l

Product Name         Product Version    

==================== ====================

vmware-player        15.5.0.14665864    

cat /etc/issue

Debian GNU/Linux 10 \n \l

uname -r

4.19.0-6-amd64

Any help?

Thanks in advance

Stefano

0 Kudos
4 Replies
Simon_Rodan
Contributor
Contributor

I have been experiencing the same problem on Linux Mint 19.2 and 19.3

0 Kudos
Minir
Contributor
Contributor

Same problem on Ubutnu 20.04

Any advice?

sh VMware-VIX-1.17.0-6661328.x86_64.bundle

Extracting VMware Installer...done.

(vmware-installer.py:28867): Gtk-WARNING **: Nelze nalézt systém motivů v module_path: "adwaita",

/usr/share/themes/Yaru/gtk-2.0/main.rc:775: error: unexpected identifier `direction', expected character `}'

(vmware-installer.py:28867): Gtk-WARNING **: Nelze nalézt systém motivů v module_path: "adwaita",

/usr/share/themes/Yaru/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant

Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: sdílený objektový soubor nelze otevřít: Adresář nebo soubor neexistuje

Traceback (most recent call last):

  File "/tmp/tmpehd791_t.vmis.env", line 132, in <module>

    exec(fileObj.read(), mod.__dict__)

  File "<string>", line 265

    except OSError, e:

                  ^

0 Kudos
Minir
Contributor
Contributor

In my cause help:

mv /usr/lib/vmware-installer /usr/lib/vmware-installer_OFF

But it was after many hours to trying lots of any advices around discucssions.

In my /usr/lib/vmware-installer was subdirectory: 3.0.0

And finaly, all it was about showing one GUI window with licence agreement...

aleksandr_vd
Contributor
Contributor

Thanks you. This is helpful for me also.

0 Kudos