camilotorresm
Contributor
Contributor

OpenGL 4.3 for VMware workstation 16

I'm currently using Ubuntu 18.04 (I've manually updated the kernel to the latest version =5.10) also I'm using the latest version of mesa available for my system using the repository from kisak, wich is version 20.3. Still, I can't get OpenGL to run on version 4.3, max I can do is 4.1. The thing is  I am building a project using Unreal 4.24 and it demands OpenGL version 4.3.

This is the output from running:

camus@ubuntu:~$ glxinfo | grep 'OpenGL version'
OpenGL version string: 4.1 (Compatibility Profile) Mesa 20.3.4 - kisak-mesa PPA

I hope you could help me, this is my first post, but also my first time using VMware. 

 

Labels (4)
0 Kudos
3 Replies
scott28tt
VMware Employee
VMware Employee

@camilotorresm 

Moderator: Please try and create a thread in the area for the product used - moved to Workstation Pro Discussions (though you may be using Workstation Player). The usage guidelines in my signature below has other tips, I would advise searching this area for related posts.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
aerojsam
Contributor
Contributor

The Product page for VMware Workstation Pro does claim to support OpenGL 4.3, as seen here:

Windows VM | Workstation Pro | VMware

 

Is this information accurate, or will this be supported in a future release?

 

Thank you in advance,

Samuel Jimenez

0 Kudos
anil2016
VMware Employee
VMware Employee

This is a documentation error. It has been reported to the respective team to get it rectified. WS 16 supports OpenGL 4.1 and below.

0 Kudos