ajgringo619
Hot Shot
Hot Shot

Noticeable typing lag in Linux VM terminals since v16.2 upgrade on Linux host

Upgraded my EndeavourOS host to version 16.2 yesterday. Now I'm noticing a lag when typing in any VM terminal window - Arch, Ubuntu, openSUSE are experiencing the same thing. I'm using open-vm-tools, which has never been a problem before. I have not changed any settings on the VMs since their creations: 8GB RAM, 4GB vGPU, 8 vCPUs.

 

Anyone else seeing this? I haven't tried with my Windows 10 host yet (also on v16.2).

 

UPDATE: working great with Windows 10 (Home) host.

0 Kudos
53 Replies
erguny
Contributor
Contributor

I have the same issue since the last Workstation update. Replied on another thread too. It is very annoying and I couldn't find any solution yet.

0 Kudos
ajgringo619
Hot Shot
Hot Shot

I just updated all of my VMs and verified that the issue still exists. However, it seems much worse on Debian/Fedora-based VMs; my Arch and openSUSE VMs don't seem to be affected. After trying both of them this morning, I found that these (2) releases - both rolling - are using the latest open-vm-tools client, version 11.3.5. While I did not see any related issues posted on the GitHub site, I'd be willing to bet that the v11.3.5 version fixes this issue.

0 Kudos
erguny
Contributor
Contributor

It might be. My VMs which are affected all run the open-vm-tools version 11.2.5. 

0 Kudos
ajgringo619
Hot Shot
Hot Shot

My worst offender is Fedora 34, which is running v11.3.0. I may try to build the latest client and see what happens.
0 Kudos
ajgringo619
Hot Shot
Hot Shot

Should have tried this earlier...

I removed the open-vm-tools packages on my Ubuntu 20 VM and the problem remains; it actually may have been even worse.

0 Kudos
wila
Immortal
Immortal

Hi,

Weird..

Have you tried turning 3D acceleration off?
Does that help?

Now the following might sound strange.. but I once had this issue a few years ago and it was ....

...

... DNS.

Typing anything in a terminal was pretty frustrating.
After setting the DNS server to 8.8.8.8 everything worked as it did before.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
ajgringo619
Hot Shot
Hot Shot

The lag seems to be gone with disabling 3D acceleration; curious what changed with the new version of VMware Workstation. Also, this still doesn't explain why my Arch/openSUSE VMs are working as expected.
0 Kudos
erguny
Contributor
Contributor

Yes, disabling 3D acceleration fixes the lag. But I don't think that should be the solution, I want to be able to use 3D acceleration. The issue seems to be with Debian based distros.

0 Kudos
wila
Immortal
Immortal

Hi,


@ajgringo619 wrote:
Also, this still doesn't explain why my Arch/openSUSE VMs are working as expected.

Not sure, but I would guess that there's a different vmwgfx driver?

I just looked over at https://github.com/vmware/open-vm-tools/issues and I'm not seeing this issue mentioned.
Perhaps a good idea to log it there.

edit:
Sorry, my bad, not had enough coffee yet, vmwgfx is a kernel module and thus it is part of the kernel.
Just did a few searches on it and the results of that are here: https://wiki.vi-toolkit.com/index.php?title=Vmwgfx

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
ajgringo619
Hot Shot
Hot Shot

While this may be related to kernel modules, (3) things still don't make any sense to me:

  1. Why does the lag go away when the host is Windows (using the same VM, just a different .vmx)?
  2. Why is the lag on Fedora as bad as Ubuntu, when Fedora is using the same kernel branch (5.14) as my working Arch/openSUSE VMs?
  3. What changed between WS 16.1.2 and 16.2 to cause such an obvious problem?
0 Kudos
ajgringo619
Hot Shot
Hot Shot

UPDATE: the "fix" of disabling 3D acceleration makes Fedora 35 even worse; the terminal is almost unusable.

0 Kudos
wila
Immortal
Immortal

Hi,

Another thing to try....

What happens if you disable bluetooth under the usb settings?

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
ajgringo619
Hot Shot
Hot Shot

Bluetooth is already disabled.
0 Kudos
Jorn-H
Contributor
Contributor

Have the same lag, and when searching around i found this :
https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/474099/496x-driver-performance-in-...

In my case it might be Nvidia Driver related.

forvm2765
Contributor
Contributor

I am having the same issue, in a really extreme form on Fedora 34, Host is Windows 10 Professional though. 

I did not find any solution for it and it is so bad that simply working quick is not possible at all. I am a very quick writer but even upper and lowercase get completely mixed up as the shift key is registered way too late for. Never had these issues before Workstation 16.

Upgraded all the VMs to 16, installed latest open-vm-tools in Fedora. Nothing works. Aside from that the integration of copy/paste in login screen of Fedora seems completely broken, it simply does not work. It did with 15 without issues. Once I am logged in copy/paste works as it should. This is a massive disappointment, too, as I have to type 30 cryptic chars every time I reboot the VM

0 Kudos
Jorn-H
Contributor
Contributor

Nvidia driver 496.76 on the host computer seems to have fixed the problem with lag on my guest VMs

0 Kudos
forvm2765
Contributor
Contributor

For me I also found out what it was in my case. And that is totally weird. If I switch the host (Windows 10) sound output to speakers while the VM is running, the GNOME terminal shell is not able to play the sound of the terminal bell correctly because it seems the sound output of the VM is messed up. This means that with every keystroke that would play the terminal bell the VM hiccups so bad that typing on the keyboard gets unusable. If I disable the terminal bell then in the GNOME terminal application typing and also autocomplete gets as fast as it can get.

So there is definitely an issue with that on a Windows 10 host to at least a Fedora VM, did not test other VMs until now with that.

0 Kudos
posthum4n
Contributor
Contributor

Another thing I've noticed is that the keyboard input lag in the VM guest is not happening as long as I'm moving the mouse.

m4r1m4t
Contributor
Contributor

For me disabling 3d acceleration didn't help. After downgrade to v16.1.2 everything is fine again.

0 Kudos