ajgringo619
Hot Shot
Hot Shot

Noticeable typing lag in Linux VM terminals since v16.2 upgrade on Linux host

Upgraded my EndeavourOS host to version 16.2 yesterday. Now I'm noticing a lag when typing in any VM terminal window - Arch, Ubuntu, openSUSE are experiencing the same thing. I'm using open-vm-tools, which has never been a problem before. I have not changed any settings on the VMs since their creations: 8GB RAM, 4GB vGPU, 8 vCPUs.

 

Anyone else seeing this? I haven't tried with my Windows 10 host yet (also on v16.2).

 

UPDATE: working great with Windows 10 (Home) host.

0 Kudos
54 Replies
goldeneye_007
Contributor
Contributor

I have Win 11 on 16.2.3 (linux host) and do not see a lag. Sometimes I will see a lag if I have Windows Updates waiting to be installed. No idea why but lagging typing is a key indicator that Windows updates are waiting.

Is it application specific? MS Word/Excel? or do you see it in programs outside of those?

Have you tried minimizing your VMware workstation and typing in a Linux app to see if the host is lagging?

 

0 Kudos
dineshmeinwk
Contributor
Contributor

My setup was the other way around. I had a windows 11 host and Ubuntu 20.04 on Vmware 16.2.3.

For me, I didn't see any lag in the host, windows 11 environment. but almost all the applications in my Ubuntu VM had the typing lag (Terminal vi, text editor, IntelliJ IDEA, etc). Specifically, with the arrow keys, other keys seem to be working fine.  After downgrading to VMware 16.1.2, it was a night and day difference (zero lag. Definitely something was introduced in Vmware Workstation 16.2.3 that is not compatible with Windows 11 hosts).

0 Kudos
gsebas18
Contributor
Contributor

I was running 16.2.3 on Windows 11 for a week or so after a new build and it worked perfectly, just yesterday I log into my Kali Vm and notice bad keyboard lag on all terminal, text editors and applications running. 

The best way to reproduce is by opening any text file and navigating with the arrow keys. Key repeats are unusable. Even after letting go of the key, the cursor kept moving for 1-2 seconds. Making me overshoot many times.

I can also confirm that if you move the mouse while using the directional arrows as per my example, the lag is gone.

Downgraded to 16.1.2 and lagging went away. However, it is not optimal due to issues with 16.1.2 in Windows 11 that were fixed on 16.2.2 regarding multiple cores:

https://communities.vmware.com/t5/VMware-Workstation-Pro/Workstation-16-1-2-Pro-under-Windows-11-hos...

The issue also persists in 16.2.2

See the gif below: You can see the text cursor being moved by the arrow keys while I move my mouse and you can see the text cursor changes behavior and keeps moving as soon as the mouse cursor disappears.

Animation.gif

louyo
Virtuoso
Virtuoso

I had a Linux VM doing same, Windows 10 was OK. Difference was Video acceleration was off on W10. Turned it off on Linux VM and lag went away. For me, the lag was last character only. 

0 Kudos
gsebas18
Contributor
Contributor

Time to go back to Windows 10 then 😵💫

0 Kudos
RDPetruska
Leadership
Leadership


@gsebas18 wrote:

Time to go back to Windows 10 then 😵💫


I personally have yet to see ANY good valid reason to move to Windows 11!

0 Kudos
louyo
Virtuoso
Virtuoso

Agree. I did install an insider version in a VM to test some software I created for a client.

Not much at being a pioneer.

Our production stuff is mostly on ESXi.

Lou

 

0 Kudos
goldeneye_007
Contributor
Contributor

I think you are probably on to something. If messing with the acceleration is having a result, odds are it's a video driver problem.

I am not seeing a problem with Win11 as a guest under Linux if you are running 16.2.3 (which also fixes some USB issues present in 16.2.1). As for is Win11 worth it? If you have hardware that it will run on then yes. They have cleaned up a lot of the rough edges. I think it is my favorite Windows to date. If your hardware requires hacks and cheats to make it work, then no I wouldn't bother, ride Win10 like it's XP.

0 Kudos
gsebas18
Contributor
Contributor

Now that I think about it. I did run into similar issues in which behavior stopped being laggy as soon as I moved the mouse around while doing the action. Under Windows 10 and VMware Workstation Pro 15.X but that time was the scroll wheel. Basically the scroll wheel would not work well unless I was moving my mouse constantly. I had to fix that by installing imwheel https://www.reddit.com/r/oscp/comments/s8tk71/better_mouse_scrolling_on_kali_running_on_vmware/

0 Kudos
bravo88
Contributor
Contributor

for the acceleration related issue the only solution for me was to make the vulkan be forced to support my card 

mks.vk.allowUnsupportedDevices = "TRUE"

i also added this but not sure if the below is necessary  

mks.forceDiscreteGPU = "TRUE"

now i have great acceleration 16.2.3  

0 Kudos
ghostrider13
Contributor
Contributor

Same lagging issue in terminal.

  • Host: Ubuntu 22.04 Linux 5.15.0-27-generic
  • GPU: NVidia RTX 3090 with 510.60.02 driver
  • VMWare Workstation Pro 16.2.3 build-19376536
  • Guest: Ubuntu 20.04 Linux 5.13.0-generic

Turning off 3d acceleration fixes the lag. Trying to force Vulkan by adding following to the vmx file doesn't help:

mks.vk.allowUnsupportedDevices = "TRUE"
mks.forceDiscreteGPU = "TRUE"

0 Kudos
MrG56
Contributor
Contributor

Have you found a solution to this issue? It's driving me insane!

0 Kudos
dineshmeinwk
Contributor
Contributor

I had to downgrade to 16.2.1

0 Kudos
posthum4n
Contributor
Contributor

I'm running a hacky Python script in the guest VM which for me solves the key input delay in the Linux guest VM running on a Linux host, but does make the mouse wiggle slightly in the VM.

pip install pyautogui

 

# thanksvmware.py
import pyautogui
pyautogui.FAILSAFE = False

while 1 == 1:
    pyautogui.moveRel(1, 0, duration = 0)
    pyautogui.moveRel(-1, 0, duration = 0)

 

 

Also tried simulating keypresses (like media keys), but haven't found something that works better than this script. 

It's really incredibly sad VMWare is ignoring this, are they using their own software?

0 Kudos
bahmanp
Contributor
Contributor

I upgraded the VM itself also to be compatible with 16.2; the problem seems to be solved. Note that After upgrading the workstation to 16.2, you can see something like "Upgrade VM hardware" under the change/edit setting in the window right before turning on the VM that you should click, follow the steps, and in the last page choose version 16.2.

0 Kudos