ajgringo619
Hot Shot
Hot Shot

Noticeable typing lag in Linux VM terminals since v16.2 upgrade on Linux host

Upgraded my EndeavourOS host to version 16.2 yesterday. Now I'm noticing a lag when typing in any VM terminal window - Arch, Ubuntu, openSUSE are experiencing the same thing. I'm using open-vm-tools, which has never been a problem before. I have not changed any settings on the VMs since their creations: 8GB RAM, 4GB vGPU, 8 vCPUs.

 

Anyone else seeing this? I haven't tried with my Windows 10 host yet (also on v16.2).

 

UPDATE: working great with Windows 10 (Home) host.

0 Kudos
55 Replies
ajgringo619
Hot Shot
Hot Shot

Since I started this post, I figured I should chime in with my current (working) situation. Due to other factors, mostly gaming-related, I downgraded my Nvidia drivers to the x470 branch. Although I still need to disable 3D-acceleration - left it on Linux Mint Cinnamon as I don't want to use fallback-mode - the terminal lagging has completely disappeared. My VMware Workstation version is 16.2.1-3, installed via the Arch package aur/vmware-workstation.

0 Kudos
mwb1100v
Contributor
Contributor

> the keyboard input lag in the VM guest is not happening as long as I'm moving the mouse

For me moving the mouse doesn't make the lag go away, but is does make it less severe.  No idea what that might mean though.

0 Kudos
gautambhat
Contributor
Contributor

I setup my sound card to the host soundcard and it became slightly better.

0 Kudos
mwb1100v
Contributor
Contributor

I solved the problem by reverting to VMware Workstation Pro v16.1.2

 

For completeness:

  - host is Windows 11, i7-8700, 48GB of RAM

  - guest is Linux Mint 20.3 (Ubuntu focal/20.04-based) w/8 processors & 16GB RAM allocated, or Mint 19.3 (Ubuntu  bionic/18.04-based) with 8 processors  & 22 GB of RAM allocated

  - turning off "Accelerate 3D graphics" didn't have an effect on the keyboard behavior.

  - the lagginess was far more evident with the cursor keys than other keys.  If the cursor keys behaved like the other keys, I probably would have chalked up the problem as being not enough horsepower on my machine

 

I had made the mistake of upgrading from Win10 to Win11 and VMware Workstation 16.1.2 to 16.2.2 more or less at the same time. Most of the time when I experienced the problem, I believed that the Win10->Win11 upgrade was responsible.  The Mint 19.3 VM had been running on Win10 for more than a year  The Mint 20.3 VM was created to see if a freshly installed VM would have the same problem (it did).

Nothing in the release notes for 16.2.x jump out as being related to this problem (note: I don't know if the problem also occurs in 16.2.0 or 16.2.1).

gautambhat
Contributor
Contributor

v16.2.2 has the same problem as v16.2.1. Removing of sound card did not make much of a difference. It still is annoying. When you downgraded it is by downgrading the vm comaptibility of the image or the whole of vmware workstation install?

0 Kudos
mwb1100v
Contributor
Contributor

I downgraded from 16.2.2 to 16.1.2 (Win11 host) by:

  - stopping/suspending my VMs and closing the VMware application

  - uninstalled 16.2.2 (including the settings when the uninstaller asks about that)

  - rebooted (not sure if this is necessary)

  - installed 16.1.2

All's good now.

0 Kudos
pdihs
Contributor
Contributor

Downgrade doesn't seem like a long-term viable option. Any input from VMware on this yet?

0 Kudos
gautambhat
Contributor
Contributor

@pdihs I agree that this is not a solution. How can we raise it with VMware?

0 Kudos
wila
Immortal
Immortal

HI,

Any of you guys using a NVidia GPU?

If so, try to use the nouveau driver instead of the driver from NVidia itself.

While on that boat, there's also this...

Starting with Workstation 16.2.0, Workstation has Vulkan renderer support and will use that by default, see https://docs.vmware.com/en/VMware-Workstation-Pro/16.2.0/rn/VMware-Workstation-1620-Pro-Release-Note...

There is a chance that your problems are due to this change, you can switch back to using X11, see https://wiki.vi-toolkit.com/index.php?title=Vmx_hacks#Linux_Host_-_switch_back_from_Vulkan_to_X11

good luck!

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
gautambhat
Contributor
Contributor

This lag is also present in Windows 10 hosts which I am using as of now. 

0 Kudos
wila
Immortal
Immortal

Hi,


@gautambhat wrote:

This lag is also present in Windows 10 hosts which I am using as of now. 


Ok, it was just a guess and figured it was worth a try.

re. "bring to the attention of VMware", for that I suggest to open a support ticket ( https://www.vmware.com/support/workstation )

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
mwb1100v
Contributor
Contributor

> for that I suggest to open a support ticket

I have no support contract, so VMware wants $50 to open a support incident.  If someone with this problem has a support incident to burn, that would be great.  But I'm OK with 16.1, so I'll live with that.

 

And just to be clear: my problem was using a Win11 host.  It seems like there's a good chance that the problem on Linux hosts is related, but who knows?

0 Kudos
thinker4ward
Contributor
Contributor

How did you downgrade?

 

0 Kudos
mwb1100v
Contributor
Contributor

> How did you downgrade?

Uninstall then install  16.1.2.  I think I rebooted in between.  I'm not sure it's necessary (and I don't even remember for certain if I did).

0 Kudos
bidimensional
Contributor
Contributor

I confirm this. The bug is very easily reproducible: use the keyboard to go to the left of a long string in a terminal, and it will keep going. This is a serious bug that makes unusable the software, I am appalled it is still open since 2021. I have the latest Nvidia drivers as of today with RTX A5000.

0 Kudos
louyo
Virtuoso
Virtuoso

PMJI late: Thanks for the tip about Vulcan. Like all things 'nix, sometimes the opposite advice about drivers is true.

I was moving from a LMDE4 host to LMDE5 (installed on separate SSD, for test purposes). If I ran a Linux Debian VM, the system would lock up within 2 or 3 minutes. Only way out was BRS. I have a rather basic Quadro P620 card. I  was running the nouveau drivers, same as the LMDE4 system. I DDG'd the problem, tried different desktops, versions of WS, etc, wash, rinse, repeat. Still locked up.

I tried the latest NVIDIA drivers with no success. Reinstalling LMDE5, (which put it back to nouveau), I Installed nvidia-settings which installs the 460 level driver. I tested prior to updating the driver. That fixed the lock up problem, hasn't done that in over 2 weeks. Lag in a terminal was minimal if even there (hard to tell when the system keeps locking up) but I did the Vulcan vmx edit on that VM anyway to have a look.  I have a Mint 20.3 VM that has no lag, without any modifications.

I am back to running 16.2.3.  Staying  at NVIDIA 460.91.03. 

Sometimes dumb luck overcomes logic.  🙂

 

0 Kudos
continuum
Immortal
Immortal

> I'm not sure it's necessary (and I don't even remember for certain if I did).
A reboot is highly recommended.
I suggest uninstall current version - reboot - cleanup registry manually - reboot.
Install previous version.

Ulli


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
goldeneye_007
Contributor
Contributor

I shut down the guest, ran updates for the Linux host, rebooted the host and restarted the VM and it went away.

0 Kudos
mwb1100v
Contributor
Contributor

> ran updates for the Linux host

That's interesting.  I wonder what (if anything) this might mean for those of us seeing the problem on Win10/Win11 hosts?

 

0 Kudos
dineshmeinwk
Contributor
Contributor

Downgrading to VMware workstation 16.1.2 resolved the keyboard lagging issue. Perhaps something wrong with V16.2 and Windows 11.

0 Kudos