VMware Communities
tcw01
Contributor
Contributor

Not enough physical memory available to power on this virtual machine

Hi,

I am getting the above error message when I try to power on or resume a VM in VMware Workstation (8.0.1 build-528992) soon after I have loaded and logged into windows. I currentl have 2 VMs - Kubuntu (512Mb) and Windows 7 Pro 64bit (3Gb) - installed.

When this error first occurred, I set up a new computer user on my PC (with the same configuration as the first user) so I can run VMware Workstation and access both VMs from either user.

What seems to work when I try to power on a VM and get the error message, is to logoff and then logon to the second user(Andrew). I can then power on the same VM without any problem. If I then logoff the second user and then log back on to the first user(tcw), I can then power on the VM without any problem.

I don't understand why this is happening as there is more than 5Gb physical memory available on the PC

I attach 3 logs:

  1. vmware-2.log & vmware-1.log from the first use (tcw)r when the error message occurred,
  2. vmware-0.log from the second user(Andrew) AFTER I had logged off, logged on to the second uset
  3. vmware.log, AFTER I have logged off (Andrew) and logged back on to the first user(tcw)

I am running Windows Ultimate 64 bit + SP1 with 8Gb memory

If anybody can shed any light on to this error happening I would be very grateful. I have a work around as described, but this isn't very satisfactory or convenient. In all the years of using VMware Workstation I have never had the slightest problem, and i find it very useful for testing and running trials on various flavours of Windows and Linux.

Many thanks

Andrew Wyatt

The Computer Workshop

0 Kudos
11 Replies
continuum
Immortal
Immortal

Hi
what is the size of your pagefile.sys - do you use one at all ?

As admin open a texteditor and edit C:\ProgramData\VMware\VMware Workstation\config.ini

add this line:


prefvmx.minVmMemPct = "50"

That should help - if you still cant run 2 larger VMs at the same time - try even lower values.

By the way - if runing many VMs at the same time is important for you I would recommend to use version 7.1.4


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
tcw01
Contributor
Contributor

Hi.

My pagefile.sys is 7.96Gb

I usually only ever run one VM at a time (Windows 7 Pro 64bit at the moment)

prefvmx.minVmMemPct is currently set to "25"  What does this actually do?

0 Kudos
abbie11
Enthusiast
Enthusiast

HI tcw01.

please find answer to your querry ,if need any more information please let us know.

prefvmx.minVmMemPct = "100"

fit memory into RAM

Whenever possible avoid settings lower 100%

prefvmx.minVmMemPct = "50"

allow some memory to be swapped

prefvmx.minVmMemPct = "25"

allow most memory to be swapped

Yours, Abbie

Winning!
0 Kudos
a_p_
Leadership
Leadership

prefvmx.minVmMemPct is currently set to "25"  What does this actually do?

You can find this and other settings with comments on continuum's website at http://sanbarrow.com/vmx/vmx-config-ini.html

André

continuum
Immortal
Immortal

you already use 25 only ???
you might get away with setting it even lower - some folks even had to turn it down to zero ...

do you really need WS 8 ?
this problem is a new feature of WS 8 - with WS 7 you should get better results


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
tcw01
Contributor
Contributor

<<do you really need WS 8 ?

No, not particularly

<<this problem is a new feature of WS 8 - with WS 7 you should get better results

This seemed like a sensible option to try, as I had never had any problems with version 7. So I went back and installed 7.1.5 and then got the following message when I tried to power on!!

Invalid config file. File ,,\,,\,,.vmx was created by a VMWare product with more features than this version of VMWare Workstation and cannot be used.

So I am back where I started and no further forward.

<<you already use 25 only ???
<<you might get away with setting it even lower - some folks even had to turn it down to zero ...

I have no idea what or when this was set to 25.  I will try 0.

BTW thanks to all for explaining 'prefvmx.minVmMemPct' and pointing me to continuum's website

Andrew

0 Kudos
markdv77
Enthusiast
Enthusiast

André Pett wrote:

prefvmx.minVmMemPct is currently set to "25"  What does this actually do?

You can find this and other settings with comments on continuum's website at http://sanbarrow.com/vmx/vmx-config-ini.html

André

Yes, it's listed there, along with some examples on how to set it - and the seemingly related prefvmx.useRecommendedLockedMemSize - for "optimal results" under different conditions. But it does not actually explain what the setting does. Based on the name it's some "minimal percentage of virtual machine memory". A minimal percentage that vmware uses to.... , or treats as..., or requires... ?? No real explanation...

If I had to, I'd guess that this is the amount of virtual machine memory that vmware will keep in memory. The rest can be swapped in/out as needed. But does this apply to the memory of each individual virtual machine, or to the total of all virtual machine memory?

An even Bigger mystery to me is prefvmx.useRecommendedLockedMemSize. I've noticed that whenever the global reserved memory setting is set to the maximum allowed value that this pref is set to "TRUE" in the global configuration file. Any thing else, even only 1 Megabite less, and it's set to "FALSE". (Tried under WS8.) But I have yet to find an explanation on what it does...

Sorry if this sould a bit like a rant, but I just really like to understand what these settings do.

Regards, Mark.

p.s. In case you read this, I do love your site continuum. Thanks! for al the valuable info.

0 Kudos
continuum
Immortal
Immortal

.... but I just really like to understand what these settings do.

same here - I still do not know why Workstation 8 behaves so strange on some installations.
I have seen 2008 R2 hosts with lots of RAM that could only run a single 2Gb VM - way less than with WS 7.
Same applies to some Windows 7 hosts ...

A 2003 host on the other hand is not affected - here I can still use as many VMs as with WS 7


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
markdv77
Enthusiast
Enthusiast

Ulli Hankeln wrote:

.... but I just really like to understand what these settings do.

same here - I still do not know why Workstation 8 behaves so strange on some installations.
I have seen 2008 R2 hosts with lots of RAM that could only run a single 2Gb VM - way less than with WS 7.
Same applies to some Windows 7 hosts ...

A 2003 host on the other hand is not affected - here I can still use as many VMs as with WS 7

Did you my post about the difference I noticed in the way WS 8 allocates memory on linux hosts?

Perhaps similar changes are in the windows version too. And if they changed the way that memory is allocated new factors could have come in to play that affect how much memory can be successfully allocated. And it could be that certain types of allocations are only available on certain (newer) versions of windows. Which could explain why you're only seeing changes in behavior on newer versions.... But only vmware can probably tell us for sure.

0 Kudos
continuum
Immortal
Immortal

> But only vmware can probably tell us for sure.

We discussed that in the beta - I said that I noticed significant changes but VMware egineers told me that they made no big changes.

As far as I know Linux 64bit hosts now use
mainmem.backing = "swap"

but this only works if you either have swap space or if you also set

prefvmx.minVmMemPct  = "100"
prefvmx.useRecommendedLockedMemSize = "TRUE"

It is a pity that VMware does not print default settings to the config files


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
markdv77
Enthusiast
Enthusiast

> We discussed that in the beta - I said that I noticed significant   changes but VMware egineers told me that they made no big changes.

From what I'm observing they definitely changed it for 64bit linux hosts.

> As far as I know Linux 64bit hosts now use
> mainmem.backing = "swap"

I think this was already the case for 64bit linux hosts with WS7. Under linux it's fairly easy to observe the differences of named/unnamed/swap by listing the open files of the vmware-vmx process. And I remember playing around with this setting and concluding that "swap" was default on my installation.

I also gave it a quick try on WS8 and it's indeed stil the default.

But I haven't done any detailed analysis in combination with different prefvmx.minVmMemPct & prefvmx.useRecommendedLockedMemSize settings. But I'm gooing to... I'll report back if I find anything interesting.

Mark.

0 Kudos