VMware Communities
twistedau
Contributor
Contributor
Jump to solution

Network Bridge Mode Not Working Windows 10 Host

Running VMware Workstation Pro 14 (14.1.1 build-7528167). None of my guest VM's can contact my host machine, and my host machine cannot contact the guest machines. This occurs when I'm using bridged mode for the guest NIC's. Other machines on my network can contact the guest VM's and the guest VM's can contact other machines on my network; they also have Internet access. This seems to just be guest to host and host to guest communication issues. If I switch from bridged to host only or NAT it works OK. I've tried to uninstall>reboot>reinstall VMware workstation. I've tried resetting the network settings to default in the Virtual network app. I can see the VMware bridge driver on my host machines physical NIC. I've tried uninstalling and reinstalling it. I've turned off the firewalls on both machines.

50 Replies
joseef
Contributor
Contributor
Jump to solution

Thanks very helpful! 

Reply
0 Kudos
shawarma_man
Contributor
Contributor
Jump to solution

Wow after I tried for several hours and trying all solutions, your solution was the last one I was gonna try AND IT WORKED, Thanks a lot.

Reply
0 Kudos
mekkano
Contributor
Contributor
Jump to solution

I’m glad it helped you. Digging’ deeper the issue is caused by a SonicWall filter (DNE LIghtweight Filter) on the NIC adapter you use for bridging. So you can just open NIC’s properties and uncheck that filter so you do not have to uninstall SonicWall client and when you need vpn connectivity just check it again of course this will bring back the issue. 

I hope this helps too. 

Greetings 

mekkano
Contributor
Contributor
Jump to solution

I’m glad it helped you. Digging’ deeper the issue is caused by a SonicWall filter (DNE LIghtweight Filter) on the NIC adapter you use for bridging. So you can just open NIC’s properties and uncheck that filter so you do not have to uninstall SonicWall client and when you need vpn connectivity just check it again of course this will bring back the issue. 


I guess this issue can be also caused by another filter installed by antivirus or another vpn client.

I hope this helps too. 

Greetings 

SD_Tech
Contributor
Contributor
Jump to solution

I have been banging my head against the wall for many hours trying to fix this issue, I tried everything in this post more than once and still was unable to fix it... UNTIL NOW!

 

For me the problem was the DHCP server from my home network wasn't serving the VM an IP address.  Setting the IP address manually was the final thing that fixed it for me.  Keep in mind, I also did everything else on the list, so it could also have been one of those things in conjunction with the manual IP address.

After all the time I spent on this, I HAD to share, because no guide or post I read mentioned manually setting the IP address.

Reply
0 Kudos
guilhbernardes
Contributor
Contributor
Jump to solution

this worked for me! Thank you!

Reply
0 Kudos
FLimaK
Contributor
Contributor
Jump to solution

Thanks @mekkano ,

I had walked all the solutions on this thread and my solution was based on your post.

 

"I’m glad it helped you. Digging’ deeper the issue is caused by a SonicWall filter (DNE LIghtweight Filter) on the NIC adapter you use for bridging. So you can just open NIC’s properties and uncheck that filter so you do not have to uninstall SonicWall client and when you need vpn connectivity just check it again of course this will bring back the issue. 

I guess this issue can be also caused by another filter installed by antivirus or another vpn client."

 

I work with several VPN clients, and they make some mess with my connections, even Checkpoint or other VPN clients does not work when Forcepoint client is active.

Unchecking the Forcepoint VPN driver on my real physical wi-fi adapter resolved the problem.

 

 

Below is a link to other bridge network problems I've found that could help others too, wich summarizes various solutions.

https://www.minitool.com/backup-tips/vmware-bridged-network-not-working.html

Reply
0 Kudos
shinnok27
Contributor
Contributor
Jump to solution

WIshed I had found this two hours ago. 

Reply
0 Kudos
randomguy2
Contributor
Contributor
Jump to solution

This is the answer.  Beware of other hypervisors and their adapters.  In my case, I also had VirtualBox installed and I had to uncheck its adapter in the VMware Virtual Network Editor program.

Reply
0 Kudos
cyberbabe
Contributor
Contributor
Jump to solution

The culprit for my situation, with VMWare Workstation Pro on Windows 10 Pro, was the vSwitch adapter installed as a feature under Programs and Features. I unchecked the Hyper-V feature and did not uncheck Virtual Machine Platform and Windows Hypervisor Platform, and all was good.  The correct IP address and subnet was as it should be on my network, performed a couple pings, success😊


Reply
0 Kudos
TedChurch
Enthusiast
Enthusiast
Jump to solution

Thanks.  I had a similar problem when I moved my lab PC to a new location with a different IP DHCP network to bridge within.  Also compounding my issue was that my Win10 onboard 1Gb ethernet adaptor failed.  I added a new 2.5 Gb ethernet nic and everything works great again.