Highlighted
Contributor
Contributor

Network Bridge Mode Not Working Windows 10 Host

Jump to solution

Running VMware Workstation Pro 14 (14.1.1 build-7528167). None of my guest VM's can contact my host machine, and my host machine cannot contact the guest machines. This occurs when I'm using bridged mode for the guest NIC's. Other machines on my network can contact the guest VM's and the guest VM's can contact other machines on my network; they also have Internet access. This seems to just be guest to host and host to guest communication issues. If I switch from bridged to host only or NAT it works OK. I've tried to uninstall>reboot>reinstall VMware workstation. I've tried resetting the network settings to default in the Virtual network app. I can see the VMware bridge driver on my host machines physical NIC. I've tried uninstalling and reinstalling it. I've turned off the firewalls on both machines.

1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor

I had a similar problem and found the solution.  I had created a VM with vmware player trial on windows 10 and it worked.  I purchased workstation pro and installed.  When I ran the same VM with workstation, there was no network connectivity at all.  I had network access if I changed to NAT, but not as bridged.  However, I need bridge.

Thanks to GreckiSAS​​I was able to find the solution.

-- Be sure your vm is stopped.

--Run the VMWare Virtual Network Editor

(click start and search for Virtual Network Editor)

-- Run it as administrator (or click the button at the bottom of the screen that says, "change settings." VMNet0 will dislpay when running as administrator. Otherwise, it will not be visible)

-- Highlight VMNet0 and click on "Automatic Settings"

-- You will see a list of adapters. De-select all but the physical network card. (When I set up up with player, I had selected only the 1.  After install of workstation, all of the items were checked.)

-- Click "OK"

-- Click "Ok"

-- Start the VM and test.

View solution in original post

25 Replies
Highlighted
Immortal
Immortal

Open a cmd as admin and run

net stop vmnetbridge

net start vmnetbridge

Sometimes that helps

Regards,

Randhir

If you found my answers useful please consider marking them as Correct OR Helpful

0 Kudos
Highlighted
Contributor
Contributor

Thanks for the tip, it did not work unfortunately Smiley Sad

0 Kudos
Highlighted
Contributor
Contributor

Try this

1. Add Administrator to the local rights group "Network Configuration Operators"

2. And start Virtual Network Editor" and "Restore Defaults"

Good Luck

Fredrik

Highlighted
Contributor
Contributor

Bridged network not working , can't find any working solution.

Screen Shot 04-29-18 at 02.21 PM.PNG

i'am having pretty much the same probleme .
I have tryed to repair the install of my vmware 12 pro then re install , then upgrade to vmware 14 pro and re install open-vm-tools . Still no connection

I have tryed to set my network cart from automatic to      PCIe .. didnt work .
Everything work well on NAT network but bridge is broken , cause of the last update of win 10 ?
Vmnet0 dont get any connection ither

Screen Shot 04-29-18 at 02.22 PM.PNG

when i ping on google dns that's what i'm getting

Screen Shot 04-29-18 at 02.20 PM.PNG

Screen Shot 04-29-18 at 02.25 PM.PNG

If any one is having the same probleme please help me to solve this probleme , i have been looking for the solution during the two last days it's very ennoying .

0 Kudos
Highlighted
Contributor
Contributor

Hi, this is something I lost my respect to VMWare and Microsoft to.

But I found the resolution.

It works when you have installed Workstation, not Player, but I undrestand you have Workstation.

So: if you need bridged connection, simply: remove all others: VMnet1 and VMnet8. Leave VMnet0 and... voila!

Now I am looking for resolution in Player, not Workstation, but I am enormously less stressed Smiley Happy

Good Luck!

0 Kudos
Highlighted
Contributor
Contributor

I had a similar problem and found the solution.  I had created a VM with vmware player trial on windows 10 and it worked.  I purchased workstation pro and installed.  When I ran the same VM with workstation, there was no network connectivity at all.  I had network access if I changed to NAT, but not as bridged.  However, I need bridge.

Thanks to GreckiSAS​​I was able to find the solution.

-- Be sure your vm is stopped.

--Run the VMWare Virtual Network Editor

(click start and search for Virtual Network Editor)

-- Run it as administrator (or click the button at the bottom of the screen that says, "change settings." VMNet0 will dislpay when running as administrator. Otherwise, it will not be visible)

-- Highlight VMNet0 and click on "Automatic Settings"

-- You will see a list of adapters. De-select all but the physical network card. (When I set up up with player, I had selected only the 1.  After install of workstation, all of the items were checked.)

-- Click "OK"

-- Click "Ok"

-- Start the VM and test.

View solution in original post

Highlighted
Contributor
Contributor

Some of my VMs were created 10 years ago and I have been upgrading VMware workstation version.

In version 12, restore default fixed the bridge issue.

in version 14, following GreckiSASI's instruction fixed the issue.

2018-12-06_10-31-08.png

Highlighted
Contributor
Contributor

These things are difficult to diagnose without actually being in front of the machines as important things can be missed. From what you have said the problem is with only the one machine not being reachable. Now if I understand correctly if you use NAT mode everything works but with bridged mode it doesn't. What jumps out at me is 'Firewall rules' as with NAT mode you are using existing addresses but with bridged you'll get new IP addresses via DHCP. So Maybe you need a Firewall rule on the 'host' to allow your new IP addresses through it.

Have fun,

MN

0 Kudos
Highlighted
Contributor
Contributor

grexdevops​ answer [solved] it for me.
Host: Windows 10 Version 1803

Guest: Fedora 29

VMware Workstation 15 Pro, version 15.0.2

Highlighted
Enthusiast
Enthusiast

not for me.  i'm on 1809 and just installed and removed the march cumulative update.  now my lenovo with an attached usb keyboard drops keys or repeats keys.  and nothing i do gets bridged networking back on for my fedora 29 guest.  before this, everything was working.  sigh.

0 Kudos
Highlighted
Enthusiast
Enthusiast

they fixed the stuttering problem but i still don't have networking ("network is unreachable").  this is true for both a fedora 29 guest and a centos 7 guest.  so the problem isn't OS-specific.  i've done all the typical stuff (reset the virtual interfaces) but it had no effect.  i haven't tried to reinstall workstation yet.  in addition to the networking problem, booting fedora 29 doesn't work smoothly.  the login screen doesn't show up unless i pause & restart the VM.  centos 7 works without a problem.

/mark

0 Kudos
Highlighted
Contributor
Contributor

I had the same problem. Bridge mode didn't work on my Win10 host. None of the solutions listed here or mentioned elsewhere worked. Here is how I got it working. The Ethernet network adapter on my host computer was configured for a static IP. When I changed it to DHCP bridge mode worked. The strange thing is that my host was connected to the LAN with WIfi which was using DHCP.  The Ethernet was disconnected but using static IP. I had even set Workstation bridge mode to use the wireless adapter but the unconnected Ethernet with it's static IP was keeping bridge mode from working. I hope this solution helps some others.

Paul

0 Kudos
Highlighted
Contributor
Contributor

Tried a lot of things, but eventually i resolved this problem by removing checkpoint vpn client from my Host. Then i restarted host and it started working.

Now i can ping my VM from host and vice versa with bridged network.

Maybe it can help somenone else.

0 Kudos
Highlighted
Contributor
Contributor

I found the following worked in Windows 10 and Vmware Workstation Version 10. I had to add vmware.exe to the allowed applications in the FW. I then reset the network back and then NAT addressing worked on a CentOS Version 7 VM.

0 Kudos
Highlighted
Contributor
Contributor

Hi ,

May I know   ip configuration details about  your physical and virtual configuration details.

If possible any filters or policies or vlan details.

I believe that the problem is related to network address mostly.

For example ip address, subnetmask, default gateway,network address, vlan address.

The next step will be related to updates, patches, compatibility, hardware issues.

If you apply firewall you can ping but you can't access internet or other networks.

0 Kudos
Highlighted
Contributor
Contributor

maybe help someone,

i have the diferent thing.......

host is  wifi (dhcp), and the bridged mode cant work when vm net use dhcp,

but ,when i change the vm net to a static ip, i can use the internet.

0 Kudos
Highlighted
Contributor
Contributor

I have the same issue working with windows 10 host and several virtual machines bridging over the wifi adapter of my laptop. Doing troubleshooting I install wireshark to see the packets detail. The problem is that the mac address of any virtual machine is using the host mac address (I don't know why) maybe a bug. So for all other pc's working in the same LAN arp mapping for any VM correspond to the mac address of the host. I will try the advice posted here to see if this help and let you know.

0 Kudos
Highlighted
Contributor
Contributor

nothing works, still has the same problem.

0 Kudos
Highlighted
Contributor
Contributor

I has disabled windows firewall and worked for me, now I can see the right mac address for the virtual machines

0 Kudos