VMware Communities
StopyZ
Enthusiast
Enthusiast

Nested does not work

Host:

Proxmox 5.2

Kernel 4.15.17

QEMU 2.11.1

CPU: Xeon E5645

1353036.png

Guest:

Windows Server 2016, without hyper v.

vmware workstation 15

When starting a virtual machine:

photo_2018-10-29_11-04-14.jpg

5 Replies
StopyZ
Enthusiast
Enthusiast

By standard hyper-v is turned off, I did not turn it on.

0 Kudos
StopyZ
Enthusiast
Enthusiast

Running Nested VMs

vmx.allowNested = TRUE

Did not help.

0 Kudos
wila
Immortal
Immortal

Hi,

It's been many years since you had to mess with .vmx settings in order to enable nested features.

I suggest to undo that change and then do the following instead:

- shut down the VM that has the host

- go to settings of that VM

- select Processors on the left side

- put a tick in the checkbox for "Virtual Intel VT-x EPT or AMD-V/RVI"

Select "Save" and boot your VM to try again.

PS: Make sure that your virtual hardware is recent. eg. Workstation 12.x or newer

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
StopyZ
Enthusiast
Enthusiast

Already tried. Also swears at the presence of Hyper v

0 Kudos
wila
Immortal
Immortal

Hi,

Wait I now see that I got confused by what you are intending to run.

You are getting this "Hyper-V" error already at trying to run the Proxmox vm?

In that case the Hyper-V role is enabled at your Windows 10 host and that's where the problem lies, not in the vmx config.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva