dude64
Enthusiast
Enthusiast

NSX on Workstation Pro v15 breaks - Jumbo Frame Lost from v14 it appears

We began to upgrade our Workstation Pro based labs to v15 and have noticed on upgraded computers from v14, that NSX based labs break due to what appears to be loss of jumbo frame support (was hard coded to 1600 in Workstation Pro v14). We're reproduced the problem on two computers so far, and holding off on upgrades until we confirm this. Previously v12-14 of Workstation Pro allowed 1600 byte frames by default on virtual network adapters, but with the upgrade, this now seems to be 1500 bytes. Has anyone else seen this? VMWare, can we get this put back into v15? Thanks, dude64

Tags (1)
0 Kudos
9 Replies
sjesse
Leadership
Leadership

I did this awhile ago, but are you sure it was baked it, I thought I had to manually set the nics mtu to 1600. Here is a guide showing the commands if you want to try

VMware NSX Lab Part 3 VMware Workstation 11 · rharmonson/richtech Wiki · GitHub

"

Open a cmd shell as Administrator and execute netsh int ipv4 show int to display interfaces. Not the "Idx" values for "VMware Network Adapter VMnet1," "VMware Network Adapter VMnet2," and "VMware Network Adapter VMnet3." My installation of Windows 8.1 shows index 19, 20, and 21, respectively. Execute the following to set the MTU.

netsh int ipv4 set int 19 mtu=1600 store=persistent netsh int ipv4 set int 20 mtu=1600 store=persistent netsh int ipv4 set int 21 mtu=1600 store=persistent

"

0 Kudos
Mikero
Community Manager
Community Manager

Thanks for sharing...

Terribly sorry about the experience...We are aware and are currently investigating.

This behavior is unexpected.

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
MattGagliardi
Enthusiast
Enthusiast

Is it still the case that larger (than 1500) MTUs are not possible in VMware Workstation 15?  Same use case as the OP...trying to get an NSX lab going.  I'm running Workstation Pro 15 (v15.1.0 - 13591040) and I'm unable to get larger ping sizes with the "do not fragment" flag working.  VMs are on the same virtual switch/network (so they shouldn't be transiting the host NIC), MTUs set on both ends to be 9000, etc.  The way it's set up it should be working and if I remove the "do not fragment" flag it works fine.  Have tried with an array of sizes and nothing above 1500 goes.

0 Kudos
kgeusens
VMware Employee
VMware Employee

I am running into the exact same issue.

Alternative hypervisors do not seem to have this restriction (but run into other problems that Workstation does not have at all).

Since this was recognized as an issue, is there any timeline to get this fixed? Just imagine sales people in the field going to customers with an NSX-T lab « nested » in Workstation. What more do you need to show off Smiley Wink

0 Kudos
desmondkwh
Contributor
Contributor

I have the problem in Workstation Pro v14. I have enabled the Jumbo frame on the Physical Network Adapter and also use the netsh command to set the Ethernet interface's MTU to 1600. On the ESXi VM Network Adapter, I configured Bridge to the Physical Network Adapter. When I run vmkping, I could not ping the VTEP IP between the 2 ESXi.

However, I tried Fusion 11.5 Pro on Mac with Thunderbolt Ethernet, I don't have any issue to vmkping the VTEP IP between the 2 ESXi running on the Fusion.

What could be the problem?

0 Kudos
kgeusens
VMware Employee
VMware Employee

Hi Desmond,

Support for Jumbo Packets was reintroduced in Workstation Pro 15.5 Smiley Happy

No need for netsh commands, just remember to activate Jumbo Frames in the advanced settings of your network driver on windows.

/Koen

desmondkwh
Contributor
Contributor

Yes Koen, just tried Workstation Pro 15.5. Work like a charm! Smiley Happy

0 Kudos
leechunk
Enthusiast
Enthusiast

Hi, just wanted to share my experience here.

I am using the latest VMware Workstation 15.5.6 on Windows 10 2004.

The VM I am running consists of:

  • NSX-T 3 Manager
  • NSX-T 3 Edge
  • VCSA 7
  • ESXi 7

I have one of the vnic on ESXi7 and Edge connected to a workstation VMnet nic for overlay traffic.

But regardless of the Jumbo frame settings on the VMnet nic, vmkping with size above 1500 will not get a respond from the remote TEP interface.

What I did to make it work is to go to NSX-T manager and change the Global Fabric Settings MTU value. It could be 1600, but change it to something like 9000, and vmkping is now working!

However, you will have to do this every time you reboot your Edge or ESXi.

Could this be a bug?

0 Kudos
seregaknorrr
Contributor
Contributor

Please explain how. I have VMs (esxi hosts) on host only network, and they cannot ping each other TEP interfaces with anything over ~1475 or so. So why this whole "

  • Jumbo frame support: Virtual networks can now be configured with MTU size of up to 9000 bytes."
  • How exactly do I configure my networks in vmware workstation 16.2.3 for MTU size? The setting is nowhere to be found. Certainly it has nothing to do with my own (host) vmnet1 adapter that's not even used when 2 "host only" guest VMs talk to each other...

FYI All. I figured it out. VMXNET3 in vmware workstation doesn't support JUMBO. Period, no matter what you do. I have tried e1000e assigned to my ESXi VMs (edit vmx file) and it works like a charm with 8972 max.

0 Kudos