VMware Communities
LikeVMW
Enthusiast
Enthusiast
Jump to solution

My VMs are always running in background!

I have 2 Windows 7 x64 Virtual Machines, and after upgrading to VMware Workstation Pro 15.0.4, I got this error after opening this 2 Windows 7 machines:

Failed to get exclusive lock on the configuration file. Another VMware process might be running using this configuration file.

After closing this error, I get the "Internal error" and the VM crashes. When I look to my VMware shortcut on my taskbar and It says that 2 VMs are running. When I click to Power Off, Suspend or Pause the VMs, it doesn't change anything. Also, when I open VMware, this VMs aren't running in background.

I opened taskmgr and killed the VMX processes, it didn't work either. I don't know if my other VMs have the same problem (Windows 10, Longhorn, Whistler, Whistler, 98, Neptune, MacOS 10.14 and Android 8), but I don't rescue opening them. If you want to know, here are the symptoms:

Symptoms

*Virtual Machines are always running in the background

*Can't open Virtual Machines

*Don't react to shutdown, pause or suspend

*Can't be killed using taskkill or taskmgr

If you know what's the problem, Please type in comment section to help me or other users.

Reply
0 Kudos
1 Solution

Accepted Solutions
LikeVMW
Enthusiast
Enthusiast
Jump to solution

Solution:

Firstly, kill VMWare tray process by taskmgr or taskkill /IM VMware-tray.exe

Secondly, restart (make sure VMware Tray is enabled for automatic boot)

Then, turn off "Accelerate 3D graphics" in VM's settings.

It should work Smiley Happy

View solution in original post

Reply
0 Kudos
2 Replies
LikeVMW
Enthusiast
Enthusiast
Jump to solution

Also, I have space to run a vm (500 GB HDD and 8 GB RAM)

After some time, I tried to remove and open the vms, no reaction

Reply
0 Kudos
LikeVMW
Enthusiast
Enthusiast
Jump to solution

Solution:

Firstly, kill VMWare tray process by taskmgr or taskkill /IM VMware-tray.exe

Secondly, restart (make sure VMware Tray is enabled for automatic boot)

Then, turn off "Accelerate 3D graphics" in VM's settings.

It should work Smiley Happy

Reply
0 Kudos