VMware Communities
pdilly1980
Contributor
Contributor

Mouse won't work in VMWare Workstation 7.1.4

I am trying to get my mouse to work within my virtual system but it isn't.  I can click on the windows key on the keyboard and it opens the start menu so it obviously detects the keyboard.  I go to the VM menu to install VMware tools but it says "VMware Tools Unavailable" and is greyed out.  I installed Windows XP Professional as my OS and have Windows 7 as my host computer OS, but I am utterly baffled as to what to do from here.  Any tips/solutions would be greatly appreciated!

Reply
0 Kudos
6 Replies
continuum
Immortal
Immortal

very strange
as soon as you can use the keyboard inside the guest the mouse should work too
do you have the same problem with other guests ?

do you use a PS/2 mouse or a USB mouse ?

please attach a vmware.log


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

Reply
0 Kudos
a_p_
Leadership
Leadership

Welcome to the Community,

did you select the correct guest operating system for the VM? Please open the VM's settings and make sure "Windows XP Professional" is selected in the "General" setting in the "Options" tab.

If this is the case run devmgmt.msc from the "Start" -> "Run" in the VM to see whether there are errors.

André

Reply
0 Kudos
continuum
Immortal
Immortal

@ Andre
a msiconfigured guestOS could result in poor mouse behaviour - but not in no mouse at all - at least I have never seen that


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

Reply
0 Kudos
pdilly1980
Contributor
Contributor

Where do I get a vmware log?  I alternate between a usb mouse when I'm in my office and the built in laptop mouse when I'm not.

Reply
0 Kudos
pdilly1980
Contributor
Contributor

I'm also trying to figure out why it says "vmware tools unavailable" and is greyed out under the VM tab.  On the Settings>Options>General, it says Windows XP Professional at the top but underneath is a section of radio buttons that are also greyed out meaning I can't change anything.  It says that the Guest Operating System selected there is "Other", not Windows.

Reply
0 Kudos
pdilly1980
Contributor
Contributor

Ok.  I just reinstalled the image and made sure everything was done right and, so far, everything is working.  I just had to restart from scratch!

Reply
0 Kudos