jeffr1031
Contributor
Contributor

Mouse pointer is hand in VM on Workstation 8

Hello. I purchased Workstation 8 yesterday. I have experience with version 6 and 7. However, I have a problem I have not been able to fix. I built a VM and when I install VMWare tools the mouse pointer turns to a hand inside the VM. It also disappears at times. On the host, it performs as normal. It is only in the VM that it is not working properly. If I uninstall VMWare tools the mouse pointer works properly within the VM as well. I have reinstalled the tools and looked at process priorities. So far, I cannot figure out the cause.

I have version 8.01 build-528992.


Has anyone else seen this or have any suggestions?

0 Kudos
8 Replies
jeffr1031
Contributor
Contributor

I have more information. I was seeing the hand when I connected via RDP to my workstation which has Workstation 8 installed. If I logon directly to the workstation, the mouse pointer works properly in the VM.

I did not have this problem in 6 or 7. Not sure why it would have problems with the mouse pointer in a RDP session.

0 Kudos

Facing the same cursor problem. Dying to know the solution.

~GaneshNetworks™~ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".
0 Kudos
banackm
VMware Employee
VMware Employee

Try putting the line "mks.noHostCursor = TRUE" in your vmx file.

It might make your cursor respond a little slower over the network, but it sometimes fixes weird cursor issues.

jeffr1031
Contributor
Contributor

Thank you for the response. Can you tell me where the vmx is located?

0 Kudos
Naki
Enthusiast
Enthusiast

Wherever your Guest OS files are.

What is your Host OS? What is your Guest OS?

mxwllmcly
Contributor
Contributor

That worked... However as you said it slows it down alot! Thanx for the temp fix tho Smiley Happy

-Max

0 Kudos
mxwllmcly
Contributor
Contributor

If you haven't changed the location of where you VM's are then to find the default location go to Edit > Preferences > Workplace and it will be the first thing in the Window labeled "Default location for virtual machines".

-Max

0 Kudos
jeffr1031
Contributor
Contributor

I apologize for my slow response. Thank you for the responses. This corrected the problem.

0 Kudos