chaossysten
Contributor
Contributor

Mouse flicker in guests

Hello,

Recently all my guest VMs have started to have a weird mouse flicker. This happens even when in the install page for Ubuntu or PopOS, and continues to happen on a fresh install after installing open-vm-tools-desktop.

It didn't use to happen (about a month ago). Curious if anyone has any suggestions on what might be wrong here. I have tried "optimize" for games but while that setting seems to solve the flicker, the input gets really sluggish and unusable. It seems to be a VMware problem though since it happens on any guest (at least Debian based guests that I've tried)

PS: I tried to screen record this but oddly enough the behaviour doesn't appear in the screen recording. What this actually looks like is whenever you are moving the mouse the mouse disappears, when you stop moving or slow down it appears again. So as you move your mouse around you observe flickering as the mouse appears and disappears.

Thanks!

74 Replies
pavva
Contributor
Contributor

@hahakiki2010 @mks.dx11.disableFlips=TRUE has no effect. Still flickering

0 Kudos
mmassico
Contributor
Contributor

In the Ubuntu guest, I created a new "/etc/X11/xorg.conf" text file that disables the "HWcursor" option and it works, no more mouse cursor flickering!

--- FILE : /etc/X11/xorg.conf ---

Section "ServerLayout"
    Identifier "X.org Configured"
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
EndSection

Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
    ### <percent>: "<f>%"
    ### [arg]: arg optional
    Option "HWcursor" "off" # [<bool>]
    #Option "Xinerama" # [<bool>]
    #Option "StaticXinerama" # <str>
    #Option "GuiLayout" # <str>
    #Option "AddDefaultMode" # [<bool>]
    #Option "RenderAccel" # [<bool>]
    #Option "DRI" # [<bool>]
    #Option "DirectPresents" # [<bool>]
    #Option "HWPresents" # [<bool>]
    #Option "RenderCheck" # [<bool>]
    Identifier "Card0"
    Driver "vmware"
    BusID "PCI:0:15:0"
EndSection

IgorDen
Contributor
Contributor

For me and probably everybody it happened after update of nvidia drivers in december. U can try to downgrade video driver and this flickering disappears. It's stange thing. When u moving mouse display does not redrawing but it's not problem with cpu utilization or 3d acceliration. It's pure problem of nvidia driver and vmware compatability. Can't understand how to fix this. Sometimes disabling nvidia expirience overlay helps sometimes not.

0 Kudos
IgorDen
Contributor
Contributor

Can u explain some? I added this config and now it's 2 mouse pointer at screen) What is wrong?

0 Kudos
yblatti
Contributor
Contributor

Same here, fresh install

Host:
Intel Core i7 6700K + RTX 2080 (driver 461.09)
Windows 10 Pro, 64-bit (Build 19042.746) 10.0.19042
VMware® Workstation 16 Player
16.1.0 build-17198959

Guest:
Ubuntu 20.04.1 LTS
Gnome 3.36.8 using X11
Graphics (seen from Ubuntu) : SVGA3D; build: RELEASE; LLVM;
Tools :

apt list --installed | grep "\-vm"
open-vm-tools-desktop/focal-updates,now 2:11.1.5-1~ubuntu20.04.2 amd64 [installed]
open-vm-tools/focal-updates,now 2:11.1.5-1~ubuntu20.04.2 amd64 [installed]
xserver-xorg-video-vmware/focal,now 1:13.3.0-3 amd64 [installed,automatic]

 

0 Kudos
charmainel
VMware Employee
VMware Employee

 

FYI, the flickering issue with Fedora KDE is already fixed and is available in Mesa 20.2.3 or later.

0 Kudos
gysi
Contributor
Contributor

Hey guys, I have the same issue on Ubuntu 20.04.2 guest with Windows 10 after updating my NVIDIA graphics driver. 
Restarting the host seems to fix the issue for some hours, but then it appears again out of no where.

0 Kudos
gysi
Contributor
Contributor

 

Section "Device"
    Option "HWcursor" "True"
    Identifier "Card0"
    Driver "vmware"
    BusID "PCI:0:15:0"
EndSection

 

This works. The mouse then keeps flickering but only very rarely

0 Kudos
IgorDen
Contributor
Contributor

Problem not in flickering itself. Problem is in lagging rendering frames. It prevent screen redrawing when mouse move and flickering.

0 Kudos
gysi
Contributor
Contributor

Have you tried to disable nvidia overlay or deactivate settings in NVIDIA Control Panel -> 3D Settings?

0 Kudos
IgorDen
Contributor
Contributor

it has no effect. Sometimes it works normal, sometimes not. But it work 100% good if I downgrade nvidia drivers for pre december version.

0 Kudos
gysi
Contributor
Contributor

Ok my Workaround is now to use the xorg.conf with:

Option "HWcursor" "False"

Problem is that you then have two mouse pointers. I created a invisible mouse theme for ubuntu:

https://github.com/gysi/ubuntu-invis-cursor-theme

Using that you only have one mouse pointer. 

The only problem I have is that the mouse pointer always stays the same... but for now I can live with it.

0 Kudos
alwayseh
Contributor
Contributor

UPDATE: The issue persists, even after the NVidia graphics driver update. It just took a few hours for it to show up again.

Surprisingly enough, updating my NVidia graphics driver to the latest version (released Feb. 10, 2021; version 461.40) fixed the issue for me, without any of the other suggested fixes in this thread!

My version of VMWare and nVidia driver:

  • VMware® Workstation 16 Pro, 16.1.0 build-17198959
  • nVidia GeForce Game Ready Driver, Version: 461.40, Release date: 01/26/2021

 

UPDATE AGAIN: Looks like the issue is resolved for me. Either through the latest Workstation update (16.1.2 build-17966106) or NVidia graphics driver version (Version 466.77).

mmassico
Contributor
Contributor

I recently updated VMware and my nVidia driver (see versions below). I removed the HWcursor "off" option in the "xorg.conf" and used my virtual machine for about a week. With the latest nVidia driver (and/or the latest VMware Player), it would appear that the problem is fixed!

  • VMware® Workstation 16 Player, 16.1.0 build-17198959
  • nVidia GeForce Game Ready Driver, Version: 461.40, Release date: 01/26/2021
0 Kudos
yblatti
Contributor
Contributor

Updated my NVIDIA Drivers to : 461.40 (from 461.09 which was failing)

Problem fixed !

0 Kudos
gysi
Contributor
Contributor

@mmassico 
I already had these exact versions. My Problem still persists 😕

I think the problem appears together with the following settings in the vmx file:

mouse.vusb.enable = "TRUE"
mouse.vusb.useBasicMouse = "FALSE"
usb.generic.allowHID = "TRUE"
0 Kudos
dperez83
Contributor
Contributor

I have the problem and I have only the integrated video card Intel Iris Xe Graphics with driver version 27.20.100.9168.

Vmware 16.1.0 build-17198959
Windows 10 x64 20H2 (build 19042.804)

 

0 Kudos
mmassico
Contributor
Contributor

@gysi  

I also have the following settings in my vmx file:

mouse.vusb.enable = "TRUE"
mouse.vusb.useBasicMouse = "FALSE"
usb.generic.allowHID = "TRUE"

With the latest nVidia drivers, I was able to reproduce the mouse cursor problem after one week. ‌‌😕

 

0 Kudos
FedericoM
Contributor
Contributor

Since I'm facing the same issue with Kubuntu (plasma) 20.10, I want to thank you for the help, it works better but still have problem:
desktop background vanish and turn into black .. pieces of desktop are around .. it sucks.

Tags (1)
0 Kudos
sesopenko
Contributor
Contributor

I'm running:

  • vmware workstation pro 16.1.0
  • Host: Windows 10 Pro 20H2
  • Dual monitor Host, dual monitor enabled in guest.  Both host monitors set to 240hz.
  • nVidia drivers 461.72 (latest) and GeForce 3080
  • Ubuntu 20.04 Desktop guest

I've disabled the hardware cursor, and it didn't resolve the issue. The mouse flickers whenever it moves 1 pixel or further.  Fast movements across the screen practically render the cursor invisible which hints at it having a delay before redrawing the cursor in the new position.

Reducing the host monitor refresh rates to 60hz each doesn't resolve the flickering.

0 Kudos