xopher8713
Contributor
Contributor

Mouse click not working Workstation Pro 14.1.1 build - 7528167

Jump to solution

This was working prior to a PC upgrade. I went from a Asrock z77 Extreme 4 motherboard with 16GB of memory and an Intel i5 3570k, to a Gigabyte Z370XP SLI motherboard 16GB of memory and an Intel i7 8700. I transferred my drives, did a fresh install of Windows 10 Pro Version 1709 (OS Build 16299.251), My VMs reside on a secondary storage drive so I opened them in workstation. I have tried reinstalling VMware Workstation, recreating the preferences.ini located in %USERPROFILE%\Application Data\VMware\, recreating the virtual machine and reinstalling vmware tools. I checked another VM and encounter the same issue. So I can CTRL+ALT to break input to the host and it will allow me to click one time, after that it acts as if the mouse buttons are not working. Has anyone ran into this or does anyone have anything I can try? Any help will be greatly appreciated.

Thanks

1 Solution

Accepted Solutions
peypey0212
Contributor
Contributor

Your overlays are not a superstition, I had downloaded Fraps and enabled the FPS counter in the settings. Then after seeing your post I decided to close Fraps and try it again and what do you know, it worked!

View solution in original post

34 Replies
solarorder
Contributor
Contributor

I have the exact same issue. Jumping in on the thread to hopefully get an answer. To add to things already tested, I have tried other mice, other USB ports, configuring the vmx files on the machines, creating the VMs from scratch, even down to updating the VMWare tools on the guests. It happens with every OS I install.

0 Kudos
T68
Contributor
Contributor

Sadly, I had the same problem - once leaving the VM window, after a certain amount of time, clicking back into the window registers no mouse clicks. I scoured the web for all possibilities and I tried every one I found and none worked. The only thing that DID work, was downgrading back to 12.5.7. Once doing that, I haven't had a mouse issue. I've been doing periodic searches to see if any definitive fix has happened and so far I haven't seen anything. So I'll keep running this version for now.

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

Do you have any mouse related software installed on your host operating system, such as TouchpadBlocker or WizMouse or anything similar? That software might interfere with mouse events. If yes, can you try uninstall them and see if Workstation works well? Thanks a lot!

0 Kudos
xopher8713
Contributor
Contributor

There are no additional mouse or input software installs that interfere with it. I actually tried installing the software that came with my mouse to fix the issue and it was no help but also no change.

0 Kudos
TracyHuang
Enthusiast
Enthusiast

Did you try with changing Edit-> Preferences-> Input -> Optimize mouse to automatic/always? does it help?

Besides, would you please provide more details: What's the GPU type and driver? What's the VMs you used, are they existing or new installed VM? And please upload the vmware.log of the VM (location info Help -> About VMware Workstation)? What's mouse type? How many monitors you connect to host and what's the layout? Thanks!

0 Kudos
vanRijn
Hot Shot
Hot Shot

There's another similar thread that's been going for quite a while, although the title is a bit misleading. VMware workstation 14 Pro loses Mouse Focus  The mouse doesn't lose focus... the problem there is mouse clicks stop working.

0 Kudos
xopher8713
Contributor
Contributor

Tried changing the optimize mouse and that makes it completely unuseable

 

The GPU is the same as prior hardware a XFX R9-280X with driver version 15.30.1025.1001-151129b-297237E I have 3 Asus Monitors connected, 1 144Hz in the center and 2 60Hz on each side.

 

Mouse is a corsair vengeance m65, I have tried with corsiars software and without

 

This happens in any vm used old and new. I have tried Ubuntu 16.04.3, Kali 2018.1, Windows Xp, Windows 10, and Windows Server 2016 Data Center

 

 

Here is the most recent log for Ubuntu 16.04.3

Moderator edit by wila: Moved log to an attachment

0 Kudos
xopher8713
Contributor
Contributor

I am unable to navigate the support section of vmware.com, so since I need this to work on stuff I have downgraded to 12.5.9 and the issue does not persist. I then hit up vmware on twitter and see if they can get someone to look at it. Judging from the link to the other forum post I am not the only one with this issue and honestly if I am paying for software it should work or be in the process of being fixed.

0 Kudos
xopher8713
Contributor
Contributor

I still have gotten no where this is a fail on vmware.

0 Kudos
itspec56
Contributor
Contributor

I have the same issue. Mine was originally working fine and just suddenly my mouse clicks were no longer recognized. I don't have any of the programs mentioned below installed. I am using a Surface Pro 4. I can also say that if the VM is running in ESXi on this same laptop I don't have an issue

0 Kudos
Eliforp
Contributor
Contributor

Hi everyone.  I have been running into this issue just like xopher8713, ever since I built my new PC in December 2017.  I have only tested VMware 14.0 and 14.1.1, but here is what I've learned from searching tirelessly (actually, it made me really tired).  Last night I found some culprits.

  • Realtek Audio drivers:  Some say removing these and letting Windows use the default Microsoft HD Audio driver will fix it.
    • You might have noticed this happens a lot more when the VM or your PC thinks it should make a sound.
    • Let the new drivers install from Windows Update
    • It doesn't matter if you are using an add-in card... the drivers still cause issues.
    • If you aren't using the Realtek audio (maybe you have a Sound Blaster AE-5 or something), disable it in your BIOS.
      • This might have contributed to my problem.  I don't use the Realtek audio anymore, but still have the driver installed.
      • Some say it fixed their problem.
  • X-Split:  While running XSplit Broadcaster, this issue will arise...as in the second it can display your VM window.
    • Closing XSplit will immediately let your mouse function again as normal.
    • I spoke with XSplit and they are going to check it out on their end.
      • This was my main instigator.
  • Override high DPI scaling behavior:  One article I read stated that if you go into the VMware workstation properties, clicked the compatibility tab, and then selected the Override radio button, that the issue would disappear.
    • This didn't help me, but maybe it will help you.

  • Overlays... This is not bold because it is just my suspicion.
    • XSplit let me select the screen and/or the VMware Workstation Pro window for screen capturing/video recording.
      • I am curious if screen capturing creates an invisible overlay which still allows your to move the mouse, but is in the way of clicks.
    • More research would need to be done to determine this.

I hope one of these helps you all out.  It is a pain to switch mice, delete all VMware references in the registry and from your hard drive, uninstall it, reinstall new versions, reinstall old versions, etc. only to find that nothing helps and that support for this problem is limited to none at the current moment.  Of course, it is hard to correct a problem if nobody knows how to make it happen.  My post should solve that.  Using XSplit Broadcaster, I can duplicate the problem instantly.  If I close it, problem solved.

I realize many of you are not using XSplit or other screen capturing/recording software.  Your may have an app installed which creates that overlay effect I was speaking of though, in which case, I think the problem would still occur.

Want to see something more annoying?  Change tabs, then change back to the program and you will have earned 1-2 clicks before it fails again.

Etched
Contributor
Contributor

I've experienced this intermittently since upgrading to Workstation 14 and until tonight I was always able to get things working by rebooting the Host machine. That's not working anymore. I get approximately ONE second of clicking after the VM grabs input. I can press CTRL+ALT to take focus away from the VM then click on it again to get another click or two if I'm very quick. As a workaround, I'm connecting to the VM through Workstation's integrated VNC support. I absolutely shouldn't have to do this but it is effective. Tried uninstalling and reinstalling VMware tools on one VM. Tried uninstalling Workstation 14.1.whatever and went back to 14.0. The problem persists and affects all VMs.

It would probably help bring attention to this if everyone who has this problem too actually clicked on the button that says "I have this question too" under the original post.

The 17 feet of log files posted is not helpful, just aggravating.

0 Kudos
peypey0212
Contributor
Contributor

Your overlays are not a superstition, I had downloaded Fraps and enabled the FPS counter in the settings. Then after seeing your post I decided to close Fraps and try it again and what do you know, it worked!

View solution in original post

Etched
Contributor
Contributor

Damn! That did it for me. Didn't even occur to me that the problem became persistent after setting fraps to startup at login. Killed fraps and the problem is instantly gone! for now ... Dun dun DUN!

0 Kudos
banackm
VMware Employee
VMware Employee

Is the issue that the mouse-clicks stop, or that the entire guest console display freezes?  Like, can you still see things updating on the guest screen in the local window when this occurs?

If you see a total screen freeze, does it still happen if you disable 3D on your VM?  (You'll have to do a full VM PowerOff/PowerOn for that to take effect, suspend/resume or rebooting is not sufficient.)

We've been chasing this as a mouse issue in line with some of our other mouse issues, but it's possible some of you are actually running into a graphics problem.  Because Fraps and other screen capture/overlay software don't normally do much to the mouse stack, but do interfere with the graphics side of things.

0 Kudos
z3razerviper
Contributor
Contributor

I am on windows 10 build 1803 and now i am getting a freezing vm when i use my mouse in the vm. Its like the whole vm is pausing. Its not every mouse click but say every 20th. and it freezes for say 5 seconds.

0 Kudos
Etched
Contributor
Contributor

@bm The VM operates normally, keyboard input registers fine, and the mouse movement registers, it's simply clicks that stop registsering about a second after input is grabbed. So if I press the Win key, the VM's start menu pops up, and the highlight follows my cursor as I move it over the start menu items, but I can't click on anything to launch a program or whatever. If I press CTRL+ALT to release input from the VM, then click rapidly to grab input and select an item it works but the VM stops registering clicks within a second or so.

Disabling 3D acceleration for the VM does not affect the problem when Fraps is running. Killing Fraps immediately resolves the issue weather the VM has 3D acceleration enabled or not.

0 Kudos
charlielewis
Enthusiast
Enthusiast

I don't have Fraps, but do have ShareX; it seems to be happening the same way, since it's a screen capture utility.

0 Kudos
peypey0212
Contributor
Contributor

If you switch back into your VM does it allow for a couple of clicks then stop? If it does then you probably have an overlay open, like:

  • Fraps
  • Shadowplay
  • Overwolf
  • Discord
  • OBS, etc.

did a fresh install of Windows 10 Pro Version 1709 (OS Build 16299.251)

Did you have the Game Bar disabled on the previous install of Windows 10?

If you did then try disabling the Windows 10 game bar:

Go to the settings app in the Windows start menu

     -> go to Gaming

          ->then Game Bar

               ->Then turn off "Record games clips, screenshots, and broadcasts using Game bar"

Restart and see if the problem persists.

0 Kudos