Grogan
Enthusiast
Enthusiast

Linux Vmware Workstation 6.5.1 Cannot install on a system with KVM enabled

I am trying to install Workstation 6.5.1 using the .bundle. Of course, KVM is not enabled. I have never enabled that in my kernel. I cannot tell what the installer is looking for, or I'd try to mitigate it.

I have searched around here and I can't find any information on this problem (I am assuming the search is working correctly but I find it hard to believe that I can't find any info on KVM in discussions here)

I have tried running the installer with the -I switch to ignore script errors, but it doesn't ignore that condition. I know for a fact that I do not have KVM enabled in kernel or as a module so if I can somehow bypass that check all should be well.

I have been using VMware workstation for several years and 6.0.x works on this system. No, it's not a "supported system". I don't expect extensive support, just a clue.

Can anyone tell me what condition the installer is barfing on, how it's checking for the KVM driver, or how I can debug this? I really don't want to stick with Workstation 6.0.x because I want to use a newer kernel than it supports. I also want to run a Windows 7 guest, and the Vmware SVGA II driver doesn't work.

Currently I have tried this with Linux 2.6.23.17 and Linux 2.6.26.8 but I don't think that matters at this stage of the installation. I accept the Eula, I click next when prompted for the path to Eclipse (I dont' have it) then it tells me it's ready to install. I click Install and I am instantly presented with "You cannot install on a system with KVM enabled" and it aborts.

Here is the contents of /var/log/vmware-installer:

Using UI type gtk

Opening database file /etc/vmware/database

destination /tmp/tmpL4hOHe/.installer/__init__.py already exists, overwriting.

destination /tmp/tmpL4hOHe/.installer/__init__.py already exists, overwriting.

destination /tmp/tmpL4hOHe/.installer/__init__.py already exists, overwriting.

destination /tmp/tmpL4hOHe/.installer/__init__.py already exists, overwriting.

destination /tmp/tmpL4hOHe/.installer/__init__.py already exists, overwriting.

Top level exception handler

Traceback (most recent call last):

File "/tmp/vmis.OTgeAN/install/vmware-installer/vmis/core/transaction.py", line 267, in RunTransaction

txn.Run()

File "/tmp/vmis.OTgeAN/install/vmware-installer/vmis/core/transaction.py", line 55, in Run

self.get()()

File "/tmp/vmis.OTgeAN/install/vmware-installer/vmis/core/common.py", line 65, in Show

i.Initialize(txn.temp)

File "/tmp/vmis.OTgeAN/install/vmware-installer/vmis/core/install.py", line 234, in Initialize

self._installer.InitializeInstall(**self.args)

File "/tmp/tmpL4hOHe/.installer/vmware-player.py", line 42, in InitializeInstall

raise InstallError('You cannot install on a system with KVM enabled.')

InstallError: You cannot install on a system with KVM enabled.

0 Kudos
11 Replies
Grogan
Enthusiast
Enthusiast

So... nobody can tell me anything about this? A misleading error message from a dumbed down installer is all I get? KVM isn't the problem at all, it's obviously the installer.

Well, I might as well mark this question as answered because I solved my own problem. I switched to VirtualBox, which is far more Linux friendly. You don't hear them whinging about supported distributions and kernel versions.

0 Kudos
louyo
Virtuoso
Virtuoso

Well, I am glad to hear that you are happily VM'ing.

Keep in mind that this forum is about users helping, or trying to help, other users, although VMWare folks do chime in from time to time. I have not seen or heard of your problem, so I did not respond.

Did you file a support ticket with VMWare? That should give them the data they need to reproduce (and correct) the problem.

Lou

0 Kudos
daddri
Contributor
Contributor

Hi all!

I've go the same problem. When trying to install Workstation 6.5.1 .bundle package in my Fedora 10 x86_64 with kvm machine.

I've stopped libvirt service and deleted the qemu connection but Workstation still can't be installed so I suppose it may be with something about the software I've got installed. Anyway using kvm works fine.

0 Kudos
Grogan
Enthusiast
Enthusiast

Thanks for replying, louyo. I appreciate it. In the old days, one used to post in the forum and VMWare folks did indeed read and respond to the posts. I would imagine it's difficult for anyone now because of the level of organization of these forums. The old forums were easier to navigate.

0 Kudos
Grogan
Enthusiast
Enthusiast

Daddri, your situation is probably legitimate because you DO have KVM enabled. The business end of it is the kernel support (usually compiled as a module)

Type the lsmod command, and see if a module named kvm is loaded in your kernel. I'm not sure if rmmod kvm would be enough for the check the installer does, but you could try that first.

0 Kudos
ksc
VMware Employee
VMware Employee

It's the KVM kernel module - I don't know exactly what the installer does, but I suspect it's "lsmod | grep kvm" or something like that. Doesn't matter if KVM software is installed, it only matters if the kernel module is loaded.

If you want to disable kvm on bootup, look around in /etc/modprobe.conf or /etc/modprobe.d/blacklist (the exact way would be distro-specific).

VMware switches in and out of root mode each time so as to not conflict with other virtualization software. KVM likes to hang onto the virtualization root mode aggressively for a minor performance gain. For comparison, Parallels hangs on to the root mode but detects other virtualization software and lets go when it detects a conflict. Until KVM becomes more compatible with other software, our installer will detect KVM and actively try to prevent you from getting into this situtation.

0 Kudos
CharlieM
Enthusiast
Enthusiast

It's the KVM kernel module - I don't know exactly what the installer does, but I suspect it's "lsmod | grep kvm" or something like that. Doesn't matter if KVM software is installed, it only matters if the kernel module is loaded.

If you want to disable kvm on bootup, look around in /etc/modprobe.conf or /etc/modprobe.d/blacklist (the exact way would be distro-specific).

VMware switches in and out of root mode each time so as to not conflict with other virtualization software. KVM likes to hang onto the virtualization root mode aggressively for a minor performance gain. For comparison, Parallels hangs on to the root mode but detects other virtualization software and lets go when it detects a conflict. Until KVM becomes more compatible with other software, our installer will detect KVM and actively try to prevent you from getting into this situtation.

IIRC, there was an issue where unloading the KVM module was not enough, as it forgot to 'let go' of root mode when it was unloaded. I don't think that bug lasted long, but it's something to watch for; just be sure your distro is up to date.

0 Kudos
daddri
Contributor
Contributor

Thank you!

Yes I've done lsmod as you've said and here goes the lines that contain something about kvm:

kvm_intel 52944 0

kvm 137464 1 kvm_intel

Anyway I think I'll wait before installing vmware... because I'm not skilled with the command line and I'm afraid of crashing everything... Smiley Happy

Thanks in advance!

0 Kudos
Grogan
Enthusiast
Enthusiast

Make sure it's not in use (don't be running qemu)

rmmod kvm_intel kvm

It shouldn't crash anything. If it does, the worst that would happen is that you will have to reboot.

0 Kudos
daddri
Contributor
Contributor

Thank you Grogan. It did the trick and I have arrived to install it.

But... I have tried to launch it an nothing happened! I have turned off Selinux (I have disabled it) an enabled the VMware service in 'system-config-services'.

At the boot time, it says 4 services marked in red of vmware failed to start... So I've launched vmware from the shell and this is the output:

$ vmware

Logging to /tmp/vmware-adrian/setup-3669.log

modinfo: could not find module vmmon

modinfo: could not find module vmnet

modinfo: could not find module vmblock

modinfo: could not find module vmci

modinfo: could not find module vsock

modinfo: could not find module vmmon

modinfo: could not find module vmnet

modinfo: could not find module vmblock

modinfo: could not find module vmci

modinfo: could not find module vsock

/usr/bin/vmware: line 31: 3669 Violación de segmento "$BINDIR"/vmware-modconfig --appname="VMware Workstation" --icon="vmware-workstation"

then i found in fedora forums, to remove the old binary modules:

mv /usr/lib/vmware/modules/binary /usr/lib/vmware/modules/binary.old

and rebuild it again:

vmware-modconfig –console –install-all

And now It works!

Thanks Grogan!

0 Kudos
Grogan
Enthusiast
Enthusiast

Good work, I'm glad you got it sorted. Yes, some of these distros think they are doing you a favour by providing binary modules. The problem is they are usually too old to be of much use. The same with the Nvidia driver... who wants to use an old driver? Because they put them in a different subdirectory, they don't get replaced.

Now, if you don't want those kvm modules to load at every boot, you should be able to black list them in /etc/modprobe.conf (I don't know what mechanism is being used to load them, possibly udev when an event calls for them, or possibly in the startup scripts for qemu services). However, I would hope that the following would be honoured in /etc/modprobe.conf.

blacklist kvm_intel

blacklist kvm

The second line may not be necessary. (kvm may just get loaded as a dependency for kvm_intel)

Actually, while that should still work, I just did a search and the proper way to blacklist modules in Fedora (8 or higher) is to add the lines to the /etc/modprobe.d/blacklist file. Same as shown above.

0 Kudos