agborroland
Contributor
Contributor

Kernel-header problem on CentOS 7

Hello!

I am trying to install VMware 8.0.6 (VMware-workstation-full-8.0.6-1035888.86_64.bundle) on a CentOS 7 server with the following properties;

Memory: 3.6GiB

Processor: Intel Core i3-4000M CPU @ 2.4GHz x 4

Graphics: Intel Haswell Mobile

GNOME: Versin 3.28.2

OS Type: 64-bit

Disk: 315.7 GB

Server is up to date and kernel-devel and kernel-headers installed. When i launch the VMware using the the command # vmware on the command line, i get this message that shows up (image of problem is attached). I have spent time trying to figure out why but i can't still get it fixed.

Please any help will be appreciated!

0 Kudos
4 Replies
wila
Immortal
Immortal

The VMware Workstation version that you are trying to use here is too old.

It simply does not know what to do with that kernel as it has changes made after VMware Workstation 8 was retired.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
agborroland
Contributor
Contributor

Thank you Wlla!

I understand your response. I have tried versions up to 10.0.1, it gives the same problem.

Only Versions 12.0.1 and above in my case that does not give me give me that problem. And when it finally installs, the HSNM hotspot manager i run in it freezes after some time of functioning and i get the message found in the attach image.

Thank you for checking on this as well!

0 Kudos
scott28tt
VMware Employee
VMware Employee

Moderator: We don't need multiple threads with that same issue, please update just the one that is NOT locked: Properties of machine to buy to run VMware player!


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
wila
Immortal
Immortal

@Scott I kind of understand your reasoning on the lock, but they are 3 different questions.

However TS supplied the same info to every topic. It is why I replied to each of them and figured not to lock them. 2 topics should be enough though Smiley Happy

@agborroland The error is a hardware issue as mentioned earlier. You can get VMware Workstation 12.x and up to run on your centOS because of the kernel version, older versions don't work unless you apply some custom patches to match the kernel headers. (The most popular patch set down here would be https://github.com/mkubecek/vmware-host-modules but from the looks of it, it is VMware Workstation 12.x and up)

The reason why a hardware error shows up only with VMware Workstation is because VMware Workstation is more taxing on your hardware, it will try to use all available hardware resources and as such it is easier to trigger any hardware issues you might have when running your VM.

Your "machine check error" partial screenshot is not detailed enough to be able to help you.

We need some logs that has the machine check -with details- in it, in order to be able to assist.

If you want us to have a look then please attach the files /var/log/messages and /var/log/dmesg from your host and tell us around what time the machine check happened.

Make sure you attach the log files that have this time frame!

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos